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Introduction to XD3 

Mirada Medical’s XD 3.6 is a software application designed for the rigid and deformable registration of 

medical image datasets including PET, CT, MR, and SPECT as well as nuclear medicine planar, planar WB 

and planar dynamic. Additionally, XD3 provides powerful image viewing capabilities including series 

image review, region quantification and tracking and a customizable reporting tool. 

XD3 is available in both Standard and Advanced tiers. This user documentation provides instruction for 

the Advanced Tier. Some functionality described may not be available to you, depending on the license 

tier you have installed. The following table lists differences in the two tiers. 

Feature Standard Advanced  
Follow up scan comparison Yes Yes (unlimited) 

Support for 4D (gated) data No Yes 

Support for multi-sequence MR No Yes 

Support for multi-phase, multi-time point CT No Yes 

Support for multiple time points No Yes 

Rigid Fusion of images Yes Yes 

Deformable fusion of images No Yes 

Three way fused views No Yes 

Advanced modality optimized deformable image registration No Yes 

Save regions as RTSS Option Yes 

Load and display RTSS Option Option 

Export rich fusion viewer to disk Option Yes 

Save state, bookmarks, ROIs rulers to PACS Yes Yes 

Derive ruler from ROI Yes Yes 

CT-specific segmentation Option Option 

Export region voxel values No Yes 

 

Review Mode Standard Advanced 
General Fusion Yes Yes 

General Oncology Review Yes Yes 

Basic NM Review  Yes Yes 

PET Review Yes Yes 

PET/CT Whole Body Review Yes Yes 

Single Volume Review Yes Yes 

Head/Neck Review No Yes 

Melanoma Review No Yes 

MR/PET/CT No Option 

New in XD 3.6 
The following are some of the key features that have been added to the application in this release: 

• CT-specific segmentation tools. 
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• RTSS Import 

• Fast navigation mode using the right mouse button 

• Create Multiple Thresholds Region 
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Regulatory Statement 

Device Classification 
Class II (Picture Archiving and Communications System) device with reference to Section 892.2050, 

Product Code: LLZ Image Processing System. 

Intended Use 
XD3 is intended to be used by trained medical professionals including, but not limited to, radiologists, 

nuclear medicine physicians, and physicists. 

XD3 is a software application intended to display and visualize 2D & 3D multi-modal medical image data. 

The user may process, render, review, store, print and distribute DICOM 3.0 compliant datasets within 

the system and/or across computer networks. Supported modalities include, static and gated CT and 

PET, and static MR, SPECT and planar NM. The user may also create, display, print, store and distribute 

reports resulting from interpretation of the datasets.  

XD3 allows the user to register combinations of anatomical and functional images and display them with 

fused and non-fused displays to facilitate the comparison of image data by the user. The result of the 

registration operation can assist the user in assessing changes in image data, either within or between 

examinations and aims to help the user obtain a better understanding of the combined information that 

would otherwise have to be visually compared disjointedly. 

XD3 provides a number of tools such as rulers and region of interests, which are intended to be used for 

the assessment of regions of an image to support a clinical workflow. Examples of such workflows 

include, but are not limited to, the evaluation of the presence or absence of lesions, determination of 

treatment response and follow-up. 

XD3 allows the user to define, import, transform and store and export regions of interest structures and 

dose volumes in DICOM RT format for use in radiation therapy planning systems. 

Cautions 
The device presents medical image information, acquired from scanner systems, which can be used as 

part of a clinical diagnostic process, in particular for the diagnosis, staging, treatment assessments and 

follow up of disease. The clinical diagnostic process uses many other sources of information to form the 

assessment of the condition of the patient, including blood tests, clinical examination, case history and 

genetic profiles. The information that medical imaging provides, as presented by XD3, is a complement 

to these standard methods. XD3 should not therefore be solely used to directly drive a clinical decision 

making process. 

Prescription Statement 

Caution: Federal law restricts this device to sale by or on the order of a licensed healthcare practitioner. 
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Computational Performance 

Unless explicitly agreed to by Mirada Medical, no responsibility is taken for the duration required to 

perform functions within the software environment. Specific performance requirements can only be 

agreed to if the product is delivered on Mirada Medical specified hardware. 

Accuracy 

The actions of the user may directly affect the accuracy of functions within the software environment. 

Therefore it is the responsibility of the user to determine if the results of image visualization are 

satisfactory. 

Reporting 

While the device is a quality product, manufactured under a rigorous quality control program, it is not a 

secure repository for clinical reports. Any comments, images or annotations compiled into any form of 

report and provisionally stored by the software environment are at the user’s risk. No responsibility is 

taken by Mirada Medical for damaged reports, incomplete record manipulation, storage/retrieval 

problems or network-based security issues unless specifically agreed. 

Security 

The software tool may, by virtue of its usage, contain confidential patient information. The security and 

configuration of the computing hardware used to execute the software is the responsibility of the end-

user. This includes secure imaging local area networks (LANs), appropriate fire-wall provision, network 

directory permissions, etc. 

Printing 

Mirada Medical takes no responsibility for the faithfulness or quality of a generated hard-copy result of 

a printing device not supplied by Mirada Medical and/or installed/configured by Mirada Medical. 

User Installation/Operation 

User-performed installation and configuration of the software is entirely at the user’s risk unless 

otherwise agreed by Mirada Medical (on the basis of an extended EULA/service contract). This includes 

any disruption to existing installations, software (or software licenses) or data loss. 

Diagnostic and Therapeutic Restrictions 

Use of the software as a primary viewing or diagnostic device  

The software is designed as an aid to diagnosis, enabling information to be used as an input into a 

diagnostic process. Other methods and procedures should be in place to enable a diagnosis to be 

reached without the aid of this software. The software should not be used as the sole basis for forming a 

diagnosis, to do so would constitute a misuse of the software. 
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Use of the software for Biopsy Planning  

The software is designed as a visual aid and as such it is not recommended for use in applications where 

the image geometry or the fused image geometry (as displayed by the software application) cannot be 

confirmed by other means. The software should not be used as a direct control mechanism for biopsy 

guidance mechanisms (either hardware or software based). 

Use of the software for Surgical Planning 

The software is designed as a visual aid and as such it is not recommended for use in applications where 

the image geometry or the fused image geometry (as displayed by the software application) cannot be 

confirmed by other means. The software should not be used as the sole basis for surgical planning, the 

preparation, execution or post-operative assessment of surgical practices.  

Use of the software for Radiotherapy and Treatment Response  

The software is designed as a visual aid and as such it is not recommended for use in applications where 

the image geometry or the fused image geometry (as displayed by the software application) cannot be 

confirmed by other means. The software should not be used as a direct control mechanism for delivery 

of treatment, either via radiation or chemotherapeutic methods. The software should not be used as the 

sole basis for evaluating the success/response to treatment. 

Warnings 
The warnings listed here relate to specific functions and modes of use for the software. These are also 

listed in the applicable sections of this Help Guide.  

 Unsupported modalities, data or image types may cause the software to function incorrectly, to 

return invalid results or to reject the data if an attempt is made to load them into the software. Attempt 

to load invalid data along with valid data may cause both sets of data to be rejected by the software. 

 Lossy compressed data, by design will reduce image quality. This may impact the ability to view 

images with the same accuracy and detail as with non-lossy data. All loaded lossy data is labeled as such 

in the viewing window. 

 The Maximum Intensity Projection or MIP Renderer is a tool for data visualization in 3D and is 

useful for obtaining an overview of the areas within the image data of a high intensity and as a tool to 

navigate to those regions. The MIP should not be used as the sole view used to interpret the image data. 
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Fused images are displayed within system provided layouts and can be included in user defined 

layouts. The modality, quantification information, time point and dataset designation within the current 

review mode are displayed for each layer in the fused view to allow identification of each layer. 

Care should be taken to ensure that the slice numbering scheme chosen in XD3 matches that of 

any system used to launch XD3. 

The slice navigation slider is specifically designed to be able to navigate quickly to a desired area 

within an image view. As such the slice navigation slider does not display every slice in the view being 

navigated from the currently displayed slice to the slice represented by the slider position set. 

The PET SUV from Acquisition calculation underlying the display of this quantification option is 

outside the control of Mirada Medical. When PET SUV from Acquisition displays values, the number 

displayed is based on the stored value in the image data. Please contact your vendor for further 

information on this topic. 

 If the Go To Hottest Voxel tool is used on a region with more than one voxel with the highest 

intensity value, then only one of these voxels will be identified. 

When an automatic registration scheme is set to be run on application load, the results should be 

reviewed using the crosshair alignment and the quality control tools available via Registration -> 

Registration Manager to ensure that the registration is satisfactory. This is particularly important before 

propagation of ROIs between time points. 

When an automatic registration scheme is run with data assignments containing multiple related 

series (e.g. Gated CT or PET, Multi-phase CT, Multi-sequence MR), the first series/volume assigned is the 

one used for registration for registrations involving that assignment. This may or may not be the optimal 

series/volume to use for registration depending on the acquisition protocol. This can be modified on the 

Data Management screen by changing the ‘Anchor’ for the assignment and reviewed on the 

Registration -> Registration Manager to ensure that the registrations are satisfactory. 

When propagating ROIs between time points, it is important to check that the threshold used is 

appropriate for the data in the time points. For meaningful comparison statistics to be displayed, the 

threshold should be the same in each time point. 
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To see the threshold used, select the region in the time point and view the threshold slider or hover the 

mouse over the Region defined in the Regions of Interest panel in the Toolbox. 

The threshold is also visible on the Regions Table. 

When defining a 2D ruler, the measurement associated with a line is displayed in the same color 

as the line to which it pertains. When the measurements are similar, the colors should be checked to 

identify the pertaining line. 

 The Create Ruler from Region tool calculates the long and short axes from the ROI selected using 

mathematical approximations of the smooth ROI boundary. However, the resulting bi-ruler may not 

correspond to what the user considers to be the long and short axes that best characterize the lesion 

from a clinical point of view. It is important that the resulting Biruler is visually inspected and compared 

with the region used for creation to ensure the results are as desired. 

 The Create Ruler from Region tool uses mathematical approximations to the smooth ROI 

boundary when calculating the best bi-ruler placement. However, in some rare cases the 

approximations may result in a ruler that does not correspond exactly to the displayed boundaries or 

one that passes slightly outside the lesion boundary. The user should check the result of the tool to 

confirm that the ruler meets their expectations. 

When viewing fused images, artifacts may be introduced by poor alignment of findings between 

the image layers in the fused view. It is recommended that the registration accuracy is checked prior to 

image interpretation and the transparency of the layers is adjusted appropriately to view the layers in 

the fused views.  

When a layout image segment contains multiple planar NM Images from one or more series, the 

only way to distinguish to which planar series an image pertains is by the series description text label on 

the image segment.  

Gallery images do not individually contain patient identification information due to the potentially 

limited size of the image segments. To identify to which images the gallery pertains, system provided 

gallery views contain a patient information view segment. 

The layout editor allows patient information views to be added to all user defined layouts and should be 

used when creating Gallery views. 
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The Data QC validation is performed on a per user basis using the validation criteria specified by 

each user. The validation does not perform any image quality or registration checks. 

This feature requires an advanced license to perform and report validation results. Care should be taken 

when utilizing the floating license deployment and using this feature, as launching with a Standard 

license after an Advanced license will not perform validation on the data as may be expected. 

It should be noted that not all fields are validated, some are for display only. These fields cannot be set 

to validate the contents when specifying which fields to validate. 

The Voxel Intensity Distribution feature relies on the accuracy of the registration when the ROI 

was created on one dataset and the intensity distribution statistics are viewed for the other datasets 

within the same time point. The registration should be checked for accuracy using the Registration 

Manager prior to using this feature. 

 Functions that rely on the inversion of the registration deformation map such as the cross-hair 

alignment and Region of Interest propagation may exhibit inconsistent and asymmetrical behavior in 

certain situations. For example in Adaptive Planningreview mode, if the user were to navigate the cross-

hair to a location A in the Baseline Planning the software will automatically place the cross-hair at a 

particular corresponding location, B, in the Current Planning. However, if the user were then to move 

the cross-hair around in the Current Planning and then place it back at location B, the position of the 

cross-hair in the Baseline Planning may not be at location A.  

This applies to any deformable registration either within a timepoint or across timepoint. For example, 

in Fusion Analytics in which a deformable registration exists between the Planning and MR images, the 

Planning dataset should be used for cross-hair navigation.  

 When using the Volume Crosshair tool, due to the discrete nature of the image data, quantization 

effects may result in a small difference in the statistics displayed on the same data viewed in fused and 

non-fused views. This effect may be greater in the presence of a large deformable registration between 

the layers. Such differences are generally not clinically significant. However, we recommend that the 

user check the magnitude of any differences by comparing the statistics visible in the fused and non-

fused views when using this tool. If the user considers the difference significant for their purposes then 

the non-fused statistics should be used. This effect does not occur with the other ROI tools available in 

the application. 

 The frames in a dynamic flow study are played at a uniform rate and not in real-time. 
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Due to its definition, the peak value may include voxel values from outside the ROI boundaries 

when the ROI is near an adjacent area of the image with high PET values. The user should treat the peak 

value with caution where high PET voxels are within 0.7 cm of the ROI boundaries. 

 XD3 creates the DICOM RT Structure Sets from the selected region as specified in the DICOM 

Standard. RTP systems may apply interpolation between the encoded contour control points that differs 

from their display in XD3. We recommend that the user takes screenshots of the regions used to create 

the contours, on an acquisition orientation view, and uses these to compare to the contour displayed 

within the RTP system to ensure that the imported contour is an accurate representation. 

 Different interpolation methods may be used by XD3 and TPS systems when displaying contours. 

This means that when viewing findings in the acquisition orientation, they may appear visually different 

between systems. It is recommended that screenshots of loaded findings be taken in the acquisition 

view and compared to the same findings as displayed on the TPS to ensure that the imported structures 

are accurately represented in XD3. 

 Regions resulting from performing the Transform to All, Transform to Remaining, Transform to 

All within Timepoint and Transform to Remaining within Timepoint actions are highly dependent on 

the quality of the registration that exists between the dataset on which the source region exists and all 

the datasets to which the region is to be transformed. It is recommended that quality checks be 

performed within the Registration Manager screen on the accuracy of the registrations prior to 

performing a region transformation action. 

 The volume doubling time statistic is derived from the volume statistic. It is an estimate of the 

true tumor volume doubling time and depends on the accuracy of the regions drawn. The region should 

be checked on every slice on which it exists to ensure it is as accurate as possible. 

 The volume doubling time calculation becomes more robust the larger the regions become. At 

small volumes where the region volume consists of only a few voxels, the potential error in the reported 

volume may be quite large. The user is advised to use the Data QC screen to check the voxel dimensions 

when making a judgement as to how to interpret the volume doubling time. In addition, the volume 

doubling time calculation may become very large and sensitive when the volumes in consecutive 

timepoints are similar. 
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 Many data roles can load multiple volumes so long as they share a common frame of reference. 

Once loaded, XD3 will attempt to sort the volumes into a logical order. For gated data, this will be in a 

temporal order. Multiple reconstructions of the same raw data can also be loaded, however in such use 

cases it may not be possible to consistently order the volumes. While the application is not designed to 

support multiple reconstructions of the same data for PET and SPECT (such as FBP and TOF), it is 

possible to load these reconstructions simultaneously into the same data role. In this case it is not 

possible to guarantee that the same order is maintained over multiple timepoints. The user must check 

within the Data Management screen to ensure that the same reconstructions have been assigned to the 

anchor role. 

 Automatically shadowed regions will be quantified in the resolution of the dataset onto which 

the region was shadowed. Only voxels whose center lies within the region are considered when 

calculating statistics. If the dataset on which the original region was defined and the dataset onto which 

the region was shadowed are of a different resolution, the regions may have a different Volume statistic 

as the volume will always be a multiple of the voxel volume of the dataset on which the region is 

defined. For instance, a region defined on a CT dataset and automatically shadowed onto the PET may 

have a different Volume statistic when calculated on the CT compared the Volume statistic calculated on 

the PET if the CT dataset is of a different resolution to the PET.  

It follows that any statistic derived from the Volume statistic (e.g. Volume Doubling Time) will be 

different for a finding shadowed between a pair of datasets if the Volume statistic is different for that 

finding. 

 The CT Region Segmentation tools estimate a lesion boundary based on image contents and the 

user initialization and does not attempt any automated detection of lesions. The quality of the results 

need to be checked for accuracy by the user prior to being used. 

Notes 

Note 1 
When using SUV calculation during PET assessment certain assumptions are made with regard to the 

reference time for the acquisition of the data series. Variability in interpretation of requirements 

outlined in the DICOM Standard with regard to determination of the start reference time during 

acquisition and the time of tracer injection may result in variability in the SUV values calculated by 

different vendors. 
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It is important to note that due to inconsistency of approach throughout the industry, the acquisition 

time used in SUV calculation may be any of the acquisition times presented in the DICOM data. It is 

equally important to note that SUV is affected by a number of physiological factors which cause 

variability. Taking these two factors into account, SUV can be thought of as a simplified measure of 

radiopharmaceutical uptake which has a complementary rather than directive role in the assessment, 

treatment and staging of disease. 

 

In compliance with Council Directive 93/42/EEC. 

Manufactured by: 

Mirada Medical Ltd. 
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Oxford 
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United Kingdom 

 

Date of manufacture: September 2016  



  mm2357-6 
  FUXD-USER 
 

Mirada Medical | XD 14 

 

Data Supported 

Supported Image Modalities 
The following data types are supported: 

• CT 

• MR 

• PET 

• SPECT/NM 

Supported Image Types 
The following image types are supported: 

• Gated CT, NM, PET 

• Multi-sequence MR 

• Multi-phase CT 

Supported Non-Image Data Types 
The following non-image types are supported: 

• RTSS 

Supported Data Types 
The following data types are supported: 

Uncompressed: 

• Explicit Big Endian 

• Implicit Little Endian 

• Explicit Little Endian 

Compressed: 

• Lossless JPEG First Order 

• Lossless JPEG 

• Deflated 

• Lossy JPEG Baseline 

• Lossy JPEG Extended 

• Lossless JPEG 2000 

• Lossless or Lossy JPEG 2000 

NOTE: The XD3 DICOM Conformance Statement contains a detailed description of supported 

modalities and data types. 



  mm2357-6 
  FUXD-USER 
 

Mirada Medical | XD 15 

 

 Unsupported modalities, data or image types may cause the software to function incorrectly, to 

return invalid results or to reject the data if an attempt is made to load them into the software. Attempt 

to load invalid data along with valid data may cause both sets of data to be rejected by the software. 

 Lossy compressed data, by design will reduce image quality. This may impact the ability to view 

images with the same accuracy and detail as with non-lossy data. All loaded lossy data is labeled as such 

in the viewing window. 

 Different interpolation methods may be used by XD3 and TPS systems when displaying contours. 

This means that when viewing findings in the acquisition orientation, they may appear visually different 

between systems. It is recommended that screenshots of loaded structures be taken in the acquisition 

view and compared to the same structures as displayed on the TPS to ensure that the imported 

structures are accurately represented in XD3. 

 Many data roles can load multiple volumes so long as they share a common frame of reference. 

Once loaded, XD3 will attempt to sort the volumes into a logical order. For gated data, this will be in a 

temporal order. Multiple reconstructions of the same raw data can also be loaded, however in such use 

cases it may not be possible to consistently order the volumes. While the application is not designed to 

support multiple reconstructions of the same data for PET and SPECT (such as FBP and TOF), it is 

possible to load these reconstructions simultaneously into the same data role. In this case it is not 

possible to guarantee that the same order is maintained over multiple timepoints. The user must check 

within the Data Management screen to ensure that the same reconstructions have been assigned to the 

anchor role. 
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Review Modes 

Review modes are used to create a simplify the steps involved in matching the XD3 application to a 

particular task such as deformable fusion for multi-modal contouring or using an atlas for automatic 

contouring. Functionality, the number of supported data sets, layouts, defaults, etc. are customized to 

each particular Review Mode. For instance, pressing F5 ‘Auto Deformable’ does something different 

depending on whether you are in General Oncology or MR/PET/CT review mode..  

Review Modes are accessed from the icons on the right side of the Application Launcher screen or from 

the ‘Select a review mode’ drop-down menu on the Data Configuration screen.  

When selecting data and launching a review mode, the XD3 application window may be displayed 

without any further user interaction. If certain conditions are present, the data configuration screen is 

displayed so the data assignments can be reviewed or modified manually. The following are those 

conditions: 

• The system is not launched with a specified Review Mode 

• The automatic data assignment leaves some data unassigned 

• There is a different collection of data available for each time point (e.g. CT and Dose in one time 

point, and only a CT in another time point). 

Holding down the Ctrl key and clicking any review mode icon will force display of the data configuration 

screen. 

The following Available Review Modes section of this document lists all Review Modes and a 

description of each. 
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Available Review Modes 

XD3  
This is a generic way to launch XD3 which displays the data configuration screen allowing the review 

mode to be selected manually from the drop down menu and the data assignments to be confirmed or 

modified manually.  

General Fusion 
This review mode supports one time point and allows the registration of up to three datasets. One 

datasets is designated the source and the other dataset(s) targets. The targets are registered to the 

common source. 

General Oncology Review 
This review mode is designed to allow you to review one or more time points of PET/CT or SPECT/CT 

data. An MR may replace one or more of the CTs. This review mode supports multi sequence MR and 

multi-phase CT. 

MR/PET/CT 
This review mode is designed to allow you to load multiple sequences of MR data along with PET and CT 

for review. This review mode supports multiple time points. 

Basic NM Review 
This review mode allows you to load planar NM images as well as SPECT or SPECT/CT volumes for 

multiple time points. 

PET Review 
This review mode is designed for follow-up PET reviews. It supports PET images only (with optional NAC 

reconstructions). 

PET/CT Head and Neck Review 
This review mode allows you to read data including WB plus additional regional scans in a meaningful 

way with respect to the layouts and registrations performed. 

PET/CT Melanoma Review 
This review mode allows you to load a WB PET/CT and a PET/CT of the legs. NACs may also be loaded as 

they are particularly important for these cases. Single or multi time-point review is supported 

PET/CT Whole Body Review 
This review mode is designed for review of one or more time points of PET/CT. Optical Flow (CT-CT 

registration) is performed and datasets are labeled as PET and CT. 
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Single Volume Review 
This review mode is available for quick review of a single dataset. You may choose a single PET, CT, MR 

or SPECT dataset for viewing and quantification. 

Review Mode Preferences 
For each review mode there are several user preferences which may be selected via the Tools -> 

Options menu on the Review Modes tab.  

• Automatic registration scheme: this may be selected from the dropdown menu at the top of 

the window. It is the registration that is performed upon data load into the application.  

• Default report template: this may be selected from the dropdown menu, and may be a Mirada 

provided report template or a user-defined custom template. 

• Layouts: You may place a tick in the box next to any layout that you would like to have available 

in a given review mode. Each user (per login) may also identify five favorite layouts which will 

appear as icons in the upper left on the screen at the top of the Toolbox. Any layout may also be 

be set to a hotkey by double-clicking left in the Hotkey column until the cell turns yellow and 

then typing the keystroke of the desired hotkey. If a hotkey is already in use, a dialogue will 

appear alerting you that it is already in use by another function. 

• Window Defaults: this allows you to choose the default layouts for your review mode, and 

others to use if the default selection does not support the data loaded. Window 1, Window 2 

and Window 3 correlate to multiple monitors. 

• Colormap Defaults: this allows you to set default colormaps for your base and overlay images in 

fused views.  

NOTE: Changes made on this screen will be applied upon the next launch of the application 

 

Data configuration screen 
The data configuration screen allows you to review and/or manually select how the datasets for each 

time point are configured and loaded into the software for viewing and/or manipulation. This screen will 

appear automatically if: 

• The system is not launched with a specified Review Mode 

• The automatic data assignment leaves some data unassigned 

• There is a different collection of data available for each time point (e.g. CT and PET in one time 

point, and only a PET in another time point). 

The Data Configuration screen may also be displayed manually by pressing the Ctrl button and clicking 

left on the appropriate Review Mode in the Application Launcher screen.  

You may change your selection of Review Mode by using the drop down menu at the top of the screen. 
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The files available for review are listed near the top of the window in the Series List. Each series is placed 

in the appropriate position as shown in the PET/CT Whole Body Review mode example below: 

 
If multiple time points are loaded, the first or oldest dataset is loaded into Baseline, Prior studies are 

loaded in chronological order and the current study is loaded into Current position. Use the eraser tool 

to remove any dataset from its pre-assigned position. Drag and drop datasets from the Series List to the 

appropriate position in the Data Configuration grid. Using the buttons in the lower left of the window, 

you may Clear All assignments to start over, Add Timepoint to include another study, or select Reset to 

return to the original configuration. Continue until you are satisfied with the placement of data and click 

‘OK’. 

Certain assignments are mandatory and this varies between review modes. Generally it is the 

Anatomical role that is required. If you select the ‘OK’ button without these assignments populated, a 

warning will be displayed which will detail the mandatory assignments. 

This opens the image workspace with images displayed in the default layout. 
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Data QC 

Data QC Feature 
The Data QC tool is provided to allow you to view attributes from datasets loaded into the application 

for review. Generic attributes that apply to all modalities or those such as acquisition date will be 

available for display only. Several attributes that can be validated such as slice thickness, kVP, X-ray tube 

current and several others may be displayed for the CT data. Likewise, software version, injected dose, 

delay time, half-life, patient height, patient weight and additional attributes are available for validation 

on the PET data.  

If you wish, you may perform validation of this data based on limits that you define. For example, you 

may want to be warned if the delay time variance from the time of injection to time of scan between 

time points is greater than a certain amount of time. Remember that attributes are for display only and 

cannot be validated. The Data QC screen will show you the attributes and flag any that are outside the 

tolerance levels you have set. Additionally, the Data QC screen may be included in a custom report. You 

may choose which attributes are visible and whether you would like to be prompted to display the Data 

QC screen on startup if there are validation warnings.  

Configuring Data QC 
The Data QC screen may be displayed via the Window menu, on the toolbar layout selector, from the 

on-screen layout selector (Ctrl + Tab) or via a hotkey set in Tools -> Options on the User Interface Tab. 

See User Preferences section for detail on setting hotkeys. 

See User Preferences section for detailed instruction on setting up the Data QC items that you wish to 

have visible on your Data QC screen and which attributes you wish to validate when data are loaded. 

When loading gated data, multi-phase CT or multi-sequence MR, variance checks are carried out 

between the different phases or sequences and the results reported. 

There are some fields for PET data whose values come from the Quantification Options dialog rather 

than the underlying data. These fields are Delay Time, Half Life, Height, Injected Dose, Sex and Weight. 

These fields are editable by the user in the Quantification Options dialog and any changes made are 

reflected live in the Data QC screen. 

NOTE: Validation requires an Advanced license. Attributes can be viewed with a Standard or Advanced 

license. 

NOTE: The way that validation is performed varies slightly between the type of data being validated. 

Textual data is validated against the input validation values, and is not case sensitive. If this textual 

data is not present for data being validated within a time point, then the cross time point variance 

check will also fail and be reported as such. 
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Numeric data is validated against the minimum, maximum and variance (i.e. the range) values entered. 

The values entered are checked inclusively, so if a variance of 10 is entered and the variance is 10, it will 

pass the check. If this numeric data is not present for data being validated within a time point, then the 

cross time point variance check will pass and be reported as such. The within time point check will fail. 

 

The Data QC validation is performed on a per user basis using the validation criteria specified by 

each user. The validation does not perform any image quality or registration checks. 

This feature requires an advanced license to perform and report validation results. Care should be taken 

when utilizing the floating license deployment and using this feature, as launching with a Standard 

license after an Advanced license will not perform validation on the data as may be expected. 

It should be noted that not all fields are validated, some are for display only. These fields cannot be set 

to validate the contents when specifying which fields to validate. 
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Layouts 

Provided Layouts 
Layouts are the hanging protocols used to display images. Each Review Mode contains a selection of 

available layouts. These layouts may be accessed either from the dropdown menu in the upper right 

corner of the image window, via the Window menu, or by using Ctrl and Tab keys simultaneously to 

bring up an on-screen layout selection menu (see below). When using Ctrl and Tab, hold down on the 

Ctrl key and toggle the Tab key to scroll through the on-screen menu of layouts. Layouts may also be 

selected by clicking on them in the on-screen layout selection window.  

Any layout may be assigned to a hotkey of your choice via Tools -> Options menu and under the Review 

Modes tab. See User Preferences section for detailed instruction on creating hotkeys for your layouts. In 

addition, each user may choose five favorite layouts for display and access in the Favorite Layouts area 

in the Toolbox. Favorites may be defined on the Review Modes tab in Preferences via the Tools -> 

Options menu as shown below.  

Please take caution when making layouts available in a review mode for which they were not created as 

the data will likely not be displayed as expected. 
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Data QC, Registration Manager, Findings Table, Report Screen, and Secondary Capture will always be 

available in the selection of layouts regardless of the Review Mode. 
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Custom Layouts 
Custom layouts may be created from the Tools menu by selecting Layout Editor. The New Layout 

window will appear. Provide the name you wish to assign to the new layout, select the Review Mode for 

which you want the layout to be available, and select the number of time points you would like it to 

support. Select Continue.  

Next select the grid size that you would like to use in creating the layout by selecting the  icon from 

the Layout Actions are of the Toolbox. Click and drag your mouse to highlight the number of rows and 

columns that you would like to include. Each square represents an image view and is highlighted in 

orange to identify the number and arrangement you would like to see in your layout. By clicking left in 

the lower right square of your highlighted grid, that array is saved as your layout grid. You may merge 

adjacent cells by clicking left on the cells you wish to merge and then click right to select Merge Cells 

from the dropdown menu. For example, you may wish to display a MIP using two or three merged cells.  

 
If you merge cells and then decide you do not want them merged, click the right mouse button within 

that cell and select Split Cell from the dropdown menu.  

View Types 

Select the type of images you want to include in your layout by selecting from the drop down menu. The 

choices are: 

• Volume View Types – for axial, coronal, sagittal and acquisition orientation images from 

PET/CT/MR/SPECT datasets 

• Gallery View Types 
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• Info Views – these views contain textual overlays containing patient information only; they may 

be added to the beginning of a gallery view or any image view where images may be too small 

to show the full patient information overlay 

• MIP View Types 

• 2D Slice and Planar Views - for displaying NM planar data  

NOTE: Acquisition orientation views allow data to be viewed in the same orientation it was acquired. 

For example, an off-axis MR scan can be scrolled through without having to view partial slices created 

from post-acquisition reorientation to axial. 

Each cell within the layout has a context menu that can be accessed by clicking the right mouse button. 

This menu allows the following to be set: 

• Time point offset – Defines the time point to display for a multi-time point layout.  

• Window/Level – Select a window/level preset to apply to the base layer of the dataset loaded 

into the cell. 

• Slice Offset – This is only available for 2D Slice and Planar Views. This is used to display a 

particular image from a multi frame series. For instance, use Slice Offset to display the second 

image in a sequence of spot images. 

• Dataset Offset – This is useful for gated CT or PET, multi-phase or multi-sequence MR or 

dynamic SPECT. This allows the initial dataset within the group to be set. For instance, the third 

volume in a multi-sequence MR series. 

Continue defining your layout by dragging and dropping the image sets on the left into the desired 

positions on your new layout grid. If more than one image view is dragged and dropped into the same 

cell, a fused view will be created. The layers will be created in the order that they are dropped on the 

cell. Once all positions are filled, click Save Layout. The layout editor will not allow you to save a layout 

with empty cells. 

You may change the name you have given the layout prior to saving it by retyping in the Layout name 

field. Also, use the drop down menu to preview the layout for all Review Modes for which the layout will 

be available. 

Layouts may be made available for various Review Modes, selected as Favorites, or set as Hotkeys in 

Review Modes tab in Preferences found by selecting Tools -> Options from the menu. 

It is also possible to create layouts that do not match the currently loaded data in the application. In this 

case, the layouts will not be available for selection until the data in the application matches that defined 

by the layout. 

NOTE: Certain layouts such as three way fused views require an Advanced license. These layouts can 

be created with the Standard license, but will not be available for selection. 
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Fused images are displayed within system provided layouts and can be included in user defined 

layouts. The modality, quantification information, time point and dataset designation within the current 

review mode are displayed for each layer in the fused view to allow identification of each layer. 

When a layout image segment contains multiple planar NM Images from one or more series, the 

only way to distinguish to which planar series an image pertains is by the series description text label on 

the image segment.  

Gallery images do not individually contain patient identification information due to the potential 

limited size of the image segments. To identify to which images the gallery pertains, system provided 

gallery views contain a patient information view segment. 

The layout editor allows patient information views to be added to all user defined layouts and should be 

used when creating Gallery views. 

Layout Selection and Time Points 

System provided layout selection 
Each system created layout displays a fixed number of time points. The actual time points displayed in 

the layout can be modified. For example, with three time points loaded, when selected for the first time, 

a two time point layout may have the Prior 1 and Current time points displayed. This can be changed to 

Baseline and Current if so desired. When another system provided two time point layout is selected, this 

Baseline and Current time point selection is maintained in the newly selected layout. 

In summary, the time points displayed are remembered when switching to system provided layouts with 

the same number of layouts. The time point selection is not remembered across application windows. 

Custom layout selection 
As with system provided layouts, each custom layout is defined with a fixed number of time points. The 

initial time points to be displayed in the layout are set when creating the layout (newest, oldest etc). 

When switching to a custom layout, the time point selection is reset unless the time points defined in 

the current layout and the one to switch are identical, in which case the time point selection will be 

maintained. A two time point layout created with oldest and newest time points is not considered 

identical to a two time point layout created with newest and newest-1, as these will resolve to different 

time points, depending on the number of time points loaded. 

As with system provided layouts, the time point selection is not remembered across application 

windows for custom layouts. 
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Image Window 

Active Text 
In the image window there is information about the patient, study and images displayed. Some of the 

text is for information only and other is ‘active text’ that may be used to adjust the image. The default 

colors of the text are blue and black/white. The black/white colored text is inactive and represents 

information such as patient name, sex, age, birth date, identification number, hospital or facility name, 

the currently displayed field-of-view, series name and date obtained from the DICOM header.  

The blue colored text is the active text. When the mouse pointer hovers over any setting that may be 

adjusted in this manner, the text becomes underlined. Click on the text to display the available control. 

Available Active Text Controls  
In the image window there are active text controls for: 

• Scale 

• Window and Level 

• Quantification Options (SUV) 

• Slice Index 

Custom color and font size for the on screen text may be set in user Preferences via the Tools -> Options 

menu on the Views tab. Click on the Interactive text color shown to display the color palette and select a 

new color. Font size may be changed by using the up and down arrows or double-clicking and entering 

the desired size. 

Image View Labels 
In XD3 an image view can be customized to display only the information the user wants. Each view has 

two configurations: the information to display on-screen and the information to imprint into the view 

when a screen capture is taken of that view. 

There are five view configurations available in XD3: Default, Default Snapshot, Patient Only, None and 

Slice Number Only. Each of the different view types (see View Types) can have a different configuration 

selected for on-screen display and for when a screen capture is taken. 
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The selected configurations can be changed as a user preference via the Tools -> Options menu on the 

Views tab. 
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The different configurations control which information is visible in the four corners of the views. 

 
 

Default 

 
Patient Name, Patient Sex, Patient Age, Patient Birth Date, Institution Name, Accession Number, View 

Code, View Type, Series Date and Series Description come from the underlying DICOM data that is being 

displayed as the bottom layer in the view. 

Scale label is the current zoom factor being applied. The window/level controls are the active text 

controls that allow the user to modify the displayed window/level.  

Dataset Name is the review mode-specific name of the data role to which the data has been assigned. 

E.g. “Anatomical” or “Source”. The Quantification label is the value at the crosshair location displayed in 

the appropriate units. 

Patient Name         

Sex | Age | Birth Date 

Institution Name     

Accession Number 

Scale Label    

Window/Level Controls 

View Code 

         View Type 

         Slice X / Y         

Series Date    

      Series Description Dataset Name | Quantification 

NW NE 

SE SW 
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View Code is only applicable to NM data and comes from the NM Detector Information Sequence in the 

NM Detector Module. The View Type displays something appropriate for the type of view. For instance, 

this could be Axial, Coronal, Sagittal, MPR, Original, MIP, et cetera. 

Default Snapshot 

This is currently the same as the Default configuration. 

Patient Only 

 
Patient Name, Patient Sex, Patient Age, Patient Birth Date, Institution Name and Accession Number 

come from the underlying DICOM data that is being displayed as the bottom layer in the view. 

None 

No information is displayed in any part of the view 

Patient Name         

Sex | Age | Birth Date 

Institution Name     

Accession Number 
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Slice Number Only 

 
Slice number is a single number relating to slice number of the crosshair position in the orientation of 

the view. 

  

  

Slice Number  
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Toolbox  

Toolbox 
This bar on the left side of the image window is used to display a number of control panels. Some of 

these are open by default and some are disabled. The open/collapsed contents can vary per monitor 

(i.e. application window) and per task.  

Showing or Hiding the Toolbox 

 The toolbox may be hidden from display, thus allowing additional space for images by selecting the 

button on the toolbar or by selecting ‘Show Toolbar’ from the View menu. This function may be set to a 

hotkey. This setting applies to all windows as the toolbox may not be removed from just one window. 

Favorite Layouts 
Each user may select up to five favorite layouts to be included in the display at the top of the Toolbox for 

quick access. Those favorites can be set up in Options on the Review Modes tab, by selecting Tools -> 

Options from the menu. Click to place a check mark in the box next to any available layout to select as a 

favorite. These or other layouts may be given hotkeys to allow you to switch quickly between different 

layouts. If a hotkey has been assigned to any of the favorite layouts, when you hover your mouse over 

the layout the hotkey will be displayed. 

The layouts that you have chosen as favorites will be available for selection once the application has 

been restarted.  

Layers 
The Layers Panel in the Toolbox displays a row for each dataset displayed in the selected view. Next to 

each layer is a box to check to include or remove that dataset from the current image view. By 

highlighting a particular layer (that row is highlighted in blue), you choose the layer for which controls 

are active. For example, when using the Transparency Tool, the system adjusts the transparency of the 

selected layer within the current image view.  

 
 In the example above, both CT and PET (AC) datasets are visible in the view, and the controls are active 

for the PET (AC) dataset . 
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The window/level slider control resides in this area of the toolbox as well, and adjusts the window and 

level of the selected layer. The units of the control will be appropriate for the modality of the layer. If 

you select the adjust transparency control, the system displays the Transparency slider in the Layers 

panel. 

Pressing the ‘O’ key on the keyboard makes the overlay invisible if it is currently visible or it will make it 

visible if it is currently invisible. The removal of the overlay applies to all fused views within the 

application. All Layers within the view other than the base layer are removed. 

Findings 
The findings include regions, measurement, and annotations created on an image. You may modify the 

created findings’ names, colors and viewed statistics by double-clicking the finding name. When the 

mouse hovers over any ROI or Ruler in this panel, the tooltip will display statistics or measurements. This 

feature is most useful with ROIs if a region has been projected. 

 
The Findings panel toolbar contains the following options: 

 Delete the selected finding 

 Go To the selected finding 

 Show or hide the selected findings 

 Display the Findings Table 

 Link the selected findings 

 Display Findings Graph 
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 Projects the selected finding to all time points 

 Projects the selected finding within its time point 

 Create regions at preset thresholds within the selected area 

Click the right mouse button on any selected finding to: 

• Delete 

 This action is also available from the toolbar. 

• Copy Statistics to Clipboard 

• Copy Statistics to the Image Gallery 

• Display Findings Graph 

 This action is also available from the toolbar. 

• Go To the selected finding. 

 This action is also available from the toolbar. 

• Go to hottest voxel 

If the Go To Hottest Voxel tool is used on a region with more than one voxel with the highest 

intensity value, then only one of these voxels will be identified. 

• Create a ruler from the region 

• Create Multiple Threshold Regions: This creates multiple threshold ROIs from a previous 

threshold ROI.  Thresholds are pre-set in Tools -> Options under the Findings tab. 

 This action is also available from the toolbar. 

• Toggle to indicate lymph node 

• Unlink 

• Link Findings: There are two types of findings: rulers and regions. Rulers include uni-rulers, bi-

rulers and angles (annotations are not classed as findings). Regions include isocontour regions 

(with threshold), filled regions, 2D rectangles, 2D ellipses and regions painted with the freehand 

paint tools. Ruler findings can always be linked to other ruler types. They can also always be 

linked to region types. Region structues can be linked to ruler findings but are restricted as to 

which other regions they can be linked. A region can only be linked to another region that was 

defined on the same data role. E.g. a region defined on the Anatomical data role in General 

Oncology Review can only be linked to another region defined on the Anatomical role and not to 

one defined on the Functional role. This is further restricted to only being able to be linked to 

another region defined on the same role but not on the same dataset. E.g. a region defined on 

gate 1 of a gated CT assigned to the Anatomical role can be linked to a region defined on gate 2 

of the same gated CT, but not to another region defined on the same gate 1. This restriction 

does not apply across time points. A region on gate 1 of a CT on the baseline time point can be 

linked to a region defined on gate 1 of a CT on the current time point. 
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 This action is also available from the toolbar. 

• Show/Hide regions 

 This action is also available from the toolbar. 

• Project to all by type : with a region selected, this option will propagate a finding to the 

equivalent dataset designation in all time points by recreating the region in each time point 

using the means by which the region was originally created (i.e. absolute threshold, % max 

threshold). If the region exists in multiple time points, then the value will be taken from the 

selected time point. 

 This action is also available from the toolbar. 

• Project to all by volume: with a region selected, this option will project the region to the 

equivalent datasets designations in all time points by maintaining the volume of the original 

region. If the region exists in multiple time points, the volume value will be taken from the 

selected time point.  

• Project to all within volume by type: with a region selected, this option will project the region 

to all datasets from the same frame of reference (i.e. bins of a gated dataset, phases of a multi-

phase CT or sequences of multi-sequence MR) and create shadows on each of them. If the 

region exists in multiple datasets, then the absolute threshold value is taken from the selected 

dataset. 

 This action is also available from the toolbar. 

• Transform to all: with a region selected, the region will be transformed to the equivalent 

dataset designation in all time points using the existing registration to transform the ROI shape. 

If the region exists in multiple time points, then the selected time point will be propagated. 

• Options … (displays the Findings tab in Tools -> Options) 

There are additional options for projecting and transforming findings which are turned off in the menu 

by default, but may be enabled via Tools-> Options on the Findings tab. These additional tools are: 

• Project to remaining by type: with a region selected, this option will propagate the selected 

region to the equivalent dataset designation in time points where the region does not already 

exist by recreating the region in each of the time points using the means by which the region 

was originally created (i.e. absolute threshold, % maximum threshold) 

• Project to Remaining by volume: with a region selected, this option will propagate the region to 

the equivalent dataset designation in time points where the region does not already exist by 

maintaining the volume of the propagated region. If the region exists in multiple time points, 

then the volume value will be taken from the selected time point 

• Transform to remaining: with a region selected, this option will propagate the region to the 

equivalent dataset designation in all time points that do not contain the region. The existing 

registration will be used to transform the ROI shape. If the region exists in multiple time points, 

then the selected time point will be propagated. 
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• Project to remaining within timepoint by type: with a region selected, this option will project 

the region to all datasets from the same frame of reference (i.e. bins of a gated dataset, phases 

of a multi-phase CT or sequences of multi-sequence MR) where the region is not currently 

defined and create shadows on all datasets to which the role on which the region was defined 

are linked. If the regions exists in multiple datasets, the absolute/threshold value will be taken 

from the selected dataset. 

• Transform to all within timepoint: with a region selected, this option propagates the region to 

all datasets within the same frame of reference (i.e. bins of a gated dataset, phases of a multi-

phase CT or sequences of multi-sequence MR) using the existing registration to transform the 

ROI shape. If the region exists in multiple datasets within the same frame of reference, the 

selected region will be propagated. 

• Transform to remaining within timepoint: with a region selected, this option projects the 

region to the other datasets within the data designation (same frame of reference) that do not 

contain the region, using the existing registration to transform the ROI shape. If the region exists 

in multiple datasets within the designation, the selected region will be propagated. 

 Regions resulting from performing the Transform to All, Transform to Remaining, Transform to 

All within Timepoint and Transform to Remaining within Timepoint actions are highly dependent on 

the quality of the registration that exists between the dataset on which the source region exists and all 

the datasets to which the region is to be transformed. It is recommended that quality checks be 

performed within the Registration Manager screen on the accuracy of the registrations prior to 

performing a region transformation action. 

Threshold Settings 
The threshold of the selected iso-contour or seed point region may be adjusted using the slider or by 

typing in an absolute value or percentage of maximum. Select the region in the image window to view 

the threshold setting in the Toolbox. 

Note that if you have a linked region in different time points, each time point can have a different 

threshold. Therefore, selecting the image sets the threshold slider to the correct value for the selected 

time point. 

The threshold used when projecting findings is taken from the time point or dataset (when viewing 

gated data) that is selected in the image views for the region. For example, let’s say you create a region 

on a Baseline study with a threshold of 3 SUV, and a Prior study with a 4 SUV threshold and then link the 

findings before projecting to unused by type. If the Prior image view is selected, a threshold region will 

be created on the current time point using 4 SUV. Likewise, if the Baseline study is selected when 

projecting, then it will create a threshold region on the Current study using 3 SUV. 
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Image Gallery 
The Image Gallery houses any bookmarks, key images, snapshots or secondary captures that have been 

created during a reading session. The objects in the image gallery may be included in a report, exported 

as .BMP, .PNG, .JPEG or DICOM Secondary Capture. Note that the image gallery may be filtered by time 

point by selecting the desired time point from the drop down menu. 

Upon double clicking a bookmarked image within the image gallery, the following will be restored: 

• Layout 

• Window/Level 

• Zoom 

• Crosshair position 

• Selected dataset/Phase (gated data, multi-phase CT data, multi-sequence MR data) 

If a session is restored that includes a DICOM secondary capture it will be displayed in the Image Gallery. 

You may choose that image and then select the ‘Switch to Secondary Capture screen’ icon ( ) to view 

it. 

Cine 
Any displayed MIPS or other data with multiple gates, sequences or phases may be controlled from this 

area. Tools are present for playing the MIP, reversing the direction of the MIP cine, and pausing the MIP 

cine. The slider bar is available to adjust the speed. There are also tools in the MIP window that may be 

accessed by hovering over the blue shaded area at the bottom of the MIP window. 

If you wish to have the MIP spinning upon load, you may set the preference in Tools -> Options on the 

View tab. Check the box next to ‘Automatically play MIP cine’. 

When gated data, multiple sequences of MR or multiple phases of CT are loaded, there is an option from 

the dropdown menu to select Items or Slices. Items refer to gate, sequence or phase depending on the 

data. Select Items to cine through the gates, sequences or phases, and select Slices to cine through the 

slices (or frames in a dynamic NM series)  

The cine may also be controlled by turning on the navigation controls on the toolbar. These controls are 

displayed by default on MIP views. 

 The frames in a dynamic flow study are played at a uniform rate and not in real-time. 
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Setting Window and Level 

Window Level Control Mode 

 Window and Level may be manually adjusted using the icon from the toolbar or click the right 

mouse button to access the context menu. The following describe the functionality: 

• Dragging right increases the brightness (decreases level) 

• Dragging left decreases the brightness (increases level) 

• Dragging up increases the contrast (increases window width) 

• Dragging down decreases the contrast (decreases window width) 

 Window Max tool changes the upper end of the window/level spectrum while the lower end is 

locked (i.e. For PET data, the lower value never goes below zero). 

 Normalize window and level tool allows you to click the left mouse button and drag the mouse to 

define an area on an image for which images are ‘normalized’. 

 Reset window and level tool returns to the original window/level settings that were displayed on 

initial launch. 

Window Level Active Text Control 
You may adjust window and level by clicking on the interactive text on the image window. As the mouse 

pointer hovers over these settings, the blue text becomes underlined. Click on that text to display the 

dialog box to define and select presets.  

You may set a custom color for the interactive text in Tools->Options on the Views tab. 

Visualization dialog box 
The visualization dialog opens for the study chosen as the active window. If the active window is a fused 

view, select the study for which you wish to set the visualization parameters from the list of available 

studies on the left. The study highlighted in blue is the selected study for which the settings will apply. 

The system supplies a selection of preset values as radio buttons on the Visualization dialog. 

 Custom presets may be created by entering custom values, a new name and then selecting the Save 

icon. 

Custom presets can be deleted by selecting them and then choosing the X button. For both PET and CT 

displays the default window and level settings applied upon launch may be overridden by ticking the box 

in the Window Level tab accessed from the Tools -> Options menu. 
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Window and level may also be set using the slider control at the bottom of the screen. The color map 

may be changed in this dialog box as well, along with transparency setting for fused views.  

 
NOTE: Window/level settings may be assigned to shortcut keys via the Tools -> Options menu. 

Window Level Slider Control 
Window and level settings for all datasets may also be adjusted using the slider control in the Toolbox. 

This control is available for whatever layer is selected in the layers panel. The units and values that the 

slider displays match those currently selected via the Window and Level Settings. 
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Normalize Window Level  

 XD3 provides a tool to normalize the window and level settings by selecting an area of an image 

that becomes the baseline from which the window and level settings are determined. This action can be 

accessed from Image -> Normalize Window and Level from the menu. This tool may be assigned to a 

hotkey or added to the toolbar via Tools -> Options on the User Interface tab. 

Use the left mouse button to click and then drag the mouse over the area to be used as baseline. Upon 

release of the left mouse button, the window and level changes instantly to reflect the baseline you 

have selected for normalization. 

Reset Window Level 

 Use the Reset Window Level tool to return to the original settings. This tool may be selected from 

the toolbar or selected from the menu via Image -> Reset Window/Level. 

This tool may be assigned to a hotkey via Tools -> Options on the User Interface tab. 

The original setting is determined by the same criteria as used to set the window and level on 

application start as described below: 

• If a window level preset applies to the layout it will be used. 

• Otherwise, if a modality specific preset has been set to override the values in the data on 

loading that will be used. 

• Otherwise, if window and level values are defined in the data, it uses the values in the data if 

they exist. 

• Otherwise, the window and level will be set to 0 – 100%. 
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Regions of Interest 

ROI Display 
ROIs are displayed as smooth regions within a shaped bounding box such as an ellipsoid or cuboid that 

can itself be used to obtain simple quantification statistics (e.g. Maximum PET SUV) in some 

circumstances. Regions may be displayed as voxel masks by selecting Quantify -> Show Smooth 

Contours. This allows a user to see all voxels included in a region for region quantification purposes.  

ROIs can be displayed differently within a time point depending on the review mode that is being used. 

One general rule is that they can only be displayed on registered datasets. Specifically, an ROI created 

on the CT can only be displayed on other data sets (e.g. the PET) if there is a meaningful registration 

between the two datasets. The datasets where shadowed regions are displayed can be modified via the 

Data Management Screen available from the Tools menu. This is particularly useful when viewing 

multiple gated datasets. 

Note that it will only be possible to edit (i.e. adjust position and size) ROIs on the dataset that they were 

created, however, the ROI can still be selected and its threshold adjusted. 

You may view and modify the PET quantification options by clicking on the SUV value in the image 

window (Quantification active text control). See Active Text Control section for more information. 

Creating an ROI 
ROIs may be created on any orthogonal image view using a variety of ROI tools from the Quantify menu 

or from the ROI drop-down menu on the toolbar. The tool you select to create a region will be 

remembered and that one will be displayed on the toolbar until another is selected. The other tools will 

still be available via the drop-down menu or may be added to the toolbar individually via the toolbar 

configuration on the user interface tab in Tools -> Options. 

ROI Tools 

 Region With Absolute Threshold: Click the left mouse button and drag to create a region using 

absolute threshold value set in Contouring preferences. 

 Region with % of Max Threshold: Click the left mouse button and drag to create a region using % of 

maximum threshold value set in Contouring preferences. The threshold value is expressed as a 

percentage of the maximum value within the bounding box of the region.  

 Region: Click the left mouse button and drag to create an ROI with threshold set at minimum. Used 

to quickly find max SUV in an area of interest. 

 Ellipse Region: Click the left mouse button and drag ellipse to create a region on a single slice. 
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 Rectangle Region: Click the left mouse button and drag rectangle to create a region on a single 

slice. 

 Seedpoint Region: Click the left mouse button anywhere in an area of interest to automatically 

generate an ROI based on a threshold value. The threshold may be adjusted using the Threshold Settings 

in the Toolbox on the left side of the screen. Use the slider for a manual adjustment or choose to use a 

percentage of maximum or a fixed value. A default threshold value may be set via Tools -> Options on 

the Regions tab. 

 CT Region Segmentation: Click the left mouse button inside the lesion and drag the bounding 

sphere outside the lesion to automatically generate a 3D region. 

 Adaptive CT Segmentation: Click the left mouse button inside a lesion on a CT volume and drag the 

bounding sphere outside the lesion to automatically create a 3D region. 

 Paint: Use to define or edit an ROI by painting voxels in an orthogonal/MPR image view. 

 Freehand Region: Click and drag to create a 2D region. Use paint and erase tools to edit. 

NOTE: Any of the ROI tools may be assigned to a hotkey via Tools -> Options on the User Interface tab. 

Editing an ROI 
Once a region has been created it can be edited, using either the controls specific to that region or the 

paint brush tools. A region may only be edited on the dataset on which it was created (i.e. not on a 

dataset on which the region is mirrored). A region created on a fused view may be edited on either 

dataset. 

Paint Brush Tools 

 Paint: Use to define or edit an ROI by painting voxels in an orthogonal/MPR image view. The paint 

tool operates from within a region. 

 Erase: Use to delete voxels from an ROI by moving the mouse over the region. The erase tool 

operates outside the region. 

 Freehand Region: Click and drag to scribble a region on a single slice. Use paint and erase tools to 

edit. 

To resize the ROI, select the ROI by clicking on it within the image views then dragging the handles from 

the desired corner. To move an ROI, drag the center of the region. Once edited via Paint or Edit, regions 

are no longer threshold regions and cannot be moved or resized. 
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Tool Settings 

All of the ROI creating and editing tools have per-tool settings that are accessed from the toolbox. The 

Region with Absolute Threshold, Region from % Max, Region, Ellipse and Rectangle Region tools are all 

analogous and share the same settings. Each of these tools creates a region with different initial settings 

but each can be made to behave like any of the other types by adjusting the settings in the Threshold 

Settings Panel. 

 
Threshold Settings Panel 

The top drop-down allows the region type to be switched between thresholding by absolute values in 

the selected quantification method, and thresholding by percentage of the maximum value within the 

region bounding box. The two text fields allow entering the lower and upper threshold values. A value of 

∞ signifies that the threshold is unbounded. The slider allows setting the threshold values directly. 

Pushing one of the thumbs to the limit of the slider will make that threshold value unbounded. 

 Region With Absolute Threshold: Creates a region with an unbounded upper threshold and a lower 

threshold defined in the preferences dialog. The threshold values are expressed in the currently selected 

quantification method of the dataset on which the region was defined. The threshold values are 

absolute values which may be modified in the Thresold Settings panel of the toolbox by entering values 

into the lower and upper threshold fields, or by modifying the lower and upper thumbs of the threshold 

slider. 

Contouring Preferences are found by selecting Tools -> Options from the menu and choosing the 

Findings tab. 

 Region with % of Max Threshold: Creates a region with an unbounded upper threshold and a lower 

threshold defined in the preferences dialog. The threshold values are expressed as percentages of the 

maximum value within the 3D bounding box of the region. The threshold values are percentages which 

may be modified in the Threshold Settings panel of the toolbox by entering values into the lower and 

upper threshold fields, or by modifying the lower and upper thumbs of the threshold slider. 

Contouring Preferences are found by selecting Tools -> Options from the menu and choosing the 

Findings tab. 

 Region: Creates a region with an unbounded upper and an unbounded lower threshold. This has 

the effect of creating an entirely filled region. The filled region may be turned into a thresholded region 

by modifying the lower and upper threshold values. 
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 Ellipse Region: Creates a region with an unbounded upper and an unbounded lower threshold. This 

has the effect of creating an entirely filled region. The filled region may be turned into a thresholded 

region by modifying the lower and upper threshold values. 

 Rectangle Region: Creates a region with an unbounded upper and an unbounded lower threshold. 

This has the effect of creating an entirely filled region. The filled region may be turned into a 

thresholded region by modifying the lower and upper threshold values. 

 Seedpoint Region: Creates a region with an unbounded upper threshold and a lower threshold 

defined in the preferences dialog. The threshold values are expressed in the currently selected 

quantification method of the dataset on which the region was defined. The threshold values are 

absolute values which may be modified in the Threshold Settings panel of the toolbox by entering 

values into the lower and upper threshold fields, or by modifying the lower and upper thumbs of the 

threshold slider. Unlike the other region types, the Seedpoint Region can only threshold by absolute 

value and cannot be changed to percentage of region max. 

Contouring preferences are found by selecting Tools -> Options from the menu and choosing the 

Findings tab. 

 Paint: Use to modify the selected region by painting additional areas. 

 Erase: Use to modify the selected region by removing areas. 

Naming a Finding 
When a finding is created, whether a region, ruler or bi-ruler, it may be linked to other types of findings. 

For example you may wish to link a region with a ruler for a single finding.  

Upon creation of a region of interest, a dialog box will display which allows you to name and describe 

your region. Type in a name or select from the dropdown list of optional names. You may add to, delete 

or edit the ‘Name’ list via Tools -> Options on the Findings tab.  

You may also type a description and if you’d like, select the color of the region by clicking on the pink 

box and choosing from the color palette. 

Indicate that the region is a lymph node by ticking the box. The box labeled ‘Quantified’ indicates 

whether statistics are calculated for the created region. This would be ticked by default.Enter a 

description you wish and click OK. 
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If you do not wish to be prompted to name each new finding you may disable this feature via Tools -> 

Options on the Findings tab. In addition, the list of preset strcutures names may be modified there as 

well by selecting the Suggestions button on the Findings tab. 
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Linking Selected ROIs 
Linking selected ROIs allows you to manually link a selected ROI to an ROI in a different time point for 

region tracking. Linking an ROI means that comparison statistics can be displayed between the ROIs that 

have been linked. In the Regions of Interest panel, use Ctrl and click the left mouse button to choose the 

regions you wish to link, and then simply click on the link button. 

 

Projecting an ROI 
To project an ROI to multiple time points, select the tool from the Findings panel. This will project any 

ROI created in a single time point to all other time points that are loaded into the layout at that time. 

The region will be created by threshold or percent of maximum depending on the method used to 

create the original ROI. The statistics for each time point will be displayed on the screen. The ROI can 

also be projected by volume and to a subset of time points. To do this, click the right mouse button on 

the ROI in the Findings panel and select the required option from the displayed menu. 

 
 

When propagating ROIs between time points, it is important to check that the threshold used is 

appropriate for the data in the time points. For meaningful comparison statistics to be displayed, the 

threshold should be the same in each time point. 

To see the threshold used, select the region in the time point and view the threshold slider or move the 

mouse pointer over the Region defined in the Regions of Interest panel in the Toolbox to display the 

tooltip. 

The threshold is also visible on the Regions Table. 

Link ROI button 
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Deriving a ruler from an ROI 
You may create a ruler from any previously created region of interest. A bi-ruler will be created in the 

slice with the greatest long axis and corresponding short axis within the boundaries of the selected 

region in the orientation of the selected view. The auto-ruler first finds the longest axis, then for that 

plane will find the longest short axis. Select the image view with the orientation from which you wish to 

derive the ruler, then in the Findings section of the Toolbox highlight the region you wish to use, click 

right and select Create Ruler from Region.  

 The Create Ruler from Region tool calculates the long and short axes from the ROI selected using 

mathematical approximations of the smooth ROI boundary. However, the resulting bi-ruler may not 

correspond to what the user considers to be the long and short axes that best characterize the lesion 

from a clinical point of view. It is important that the resulting Biruler is visually inspected and compared 

with the region used for creation to ensure the results are as desired. 

 The Create Ruler from Region tool uses mathematical approximations to the smooth ROI 

boundary when calculating the best bi-ruler placement. However, in some rare cases the 

approximations may result in a ruler that does not correspond exactly to the displayed boundaries or 

one that passes slightly outside the lesion boundary. The user should check the result of the tool to 

confirm that the ruler meets their expectations. 

Creating Multiple Threshold Regions from an ROI 
Create Multiple Threshold Regions allows multiple ROIs to be created at different threshold values.  In 

the Findings panel, select a threshold ROI and then click the Create Multiple Thresholds button to 

change the ROI to multiple thresholds.  Statistics for these ROIs will be displayed separately in the 

Findings Table.   

 

If the bounding box of any of the threshold ROIs is changed, then the Multiple Threshold Regions can be 

re-generated by clicking again on the Create Multiple Thresholds button. 

Thresholds can be set in Tools -> Options on the Findings tab.  Select Add to add a new threshold, Edit 

to edit the selected existing threshold, and Delete to delete a threshold. 
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Exporting ROI Intensities 
It is possible to export the intensity values of a particular region to a file for processing outside of XD. 

For every voxel included in a region the intensity of that voxel in the dataset on which it is defined is 

exported. Additionally, the intensities of all related datasets in the timepoint are also output for the 

same position. 

For instance, if a small region is defined on a PET dataset that covers only four PET voxels then the 

intensity of those four voxels are output. If a CT dataset is also loaded for the same timepoint then the 

intensity of the CT dataset at those four locations are also exported. 

The voxel values can be exported in CSV or XML format. Select File -> Export Region Statistics from the 

menu. 

 
The export region statistics dialog allows you to select exactly which region from which timepoint to 

export. In the example above two regions, Primary and Target, defined on the Anatomical role (CT in this 

case) on the Current timepoint are being exported to file. They are to be exported in CSV file format to 

the directory, C:\data\output. 

Appropriate Role 

For a standard PET/CT dataset it is common for both datasets to have the same number of slices and 

therefore the same resolution in the Z dimension. However, most CTs have twice the resolution in the X 

and Y dimensions meaning that there are four times as many voxels in the CT dataset as in the PET. 
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If a small region is defined on the PET that covers only four PET voxels then the corresponding CT region 

will contain 16 voxels. Exporting that region with the Functional (PET) role selected will export four PET 

intensity values and the corresponding CT intensities for the position in the center of those voxels. 

Exporting the same region with the Anatomical (CT) role selected will export 16 CT intensity values and 

the corresponding PET intensities for the position in the center of those voxels. 

Creating and Exporting RTSS 
It is possible to save and export as Radiation Therapy Structure Sets (RTSS) any volumes of interest 

created in XD3 for use in radiation therapy treatment planning systems. 

Upon creation of a region of interest, a dialog box will display which allows you to name and describe 

your region. Type in a name or select from the dropdown list of optional names. You may also type a 

description and, optionally, select the color of the region by clicking on the box showing the currently 

selected color, and choosing from the color palette. The chosen color will be the one used for the 

contours when creating the RTSS. 

If you are creating a region to use as an RTSS, you may select the appropriate type of structure from the 

‘interpreted type’ dropdown list. You may add to, delete or edit this list via Tools -> Options on the 

Findings tab. Enter your name if you wish and click OK. 

 
Once you are satisfied with the region, after creating and editing it, select File -> Export from the menu. 

Select RTSS from the Export dialog box and click OK. A second Export dialog box displays, as shown 

below. Select the study with which the RTSS should be associated, and select the dataset containing the 

region from the dropdown.  

Ensure the appropriate regions you wish to export are visible; and enter label, name, and description as 

desired. Click to place a tick in the box if you wish to have the original dataset exported along with the 

region(s); the original dataset is the one containing the region to be exported.  

Select the export destination and click OK. You must enter a label in order for the RTSS to be exported. 
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 XD3 creates the DICOM RT Structure Sets from the selected region as specified in the DICOM 

Standard. RTP systems may apply interpolation between the encoded contour control points that differs 

from their display in XD3. We recommend that the user takes screenshots of the regions used to create 

the contours, on an acquisition orientation view, and uses these to compare to the contour displayed 

within the RTP system to ensure that the exported contour is an accurate representation. 

It is also important to note that when exporting RTSS, XD3 creates contours in the geometry and slices 

of the original image data and not the geometry and orientation of the current MPR views. Therefore, it 

is important to review regions on acquisition orientation views before exporting to an RTP system. 

Similarly, if the system that imports structures generated within XD3 re-samples the image data for 

display, the contours may not appear to be in the same position as when displayed in XD3.  

Importing and Displaying RTSS 
XD3 can import DICOM RT Structure Sets (RTSS). RTSS do not appear in the Timepoint Selection dialog 

but are automatically loaded if the dataset that they reference is also loaded. 
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To be able to display the structures on reconstructed views, the loaded structures are converted into an 

internal volumetric representation. This allows all loaded structures to be displayed in any MPR view. 

The original contours in the RTSS are defined in the acquisition plane of the dataset. When comparing 

structures displayed in XD3 to the same structures displayed on a different system, the acquisition 

orientation must be used. 

All imported structures are added to the Findings panel in the Toolbox. By default, quantification is 

turned off for loaded structures. If quantification statistics are required for loaded structures then 

quantification must be explicitly turned on for those structures. To do this, double-click the name of the 

structure in the Findings panel and check the Quantified option. 

 Contour interpolation is applied to RTSS for display, however methods may vary between 

different vendors. XD3 uses a particular contour interpolation method which may differ to that used by 

other systems (such as TPS). This means that structures may display differently in XD3 when compared 

to other systems. In most cases such differences will be trivial and affect only the visualization, however 

it is recommended that screenshots of loaded structures be taken in the XD3 acquisition view and 

compared to the same structures as displayed on other systems. 

Display Findings Graph 
Depending on the findings created (i.e. rulers or regions) the findings graph will display a line profile for 

a ruler and the region intensity distribution for a region.  

The Region Intensity Distribution tool allows you to set categories for voxel intensities within a region 

of interest. These categories are reported in parts of the application that report the region statistics. 

These are reported via the image view statistics, the intensity distribution graphs from the Findings 

Table and from the regions tracking tab on the Findings Table. See the example below. 

 
NOTE: The density values displayed in this example are for demonstration purposes only 
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You may click the right mouse button to copy the intensity distribution graph to a Windows clipboard or 

to image gallery to send to PACS as DICOM Secondary Capture. 

NOTE: If an ROI is modified with an intensity distribution graph displayed, the updates will not be 

reflected until the intensity distribution graph is closed and re-displayed. This also applies if the 

intensity distribution categories are modified via the user preferences. 

The categories may be set in Options via Tools -> Options on the Region Intensity Distribution tab.  

Select the modality for which you wish to set intensity ranges from the list on the left. Select the 

quantification method from the dropdown menu. Click on New to create a new region intensity 

distribution definition. This will open the dialog box which allows you to set the number and range of 

intensity levels. 

Use the green ‘+’ to add a category and use the red ‘X’ to delete a category. For each category, add 

lower and upper bounds for the category range.  

Enter the names for your categories by double clicking the default name (i.e. air, water, contrast, bone, 

etc.), and click on the colored square to the left of the category name to select the color to represent 

that category in the graphical display. Click OK to continue and save your selections. Intensity 

distributions are per-user. Any intensity distributions that are added or modified by the user will be 

available for that user only. 

There is no restriction on the category ranges allowed within an intensity distribution. If two categories 

have overlapping ranges then it is possible for the sum of the percentages of the classification to be 

greater than 100%. Similarly, if there are gaps between the category ranges then it is possible for the 

sum of the percentages of the classification to less than 100%. For instance, an intensity distribution for 

PET SUV by body weight can be created with the following ranges: Type1 [1 – 3], Type2 [2 – 4] and 

Type3 [3 – 10]. If a region is created that contains only voxels whose SUV is greater than 2.0, then every 

voxel will be included in the Type1 category (100%), every voxel will be included in the Type2 category 

(100%), possibly, a non-zero amount of voxels will be included in the Type3 category. In this case the 

sum of the percentages will be greater than 200%. 

Region Intensity Distributions may be viewed, edited, cloned or created from the Region Intensity 

Distribution tab in the Tools -> Options menu. 

The Voxel Intensity Distribution feature relies on the accuracy of the registration when the ROI 

was created on one dataset and the intensity distribution statistics are viewed for the other datasets 

within the same time point. The registration should be checked for accuracy using the Registration 

Manager prior to using this feature. 
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PET SUV Calculation 

PET SUV calculations are based on variables defined in the loaded data. These include patient’s weight, 

height and sex, et cetera. XD3 allows these variables to be modified in the Quantification Parameters 

dialog. In certain circumstances, the application will correct the values stored in the data based on the 

DICOM Conformance statement information of particular scanners. For example, data from particular 

scanners will store the Radionuclide Total Dose in MegaBecquerels rather than Becquerels as specified 

in the standard. In this case, XD3 will perform the conversion automatically and raise a warning in the 

messages panel. 

Calculation by Body Weight 
One of the methods of calculating PET SUV in this application is by body weight. The following formula is 

used in this calculation: 

 

𝑆𝑈𝑉 =  
𝑎𝑣𝑒𝑟𝑎𝑔𝑒 𝑎𝑐𝑡𝑖𝑣𝑖𝑡𝑦 𝑖𝑛 𝑅𝑂𝐼 (𝐵𝑞𝑙/𝑚𝑙) 

𝑖𝑛𝑗𝑒𝑐𝑡𝑒𝑑 𝑑𝑜𝑠𝑒 (𝐵𝑞𝑙)
∗  𝑝𝑎𝑡𝑖𝑒𝑛𝑡 𝑤𝑒𝑖𝑔ℎ𝑡 (𝑔) 

Unit is g/ml. 

This method requires that all of the following information is available: 

• Administration date/time 

• Acquisition date/time 

• Injected dose 

• Radionuclide half-life 

• Decay correction method 

• Patient weight 

Calculation by Body Surface Area 
SUV by Body Surface Area (BSA) is calculated by using an approximation of the Body Surface Area. The 

following formula is used for this calculation: 

𝑆𝑈𝑉 =  
𝑎𝑣𝑒𝑟𝑎𝑔𝑒 𝑎𝑐𝑡𝑖𝑣𝑖𝑡𝑦 𝑖𝑛 𝑅𝑂𝐼 (𝐵𝑞𝑙/𝑚𝑙)

𝑖𝑛𝑗𝑒𝑐𝑡𝑒𝑑 𝑑𝑜𝑠𝑒 (𝐵𝑞𝑙)
∗ 𝐵𝑆𝐴 (𝑐𝑚)2 

Where the BSA is approximated using the following formula (by Du Bois and Du Bois): 

𝐵𝑆𝐴 (𝑐𝑚2) = [𝑝𝑎𝑡𝑖𝑒𝑛𝑡 𝑤𝑒𝑖𝑔ℎ𝑡 (𝑘𝑔)]0.425 ∗ [𝑝𝑎𝑡𝑖𝑒𝑛𝑡 ℎ𝑒𝑖𝑔ℎ𝑡 (𝑐𝑚)]0.725 ∗ 71.84 

Unit is cm2/ml. 

This method requires that all of the following information is available: 
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• Administration date/time 

• Acquisition date/time 

• Injected dose 

• Radionuclide half-life 

• Decay correction method 

• Patient weight 

• Patient height 

Calculation by Lean Body Mass 
SUV by Lean Body Mass (depending on the sex of the patient) is calculated using the following formula: 

𝑆𝑈𝑉 =  
𝑎𝑣𝑒𝑟𝑎𝑔𝑒 𝑎𝑐𝑡𝑖𝑣𝑖𝑡𝑦 𝑖𝑛 𝑅𝑂𝐼 (𝐵𝑞𝑙/𝑚𝑙)

𝑖𝑛𝑗𝑒𝑐𝑡𝑒𝑑 𝑑𝑜𝑠𝑒 (𝐵𝑞𝑙)
∗ 𝐿𝐵𝑀 (𝑔) 

Where the LBM is approximated using the following formulae: 

𝐿𝐵𝑀𝑀𝐴𝐿𝐸  (𝑘𝑔) = 1.10 ∗ [𝑝𝑎𝑡𝑖𝑒𝑛𝑡 𝑤𝑒𝑖𝑔ℎ𝑡 (𝑘𝑔)] −  128 ∗ [
𝑝𝑎𝑡𝑖𝑒𝑛𝑡 𝑤𝑒𝑖𝑔ℎ𝑡 (𝑘𝑔)

𝑝𝑎𝑡𝑖𝑒𝑛𝑡 ℎ𝑒𝑖𝑔ℎ𝑡 (𝑐𝑚)
]

2

 

𝐿𝐵𝑀𝐹𝐸𝑀𝐴𝐿𝐸  (𝑘𝑔) = 1.07 ∗ [𝑝𝑎𝑡𝑖𝑒𝑛𝑡 𝑤𝑒𝑖𝑔ℎ𝑡 (𝑘𝑔)] −  148 ∗  [
𝑝𝑎𝑡𝑖𝑒𝑛𝑡 𝑤𝑒𝑖𝑔ℎ𝑡 (𝑘𝑔)

𝑝𝑎𝑡𝑖𝑒𝑛𝑡 ℎ𝑒𝑖𝑔ℎ𝑡 (𝑐𝑚)
]

2

 

Unit is g/ml (remember to multiply LBM formulae above by 1000 to get them in g). 

This method requires that all of the following information is available: 

• Administration date/time 

• Acquisition date/time 

• Injected dose 

• Radionuclide half-life 

• Decay correction method 

• Patient weight 

• Patient height 

• Patient sex 

For more information please see: 

Reevaluation of the Standardized Uptake Value for FDG: Variations with Body Weight and Methods for 

Correction, by Sugawara et al, Radiology, November 1999. 

PET SUV from Acquisition 
PET SUV from Acquisition displays the SUV that certain scanner manufacturers calculate and store in the 

image data. 
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The PET SUV from Acquisition calculation underlying the display of this quantification option is 

outside the control of Mirada Medical. When PET SUV from Acquisition displays values, the number 

displayed is based on the stored value in the image data. Please contact your vendor for further 

information on this topic. 
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Active Text Control 

In the image window there is information about the patient, study and images displayed. Some of the 

text is for information only and other is ‘active text’ that may be used to adjust the image. The default 

colors of the text are blue and black/white. The black/white colored text is inactive and represents 

information such as patient name, sex, age, birth date, patient ID, hospital or facility name, the currently 

displayed field-of-view, series name and date obtained from the DICOM header.  

The blue colored text is the active text. When the mouse pointer hovers over any setting that may be 

adjusted in this manner the text becomes underlined. Click on the text to display the available control.  

Available Active Text Controls  
In the image window there are active text controls for: 

• Scale 

• Window and Level 

• Quantification Options (SUV) 

• Slice Index 

Custom color and font size for the on screen text may be set in user Preferences via the Tools -> Options 

menu on the Views tab. Click on the Interactive text color shown to display the color palette and select a 

new color. Font size may be changed by using the up and down arrows or double-clicking and entering 

the desired size. 
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Toolbar and Menus 

Toolbar icons 

 Undo: Click the left mouse button to undo the last operation in the Registration Manager. 

 Redo: Click the left mouse button to redo the last operation in the Registration Manager. 

 Toolbox: Toggle to show or hide the toolbox. 

 Patient Information: Toggle to add or remove patient information from image window. 

Information Overlays: Toggle to add or remove information overlays from image window. 

 MPR Cube Overlay: Select whether the MPR cube overlay is displayed. 

 Navigation Controls: Select whether navigation controls are displayed in the selected view. 

 Crosshairs: Toggle to add or remove crosshairs from image window 

 Crosshair ROI: Toggle to show statistics at the crosshair location. Use shift + mouse wheel to adjust 

size of ROI. 

 ROIs: Toggle to show ROIs in the image windows. 

 Annotations and Angles: Toggle to show annotations and angles in the image windows. 

 Visualization: Click to display the Visualization dialog box to change window, level, color palette and 

transparency. 

 Invert Color map: Click to invert the color map in the base image. 

 Adjust Window and Level: Use left mouse button to click and drag up, down, right and left to adjust 

contrast and brightness. 

 Window Max: Click to adjust the upper end of the window/level spectrum while the lower end is 

locked (e.g. for PET data, the lower value never goes below zero). This tool is accessed via drop down 

under Adjust Window and Level icon. 
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 Normalize window and level: Click the left mouse button and drag the mouse over an area on an 

image; this draws a square which is the area for which images are ‘normalized’. Note that this button is 

not present on the toolbar by default. 

 Reset window and level: Click to return to the original window/level settings. 

 Selection Mode: Puts cursor into a click-to-select mode for various on-screen objects like rulers, 

and simultaneously takes you out of any other mode such as zoom. 

 Transparency Tool: Click the left mouse button and drag up and down to change Overlay 

Transparency. 

When viewing fused images, artifacts may be introduced by poor alignment of findings between 

the image layers in the fused view. It is recommended that the registration accuracy is checked prior to 

image interpretation and the transparency of the layers is adjusted appropriately to view the layers in 

the fused views. 

 Slice Navigation: Click the left mouse button to move through the slices in an image set. 

 Place cross hair: Click the left mouse button and then place cross hair in image window where 

cursor will determine location from which to triangulate. 

 Image Zoom: Click the left mouse button and drag the cursor down across the image to enlarge, up 

to reduce in size. 

 Image Pan: Click the left mouse button and drag to move an image within its window. Used when 

areas of the image cannot be seen within the boundaries of the image window. 

 Rotate MPR Views: Click the left mouse button to rotate MPR views in the active image window. 

 Maximize view: Toggle to maximize an image window to full screen. 

 Reset pan and zoom: Click the left mouse button to restore original pan and zoom settings. 

 MIP: Click to display series in the selected view as Maximum Intensity Projection MIP) in a floating 

window. 

 Snapshot: Click the left mouse button icon then click the left mouse button in image window to 

save a snapshot as a key image. 
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 Magnifying glass: Click and drag small square to move over images and magnify to various levels. 

 Link/Unlink Crosshairs: Toggle to link and unlink crosshairs to perform a manual alignment. 

NOTE: The Ruler Tools below may be grouped into a ‘Favorites’ drop down menu on the toolbar where 

the last one used is remembered and displayed on the toolbar. This may be set in Tools -> Options on 

the User Interface Tab under Toolbar Configuration. 

 Temporary Ruler: Click the left mouse button and drag to measure a distance within an image view; 

ruler disappears after measurement is made. 

 Ruler: Click the left mouse button and drag to measure a distance within an image view; ruler 

remains visible after measurement is made. 

2D Ruler: Click the left mouse button and drag to measure short and long axis of a lesion 

simultaneously within an image view. The axes are always maintained at 90 degrees; adjustments may 

be made to either short or long axis by clicking left and dragging ends of ruler. 

 Angle: Click the left mouse button to place, expand and adjust to measure an angle. 

 Add Annotation: Click the left mouse button to identify the finding you wish to annotate, and then 

drag to place the annotation. Use the Rulers and Annotation window on the left of the screen to edit the 

label, delete the annotation or to show or hide a selected region. 

NOTE: The Region Tools below may be grouped into a ‘Favorites’ drop down menu on the toolbar 

where the last one used is remembered and displayed on the toolbar. This may be set in Tools -> 

Options on the User Interface Tab under Toolbar Configuration. 

  Region With Absolute Threshold: Click the left mouse button and drag to create a region using 

absolute threshold value set in Contouring preferences. 

 Region with % of Max Threshold: Click the left mouse button and drag to create a region using % of 

maximum threshold value set in Contouring preferences. 

 Filled Region: Click the left mouse button and drag to create a ROI with threshold set at minimum. 

Used to quickly find max SUV in an area of interest. 

 Ellipse Region: Click the left mouse button and drag ellipse to create a 2D region on a single slice. 
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 Rectangle Region: Click the left mouse button and drag rectangle to create a 2D region on a single 

slice. 

 Seed point Region: Click the left mouse button anywhere in an area of interest to automatically 

generate a ROI based on a threshold value. 

 CT Region Segmentation: Click the left mouse button inside the lesion and drag the bounding 

sphere outside the lesion to automatically generate a 3D region. 

 Adaptive CT Segmentation: Click the left mouse button inside a lesion on a CT volume and drag the 

bounding sphere outside the lesion to automatically create a 3D region. 

 Paint: Use to define or edit an ROI by painting voxels in an orthogonal/MPR image view. The paint 

tool operates from within a region. 

 Erase: Use to delete voxels from an ROI by moving the mouse over the region. The erase tool 

operates outside the region. 

 Freehand region: Click and drag to create a 2D region. Use paint and erase tools to edit. 

Many of these region and ruler creation tools may be grouped into a single drop-down menu on the 

toolbar which will remember the last used tool within the group. It is possible to configure the system to 

place each of these tools directly onto the toolbar by going to Tools -> Options…, selecting the User 

Interface tab and then selecting the Toolbar Configuration option. 

 Time Point Selector: Click to display and select the time point you wish to display. 

 Layout Selector: Click to display Registration Manager, Data QC, Findings Table, Report, Secondary 

Capture viewer or the layout of your choice. 

Show or Hide the Toolbar 
If desired, the toolbar may be hidden by selecting View -> Show Tool Bar from the menu. Tools located 

on the toolbar are also available from the menus and from the context menu found in the right mouse 

button when in an image window. This function may also be set to a hotkey in Tools -> Options. 

Configure the Toolbar 
You may configure the toolbar to show as few or as many of the tools that you wish to be displayed. 

From the Tools -> Options menu, select the User Interface tab and choose Tool Bar Configuration. Place 

a check in the box next to the tools you wish to include in the toolbar. When you are satisfied with your 

selections, press OK. The toolbar will update with your new selections immediately. 
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There are options in the toolbar configuration window to enable Favorites: options are Ruler Tools, 

Region Tools and Region Editing Tools.  

 
By placing a check in the box next to the Favorite tools, this group of tools is available as a dropdown on 

the toolbar, with the most recently used of the set displayed on the toolbar as the favorite. To avoid 

having the individual tools visible on the toolbar (in addition to the dropdown), you should uncheck the 

boxes next to the individual tools in the Tool Bar Configuration window. 
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Context Menu 
There is a context menu (also known as the floating toolbar) accessed by clicking the right mouse button 

anywhere in the image window. This toolbar contains the same functions as the main toolbar.  

You may configure the context menu to show as few or as many of the tools that you wish to be 

displayed. From the Tools -> Options menu, select the User Interface tab and choose Context Menu 

Configuration. Place a check in the box next to the tools you wish to include in the context menu. When 

you are satisfied with your selections, press OK. The context menu will update with your new selections 

immediately. 
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Displaying a MIP 

 The Maximum Intensity Projection or MIP Renderer is a tool for data visualization in 3D and is 

useful for obtaining an overview of the areas within the image data of a high intensity and as a tool to 

navigate to those regions. The MIP should not be used as the sole view used to interpret the image data. 

 Selecting the MIP icon from the toolbar, context menu or selecting Image -> Show as MIP from the 

menu will display a floating MIP window. 

Alternatively, you may use the MIP icon on the Toolbar, from the context menu or by using a hotkey. 

If you wish to have the MIP automatically spinning upon launch, you may set that preference in Tools -> 

Options on the Views tab. Place a check in the box next to ‘Automatically play MIP cine’. 

Additionally, you may also set the number of frames to be displayed for MIPs. This applies to exporting 

them as well. 

 
MIP tools are visible within the MIP window on the left side as shown in the example above. These 

buttons allow manual control of the MIP image, playing and pausing of the MIP cine, reversing direction 

of the cine, changing from 360° to 180° rotation, snapping to a sagittal view, and snapping to a coronal 

view. The speed of the cine is controlled with the slider in the Cine section of the Toolbox. 



  mm2357-6 
  FUXD-USER 
 

Mirada Medical | XD 65 

 

Exporting a MIP 
To export a MIP file, you must be in a layout that includes a MIP display. Be certain that your MIP 

window is the active window. Select File -> Export to display the Export window. Select MIP Images from 

the list and click OK. Select the range of MIP frames to export and click on Continue. Input Series 

Information and choose destination, browse for destination directory, provide filename and choose file 

format from the dropdown menu. Click OK to export the file. The number of frames exported will be the 

same as set in Tools -> Options on the Views tab. 
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File Menu 

Export  
Options for exporting include: 

• Original Data – the Export screen will display for you to select which series you wish to export. 

The dataset selected in the ‘Associate with’ field will be exported. Provide the information about 

the destination and select OK.  

• Resampled Volumes – the system will display the Export Selection Screen to allow you to save a 

resampled volume to the destination of your choice. The resampled volume creates a new series 

that has registration applied so that the new series could look like it was from a hybrid scanner 

(i.e. slice thickness, geometry, resolution are the same). You will also be prompted to specify to 

which dataset the exported one should be re-sampled. Upon selecting OK from the Export 

Selection Screen, the system will save the re-sampled dataset to the specified destination 

• Registration – the system will display the Export Selection Screen to allow you to save a 

registration to a destination of your choice. This exports a spatial registration DICOM object – 

this object along with the two original series when reloaded are in a saved state, and are 

displayed as a record of the prior registration. There are other fields present to select which 

registration relationship is being exported. Upon selecting OK from the Export Selection Screen, 

the system will save the selected registration to the specified destination. Multiple restores 

registrations can be reapplied via the registration manager in the Loaded Registrations panel. 

• Slice Range - This option allows you to export a range of slices from an image of your choice. 

Upon selection, the system will display an Export Slice Range screen for the selected view. You 

will be able to preview the image of the view to be exported (the preview will not be available 

for off axis slice ranges. In this case, the slices should be reviewed prior to selecting the export 

slice range option). Use the start and end markers on the image preview to set the range of 

slices to be exported. The larger the width and height settings, the larger the output files will be. 

Place a check in the box if you wish to include patient information in the exported file. Likewise, 

place a check in the box if you wish to use default volume size on export. When the range is set, 

select Continue. 

Use the Cancel button to dismiss the dialog. 

Input information about the series using the drop down menu and by typing in desired 

descriptions and information about the data series. Use drop down menu to select the 

destination and file format. Browse to select the destination directory, and then type in a name 

for the file. Click OK to export the file. An Export window will appear to confirm successful 

export. 

Slice ranges may be exported as DICOM SC, JPEG, PNG, BMP and AVI. The available formats will 

depend on the export destination selected. Note that the AVI file will be uncompressed data and 

may be quite large depending on the range selected. 
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• MIP Images - You must be in a layout that includes a MIP and have the MIP window as the 

active window in order to export MIP data. The Export MIP slices window allows you to select 

the number and range of MIP frames you wish to export. Type in the numbers or use the arrows 

to scroll to reach the desired value. Check the box to include the patient information in your 

export. You may check the box to use default volume size. Press Continue to input Series and 

Destination information. 

Select the series with which you want the exported MIP slices associated from the dropdown 

menu. You may type in additional information in Series Description, Performing Physician and 

Operator Name fields. Use the Send To dialog box to select the destination, directory, file name, 

and file format for the export. Note that you may export the MIP as AVI file via the Destination 

drop down menu. Select OK to export the data. You will see a progress bar during the export 

and a dialog box confirming a successful export.  

NOTE: The number of frames displayed in MIPs can be set in Tools ->Options. The displayed number of 

frames is what will be exported. 

• RTSS – This option allows you to export RT Structure Sets generated from volumes of interest. 

Select the study with which the RTSS should be associated, and select the dataset containing the 

region from the dropdown. 

Ensure the appropriate regions you wish to export are visible; and enter label, name, and 

description as desired. Click to place a tick in the box if you wish to have the original dataset 

exported along with the region(s); the original dataset is the one containing the region to be 

exported. 

Select the export destination and click OK. You must enter a label in order for the RTSS to be 

exported. 

NOTE: Series Description, Performing Physician and Operator Name are remembered on a per user 

basis. 

Save Session 
Under the File menu, you will find an option to Save Session. This option allows you to exit the current 

session, but save all of your work. The following items are saved as DICOM objects so you can reload 

them along with the images and begin where you left off at the end of the previous session: 

• Registrations 

• Findings  

• Key Images 

• Bookmarks 

• Rulers 

• Bi-rulers 

• Annotations 

• Angles 
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• Modified PET Quantification Parameters (e.g. weight, height) 

• Data Management screen order/anchor settings (e.g. for gated data) 

These items are stored using standard DICOM objects and may be sent to and retrieved from PACS. 

There is an option to save these objects as a single series for compatibility with PACS. Compatibility 

mode is enabled by default and is useful if your PACS does not support the other DICOM objects. If you 

choose to disable this feature, you may do so via Tools -> Options on the Session tab. 

If there is a study loaded for review when you choose a new dataset for review, you will be prompted to 

choose whether or not you would like to save your current session. You may wish to automatically save 

each session upon exit. This preference may be set via the Tools -> Options on the Session Tab. 

  



  mm2357-6 
  FUXD-USER 
 

Mirada Medical | XD 69 

 

Create a Viewer 
From the File menu, you may select Create a Viewer to generate a volumetric DICOM viewer of the 

dataset(s) you are currently viewing. The viewer may be burned to a CD or saved to the file system for 

transfer to other output device (USB drive) and shared with a referring physician or patient, for example. 

When the Create Viewer dialog box appears, select from the dropdown menu whether you wish to save 

the viewer to a destination on the file system or burn directly to CD. If you choose file system as your 

destination, enter a name for the folder where the viewer will be stored and browse to select the 

location for the folder. Select OK to continue. A progress bar will be displayed as the viewer is created. 

Along with the images, any bookmarks, registrations, ROIs, rulers, annotations, and angles that were 

created during the reading session will be written to the viewer.  

If you are using a thin client system, you will save to the file system on the local machine and then burn 

to CD using Windows Explorer. 

To run the viewer, double click on the Start Viewer file. 

Send to Casebook 
When the Casebook plug-in is installed you may export a dataset(s) to a location on the file system from 

which they may be imported in Casebook. 

Send to Caseaccess 
When Caseaccess plug-in installed you may send a dataset(s) and report to the Caseaccess server where 

it can be accessed remotely. See Caseaccess User Guide for detailed information on the Caseaccess 

product. 

Send to Casemeeting 
When the Casemeeting plug-in is installed you may export a dataset(s) to the Casemeeting server where 

it may be accessed remotely for a tumor board meeting or other multidisciplinary conference. See 

Casemeeting User Guide for detailed information on the Casemeeting product. 

Exit 
This action will exit the application. Using this method to exit the application preserves the number of 

displayed XD3 windows for re-display on the next launch. 
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Edit Menu 

Undo  
Undo the previous step. Also Ctrl + Z. 

Redo 
Redo the previous step. Also Ctrl + Y. 

Capture View 
Adds currently selected view to the Image Gallery. Also Ctrl + E. 

Copy View to Clipboard 
Copies the currently selected view to the clipboard. Also Ctrl + K. 

Capture Screenshot 
Adds a screenshot of this window to the Image Gallery. Also Ctrl + Shift + E. 

Copy Screenshot to Clipboard 
Copies a screenshot of this window to the clipboard. Also Ctrl + Shift + K. 

Cut 
Cut a currently selected report item. Also Ctrl + X. 

Copy 
Copy a currently selected report item. Also Ctrl + C. 

Paste 
Paste a currently selected report item. Also Ctrl + V. 
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View Menu 

Show Toolbar 
Select to add or remove the Toolbar from the top of the image window. 

Show Toolbox 
Select to add or remove the Toolbox from the left side of the image window. 

Show Patient Information 
Select to add or remove patient information in the image window.  

Show Timepoint Information 
When launched with more than one timepoint, select to show timepoint label and date in the image 

window. 

Show Information Overlays 
Select to add or remove information overlays in the image window.  

Show Fused Overlays 
Select whether the fusion overlays are visible.  

Show Volume Bounds 
Select to add or remove volume bounds in the image window.  

Show MPR Cube 
Select whether the MPR cube overlay is visible. 

Show Navigation Controls 
Select whether navigation controls are displayed in the selected view. 

Show Crosshairs 
Select to add or remove crosshair in the image window.  

Show Volume Crosshair 
Select to calculate volume statistics at the location of the crosshair. Use shift + mouse wheel or ‘-‘ and 

‘=’ to adjust size.  

Show ROIs 
Toggle whether regions of interest are displayed in the image windows.  

Show Annotations 
Toggle whether annotations and rulers are displayed in the views.  
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Show Region Statistics 
Select whether region statistics are visible in the views.  

Image Menu 

Invert Color Map 
Click to invert the color map in the base image. 

Window/Level 
Use left mouse button to click and drag up, down, right and left to adjust contrast and brightness. 

Window Max 
Use the left mouse button to adjust only the upper level of the window/level spectrum.  

Normalize Window/Level 
Click the left mouse button and drag the mouse over an area on an image. This draws a rectangle to 

define the area for which images are ‘normalized’. 

Reset Window/Level 
Click to restore initial window and level settings. 

Select 
Puts cursor into a click-to-select mode for various on-screen objects like rulers, and simultaneously takes 

you out of any other mode such as zoom. 

Overlay Transparency 
Click the left mouse button and drag up and down to change Overlay Transparency. 

Navigate Slices 
Click the left mouse button to move through the slices in an image set. 

Place Crosshairs 
Click the left mouse button and then place cross hair in image window where cursor will determine 

location from which to triangulate. 

Zoom 
Click the left mouse button and drag the cursor down across the image to enlarge, or up to reduce in 

size. 
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Image Pan 
Click the left mouse button and drag to move an image within its window. Used when areas of the 

image cannot be seen within the boundaries of the image window.  

Rotate  
Click the left mouse button and rotate the orthogonal orientation in the active image window. 

Maximize View 
Toggle to maximize an image window to full screen. 

Zoom Reset  
Resets zoom and pan for all views. 

Show MIP Window 
Click to display a floating MIP window. MIP controls are present on the left hand side of the view. 

Controls are present for playing and pausing of the MIP cine, speed adjustment, snapping to a sagittal 

view, snapping to a coronal view and reversing direction. 

Snapshot 
Click the left mouse button icon then click the left mouse button in image window to save a snapshot as 

a key image. 

Switch Timepoint 
Select to change the displayed time point when multiple time points are loaded. 

Quantification Settings 
Select which quantification method to use for the datasets in the current view. For datasets that have 

configurable quantification parameters, a Quantification Options button is also available. Selecting the 

Quantification Options button will bring the relevant modality-specific dialog box for setting the 

parameters. 

PET 

The PET Quantification Parameters dialog allows the following parameters to either added, updated or 

removed: patient sex, height, weight, acquisition date and time, administration start date and time, 

dose and radiopharmaceutical half-life. 

Window/Level Presets 
Select to choose from a list of preset window and level settings. Preset window and level settings may 

be set to hotkeys via Tools -> Options on the Window/Level tab. 

Visualization 
Select to display a dialog box to choose Quantification Method, Window/Level setting and Color Map 
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Crosshair Bindings 
Select to configure crosshair bindings. Choose from: 

• All 

• None 

• Single Series 

• Single- Timepoint 

Zoom Bindings 
Select to configure zoom bindings. Choose from: 

• Axial + Coronal/Sagittal 

• Per Plane 

• All 

• None 

Pan Bindings 
Select to configure pan bindings. Choose from: 

• Per Plane 

• None 

Window/Level Bindings  
Select to configure window/level bindings. Choose from: 

• All 

• By Timepoint 

• Base and Overlay 

• Base and Overlay by Timepoint 

MPR Orientation Bindings 
Select to configure MPR orientation bindings. Choose from: 

• Per Plane 

• Single Series 

• None 

Interpolation Method 
Select the interpolation method to use for all views. Choose from: 

• Nearest neighbor 

• Linear 

• Cubic Spline 
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Crosshair Style 
Select the crosshair style to be used for all views. Choose from: 

• Target 

• Plain 

• Open 

• Fade 

• Frame Marker  

Volume Crosshair Size 
Increase or decrease the size of the crosshair volume when using the crosshair as an ROI. The size of the 

crosshair volume may also be increased or decreased using shift + mouse wheel or using ‘-‘ and ‘=’ 

hotkeys. 
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Registration Menu 

Run Automatic Rigid 
Select to automatically run the rigid registration algorithm. You may also use the F2 key for this. 

Run Automatic Deformable 
Select to run the automatic deformable algorithm. You can also use the F5 key for this. 

Smooth Deformation 
Takes an existing deformable registration and filters it to reduce large deformations. Successive 

iterations of the Smooth Deformation command further reduce the deformation field until it reaches a 

maximum smoothness. This tool may be useful when applying CT deformable registrations to PET 

overlays. 

Show Displacement Value 
The system displays a circle, an equal distance around the crosshair, with the distance being equivalent 

to the amount of deformation. The system will indicate the distance in millimeters. If there is zero 

deformation, the Displacement Value will be the same size as the crosshair. 
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Displacement View 
These are Quality Assurance tools which allow you to visualize the extent of the deformable registration 

applied. The deformation of the data may be shown as a Displacement Map, a Displacement Grid, or 

Displacement Arrows. These controls are only available when the registration applied has been either 

automatic CT to CT deformable or multi-modal deformable. 

When viewing the Displacement Map, the areas of deformation are indicated by a color map. Warm 

colors such as red and yellow indicate high areas of deformation; cool colors such as blue and green 

indicate areas of low displacement. 
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When viewing the Displacement Grid, the grid is shown over the target-overlaid-on-source view which 

indicates areas of low and high displacement. Areas of high grid displacement indicate high areas of 

deformation. 
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When viewing the Displacement Arrows, the amount and direction of deformation or displacement are 

indicated by arrows, where the length is proportional to the amount of deformation. 

 

Overlay Type 
Select registration overlay type. Choose from checkerboard or inset. 

Unlink Crosshairs 
Click to unlink the crosshairs between time points to allow scrolling of each study separately. Unlinking 

the crosshairs changes the crosshair bindings to ‘Single Timepoint’. 

When linking crosshairs, the inter-time point registrations will be replaced with a translation based on 

the current crosshair positions in each time point. 

This functionality is the same as the Link/Unlink tool ( ) on the toolbar. 

Registration Manager 
Registrations other than the automatic schemes defined in the review modes are performed from the 

registration manager. This is the only place these tasks can be performed. The Registration Manager 

screen may also be displayed from any of the layout selectors. 
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See Registration Manager section of this document for details. 

  



  mm2357-6 
  FUXD-USER 
 

Mirada Medical | XD 81 

 

Quantify Menu 

Drop 1cm Sphere 
Place your cursor where you would like to define a reference region. Select Quantify -> Drop 1 cm3 

sphere to drop a 1.0cm diameter region. Name the region as ‘Reference’ in the Regions of Interest 

section of the Toolbox or select Reference from the dropdown menu of the Findings dialog box. This 

reference region will enable ratio statistics in the PERCIST and Advanced tabs in the Findings Table.  

Drop 3cm3 Sphere 
Place your cursor where you would like to define a reference region. Select Quantify -> Drop 3cm3 

sphere to drop a 3.0cm diameter region. Name the region as ‘Reference’ in the Regions of Interest 

section of the Toolbox or select Reference from dropdown menu in the Findings dialog box. This 

reference region will enable ratio statistics in the PERCIST and Advanced tabs in the Findings Table.  

Drop Volume Crosshair Sphere 
Place your cursor where you would like to show statistics at the crosshair location. Use shift + mouse 

wheel or the ‘-‘ and ‘=’ keys to change the size of the region.  

Temporary Ruler 
Click the left mouse button and drag to measure a distance within an image view; ruler disappears after 

measurement is made. 

Region with Absolute Threshold 
Click the left mouse button and drag to create a ROI based on absolute threshold values set in 

Contouring Preferences. Region statistics will be displayed next to the region on the image window. 

Contouring Preferences are found by selecting Tools -> Options from the menu and choosing the 

Findings tab.  

Region with % of Max 
Click the left mouse button and drag to create a ROI based on a percentage of maximum value set in 

Contouring Preferences. Region statistics will be displayed next to the region on the image window. 

Contouring Preferences are found by selecting Tools -> Options from the menu and choosing the 

Regions tab.  

Region 
Click the left mouse button and drag to create a ROI. The threshold is set at minimum and the region 

statistics will be displayed next to the region on the image window. This is a quick way to measure a max 

SUV. 
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Ellipse Region 
Click the left mouse button and drag to create an elliptical 2D region on a single slice. 

Rectangle Region 
Click the left mouse button and drag to create a rectangular 2D region on a single slice. 

Seedpoint Region 
Click the left mouse button anywhere in an area of interest to automatically generate an ROI based on a 

threshold value that is then used to grow the region from the selected point for all connected voxels 

that exceed the threshold. 

CT Region Segmentation 
Click the left mouse button within the lesion and drag to expand the sphere to identify the lesion to 

segment. The outer solid circle is a firm boundary for the segmentation, therefore the region will not 

extend beyond this line. The inner dotted line indicates the area used to indicate the interior of the 

lesion and guides the segmentation algorithm. It may be necessary to initiate the segmentation from a 

non-central area in the lesion to exclude nearby structures to be avoided, such as ribs or mediastinal 

structures. The tool will remain active in the event that multiple attempts are needed for desired 

segmentation. Use ‘Esc’ or the ‘Select’ function to deactivate the segmentation tool or to begin 

segmentation of a new lesion. Once the lesion is segmented, a biruler may be automatically derived. 

Adaptive CT Region Segmentation 
Click the left mouse button within the lesion and drag to expand the sphere to identify the lesion to 

segment. The outer solid circle is a firm boundary for the segmentation, therefore the region will not 

extend beyond this line. The inner dotted line indicates the interior of the lesion and guides the 

segmentation algorithm. It may be necessary to initiate the segmentation from a non-central area in the 

lesion to exclude nearby structures to be avoided, such as ribs or mediastinal structures. The tool will 

remain active in the event that multiple attempts are needed for desired segmentation. Use ‘Esc’ or the 

‘Select’ function to deactivate the segmentation tool or to begin segmentation of a new lesion. This tool 

differs from the CT Region Segmentation tool in that it will use the current window and level to aid in 

the identification of boundaries. 

Note that Findings created using the CT Region Segmentation Tools will Project by Volume, meaning 

that the algorithm is not re-applied on project. Instead the shape is preserved and the position in the 

target volume is calculated from the transformation between the source and target volumes.  

 The CT Region Segmentation tools estimate a lesion boundary based on image contents and the 

user initialization and does not attempt any automated detection of lesions. The quality of the results 

need to be checked for accuracy by the user prior to being used.  
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Ruler 
Click the left mouse button and drag to measure a distance within an image view; ruler remains visible 

after measurement is made. 

2D Ruler 
Click the left mouse button and drag to measure short and long axis of a lesion simultaneously within an 

image view. The axes are always maintained at 90 degrees; adjustments may be made to either short or 

long axis by clicking left and dragging ends of ruler. 

When defining a 2D ruler, the measurement associated with a line is displayed in the same color 

as the line to which it pertains. When the measurements are similar, the colors should be checked to 

identify the pertaining line.  

Angle Tool 
Click the left mouse button to place, expand and adjust to measure an angle. 

Annotation 
Click the left mouse button to identify the finding you wish to annotate, and then drag to place the 

annotation. Use the Rulers and Annotation window on the left of the screen to edit the label, delete the 

annotation or to show or hide a selected region. 

Region Painting Brush Size 
Use menu to increase or decrease the size of the region painting brush or to select from a list of 

predefined brush sizes Paint 

Select to define an ROI by painting voxels in an orthogonal/MPR image view. 

Erase  
Select to erase from an ROI by moving the mouse cursor over the voxels in a region. 

Delete All 
Select to delete all the regions and rulers created during the current session. 

Show Smooth Contours 
Select to show ROIs with smooth contours 

Finding Tools 
Although the following tools are available from the menu, it would be most efficient to assign them to 

hotkeys via Tools -> Options and selecting the Configure Hotkeys button on the User Interface tab. 

• Delete 

• Copy Statistics to Clipboard 
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• Copy Statistics to the Image Gallery 

• Create Ruler from Region 

• Create Multiple Threshold Regions: This creates multiple threshold ROIs from a previous 

threshold ROI.  Thresholds are pre-set in Tools -> Options under the Findings tab. 

 This action is also available from the toolbar. 

• Go to the Finding 

• Display Findings Graph 

• Go to hottest voxel 

 If the Go To Hottest Voxel tool is used on a region with more than one voxel with the highest 

intensity value, then only one of these voxels will be identified. 

• Toggle to indicate lymph node 

• Unlink 

• Link: There are two types of findings: rulers and regions. Rulers include uni-rulers, bi-rulers and 

angles (annotations are not classed as findings). Regions include isocontour regions (with 

threshold), filled regions, 2D rectangles, 2D ellipses and regions painted with the freehand paint 

tools. Ruler findings can always be linked to other ruler types. They can also always be linked to 

region types. Region findings can be linked to ruler findings but are restricted as to which other 

regions they can be linked. A region can only be linked to another region that was defined on 

the same data role. E.g. a region defined on the Anatomical data role in General Oncology 

Review can only be linked to another region defined on the Anatomical role and not to one 

defined on the Functional role. This is further restricted to only being able to be linked to 

another region defined on the same role but not on the same dataset. E.g. a region defined on 

gate 1 of a gated CT assigned to the Anatomical role can be linked to a region defined on gate 2 

of the same gated CT, but not to another region defined on the same gate 1. This restriction 

does not apply across time points. A region on gate 1 of a CT on the baseline time point can be 

linked to a region defined on gate 1 of a CT on the current time point. 

• Show/Hide regions 

• Project to all by type : with a region selected, this option will propagate a finding to the 

equivalent dataset designation in all time points by recreating the region in each time point 

using the means by which the region was originally created (i.e. absolute threshold, % max 

threshold). If the region exists in multiple time points, then the value will be taken from the 

selected time point.  

• Project to all by volume: with a region selected, this option will project the region to the 

equivalent datasets designations in all time points by maintaining the volume of the original 

region. If the region exists in multiple time points, the volume value will be taken from the 

selected time point.  
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• Project to all within volume by type: with a region selected, this option will project the region 

to all datasets from the same frame of reference (i.e. bins of a gated dataset, phases of a multi-

phase CT or sequences of multi-sequence MR) and create shadows on each of them. If the 

region exists in multiple datasets, then the absolute threshold value is taken from the selected 

dataset. 

• Transform to all: with a region selected, the region will be transformed to the equivalent 

dataset designation in all time points using the existing registration to transform the ROI shape. 

If the region exists in multiple time points, then the selected time point will be propagated.; 

• Project to remaining by type: with a region selected, this option will propagate the selected 

region to the equivalent dataset designation in time points where the region does not already 

exist by recreating the region in each of the time points using the means by which the region 

was originally created (i.e. absolute threshold, % maximum threshold) 

• Project to Remaining by volume: with a region selected, this option will propagate the region to 

the equivalent dataset designation in time points where the region does not already exist by 

maintaining the volume of the propagated region. If the region exists in multiple time points, 

then the volume value will be taken from the selected time point 

• Transform to remaining: with a region selected, this option will propagate the region to the 

equivalent dataset designation in all time points that do not contain the region. The existing 

registration will be used to transform the ROI shape. If the region exists in multiple time points, 

then the selected time point will be propagated. 

• Project to remaining within timepoint by type: with a region selected, this option will project 

the region to all datasets from the same frame of reference (i.e. bins of a gated dataset, phases 

of a multi-phase CT or sequences of multi-sequence MR) where the region is not currently 

defined and create shadows on all datasets to which the role on which the region was defined 

are linked. If the regions exists in multiple datasets, the absolute/threshold value will be taken 

from the selected dataset. 

• Transform to all within timepoint: with a region selected, this option propagates the region to 

all datasets within the same frame of reference (i.e. bins of a gated dataset, phases of a multi-

phase CT or sequences of multi-sequence MR) using the existing registration to transform the 

ROI shape. If the region exists in multiple datasets within the same frame of reference, the 

selected region will be propagated. 

• Transform to remaining within timepoint: with a region selected, this option projects the 

region to the other datasets within the data designation (same frame of reference) that do not 

contain the region, using the existing registration to transform the ROI shape. If the region exists 

in multiple datasets within the designation, the selected region will be propagated. 

• Options… (displays the Findings tab in Tools -> Options) 
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 Regions resulting from performing the Transform to All, Transform to Remaining, Transform to 

All within Timepoint and Transform to Remaining within Timepoint actions are highly dependent on 

the quality of the registration that exists between the dataset on which the source region exists and all 

the datasets to which the region is to be transformed. It is recommended that quality checks be 

performed within the Registration Manager screen on the accuracy of the registrations prior to 

performing a region transformation action. 
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Tools Menu 

Options 
Select to display Preferences Window. XD3 allows certain preferences to be applied on a per user basis. 

These settings are remembered between runs of the application. See the User Preferences section for 

further detail. 

Magnifying Glass 
Click and drag a small rectangle to move over images and magnify to various levels. Right click to change 

magnification factor. The magnifying glass may also be resized by dragging its corner. 

Layout Editor 
Select to create and save a custom layout. See Custom Layout section of this document for details. 

New Color map 
Select to create and save a simple custom color map. Provide a name for the color map, then right click 

to add and define a point on the color spectrum. To remove a point, click and drag it away from the 

color bar. Select OK to save the color map and indicate whether you would like it saved for the current 

user or all users. If you need to create a more complex color map, please contact Mirada Customer 

Support or the vendor through which you purchased Mirada software. 

Data Management 
The Data Management screen is available in review modes which support either gated data, multiple-

sequence MR or multi-phase CT. This screen allows the user to specify the shadowing behavior for 

regions for the data loaded into the review mode. It also contains the default shadowing logic for each 

review model. Modifications made to this screen are reflected in any saved session. 

The contents of this screen are included in saved and restored sessions.  

See the Data Management section for more information. 
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Window Menu 

New Window 
Allows you to open an additional window for multi- monitor display. Window size and placement is 

saved between launches of the application. 

Full Screen 
Allows you to maximize the amount of screen space that is available for displaying images. The Toolbox 

and Toolbar are removed from the view. This function is assigned to a hotkey (F11). 

Back to Layouts 
Select Back to Layouts from the Data QC, Registration Manager, Findings Table, RT Planning or Report 

screens to return to the previous image window. 

Data QC 
The Data QC tool is provided to allow you to view attributes from datasets loaded into the application 

for review. Attributes such as scanner manufacturer, software version, slice thickness, kVP, X-ray tube 

current and several others may be displayed for the CT data. Likewise, software version, injected dose, 

delay time, half-life, patient height, patient weight and additional attributes are available for PET data.  

If you wish, you may perform validation of this data based on limits that you define via Preferences 

found on the Data QC tab from Tools -> Options menu. For example, you may want to be warned if the 

delay time variance from the time of injection to time of scan between time points is greater than a 

certain amount of time. This Data QC screen will show you the attributes and flag any that are outside 

the tolerance levels you have set. Additionally, the Data QC screen may be included in a custom report. 

You may choose which attributes are visible and whether you would like to be prompted to display the 

Data QC screen on startup if there are validation warnings.  

The Data QC screen may be displayed via the Window menu, on the toolbar layout selector, from the 

on-screen layout selector (Ctrl + Tab) or via a hotkey set in Tools -> Options on the User Interface Tab. 

See User Preferences section for detail on setting hotkeys. 

See User Preferences section for detailed instruction on setting up the Data QC items that you wish to 

have visible on your Data QC screen and which attributes you wish to validate when data are loaded. 

Registration Manager 
Registrations other than the automatic schemes defined in the review modes are performed from the 

registration manager. This is the only place these tasks can be performed. The Registration Manager 

screen may also be displayed from any of the layout selectors. See the Registration Manager section of 

this document for details. 
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Findings Table 
Displays the Findings Table which displays the statistics for any regions of interest that have been 

defined on the currently displayed images. Findings Table may also be accessed from any list of available 

layouts including drop down lists and transparent list accessed with Ctrl + Tab. Also, Findings Table may 

be found in the Toolbox from either the Regions of Interest panel or Rulers and Annotation panel. 

Report 
Displays the reporting feature which allows you to create custom reports based on report templates. 

Default templates are provided for each review mode, but you can make modifications and save them 

back to the same or a new template. Report Screen may also be chosen from any list of available layouts 

including the drop down lists and the on-screen list accessed with Ctrl + Tab. See the Reporting Section 

of this document for details on creating and editing custom reports. 

Secondary Capture 
This screen allows the interactive viewing of secondary capture images created within the application. It 

also allows images loaded (prior bookmarks, image stacks) to be interactively viewed and a cine played 

where appropriate. 

Available Layouts 
The hanging protocols available for display of images within each review mode are displayed via the 

Window menu. Each Review Mode contains a selection of Layouts suitable for the selected data sets. 

These layouts may also be accessed either from the dropdown menu in the upper right corner of the 

image window or by using Ctrl + Tab keys simultaneously to bring up a transparent layout selection 

menu. When using Ctrl + Tab, hold down on the Ctrl key and toggle the Tab key to scroll through the on-

screen menu of layouts. Layouts may also be selected by clicking on them in the transparent layout 

selection window. 
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Help Menu 

Help 
Displays this Help documentation. Help may also be accessed by using the F1 key. 

License 
Displays license details. License details may not be visible if your Mirada software is integrated into a 

third party workstation. 

Generate Support Package 
Select to initiate the creation of a zip file to a location of your choice containing the following readable 

information that is often required during a Customer Support inquiry. The following information is 

included: 

• Machine settings such as Name and IP Address 

• A configuration comparison list of files found in the XD3 bin folder (Factory vs. Current) 

• Public and current user settings 

• XD3 logs present on the system: XD3 log, XD3 debug log, XD3 trace log (if present) 

Enable Debugging 
Select to allow a development environment to connect to the running XD3 instance. This is applied until 

the XD3 process is restarted. This feature should only be enabled on advice of Mirada support 

personnel. 

Update XD3 
This feature allows any online updates to be installed and should only be used with involvement of 

Mirada Customer Support. 

About 
Displays the version of the application and associated copyright and license information. 
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Messages  

Show Messages 
Displayed in this area are messages that may include reports of things that happened during a data load 

or initial registration. If an icon (yellow or red, indicating warning or error) appears next to the Messages 

menu item, this indicates that a new message is available and should be reviewed. This icon disappears 

after the message has been viewed.  

Occasionally, there will be messages displayed that you do not need to explicitly acknowledge, as they 

may be part of a hazard mitigation or messages that help with the use of the application.  

Information presented in the messages window is also stored with additional detail in the application 

log file. 
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Loading a Saved Session 

When the application is launched with one or more saved sessions, the user is presented with the choice 

of which saved session to restore or, alternatively, the option to start a new session. 

When a session has been selected to be restored, the system will attempt to assign the data from the 

previous session to the same data designations. Any new timepoints will be inserted where appropriate. 

The following information will be restored:  

• Registrations 

• Findings 

• Key Images 

• Bookmarks 

• Rulers 

• Bi-rulers 

• Annotations 

• Angles 

• Modified PET Quantification Parameters (e.g. weight, height) 

• Data Management screen order/anchor settings (e.g. for gated data) 

Items can only be restored if the data on which they were defined has been reloaded. For instance, 

consider a saved session for a two timepoint PET/CT case where a region was defined on each PET. If the 

session were subsequently restored but with only one of the PET/CT timepoints supplied to the 

application, only one of the regions will be restored.  

The application allows the hardware registration between hybrid datasets to be overridden by a custom 

registration. If a custom registration has been applied, it will be saved as part of a session. Upon 

restoring the session the custom registration will be reapplied overriding any hardware registration that 

may have been present. If this occurs the application will warn the user. 
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Data Management 

 This screen is used to specify two different types of binding behavior: Bindings for Timepoint and 

Bindings for Dataset. Bindings for Timepoint allows the viewing and editing of bindings between 

different data roles in the same time point. Bindings for Dataset allows the viewing and editing of 

bindings between the same data role across time points. In the case that only a single time point is 

loaded, Bindings for Dataset is not available and the Bindings for Timepoint is simply called Bindings. 

Bindings for Timepoint 

This allows viewing and editing of links between different volumes of multi-volume data assigned to 

different data roles. 

XD3 makes certain logical assumptions about how the bindings in one timepoint relate to those in 

another. These bindings may not be optimal if the acquisition protocols used in each study are not the 

same. 

The screenshot below shows the dataset bindings between a gated PET assigned to the Functional role 

and a gated CT assigned to the Anatomical role. In this instance, there are equal numbers of PET and CT 

bins and the default bindings are one-to-one. What these bindings represent are links along which 

shadow regions are created. Drawing a region on the first bin of the PET dataset will automatically 

create a shadow region on the first bin of the CT. Similarly, creating a region on the second bin of the CT 

will automatically create a shadow region on the second bin of the PET dataset. 

The binding links also affect the volume displayed in the layout views. In the example displayed below, 

changing the displayed PET volume in a Functional view affects the volume displayed in other Functional 

views in the layout and it also affects the volume displayed in Anatomical views. This means that 

switching the view from displaying the first PET bin to displaying the second PET bin makes all views in 

the layout displaying PET show the second bin. It will also update all Anatomical views in the layout to 

display the second CT bin as that bin is linked to the second PET bin. This also works on fused views. 

Cycling through the PET bins on the overlay will update the CT base layer in the view to display the 

appropriate bin based on the links in the data management screen. 
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The tab for Bindings for Timepoint displayed above also includes a time point selector. Use this drop-

down to select the time point for which bindings are to be viewed/edited. 

Modifying the Bindings 

 
The screenshot above shows modifications made to the default bindings. A link can be removed by first 

clicking it and then selecting Remove Binding from the popup menu. A binding can be added by 

dragging a volume label to the target volume label. In this example a binding was added between the 

fourth bin of the CT to the fifth bin of the PET by dragging the fourth CT bin box to the fifth PET bin box. 

In the example above, drawing a region on the fifth PET bin will create a shadow region on both the 

fourth and fifth CT bins. Drawing a region on either the fourth or fifth CT bin will create a shadow region 

on the fifth PET bin. Drawing a region on either the third or fourth PET bins does not create a shadow 

region on any CT bin. Similarly, drawing a region on the third CT bin does not create a shadow on any 

PET bin. 
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To understand how the modified bindings displayed above affect the views displayed in layouts, 

consider the following procedure: 

1. In a fused view, enable the navigation controls and select the first bin of the CT (this can be 

done by clicking the first box next to the Anatomical label). Note that the first bin of the PET is 

selected as those two bins are bound. See the image below. 

 
2. Select the second bin of the CT by clicking the second box next to the Anatomical label. Note 

that the second bin of the PET dataset becomes selected and displayed. See the image below. 
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3. Select the third bin of the CT by clicking the third box next to the Anatomical label. Note that the 

selected PET overlay does not change. This is because the third bin of the CT is not bound to any 

PET volume. See the image below. 

 
4. Select the fourth bin of the CT. Note that the fifth PET bin becomes selected and displayed as 

those volumes are bound in the data management screen. See the image below. 
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5. Select the fifth bin of the CT. The fifth bin of the PET is also selected as those datasets are 

bound. In this instance the fifth PET bin was already selected, but had it not been then selecting 

that CT bin would have changed the selected PET bin. See the image below. 

 
6. From here on there is a direct link between each of the CT and PET bins and they move lockstep 

as the CT bins are visited in turn. 

The same procedure can be carried out by stepping through the PET bins. This is detailed below as there 

is a special case for dealing with a single bin being bound to many bins on a different data role. 

1. Select the first bin of the PET by clicking the first box next to the Functional (AC) label. Note that 

the first bin of the CT is selected and displayed. See the image below. 
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2. Select the second bin of the PET by clicking the second box next to the Functional (AC) label. 

Note that the second bin of the CT is selected and displayed. See the image below. 

 
3. Select the third bin of the PET. Note that the selected CT bin does not change. This is because 

the third bin of the PET is not bound to any CT bin. See the image below. 
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4. Select the fourth bin of the PET. Note that the selected CT bin does not change because the 

fourth bin of the PET is also not bound to any CT bin. See the image below. 

 
5. Select the fifth bin of the PET. In the data management screen, the fifth bin of the PET is bound 

to both the fourth and fifth bins of the CT. This ambiguity is always resolved by selecting the first 

bin to which the PET bin is bound. In this case, that is fourth bin of the CT. See the image below. 
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6. From here on there is a direct link between each of the CT and PET bins and they move lockstep 

as the PET bins are visited in turn. 

The examples considered so far have involved CT and PET data where the numbers of bins were equal in 

each dataset. The principles covered extend to more complex cases that will be briefly mentioned 

below. 

Static PET on Gated CT 

 
By default, all bins of the CT are bound to the PET. Drawing a region on any CT bin automatically creates 

a shadow on the PET. Drawing a region on the PET automatically creates a shadow region on each of the 

CT bins. 
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In a layout, cycling through the displayed CT bins always displays the same PET. 

Gated PET on Single CT 

 
By default, all bins of the PET are bound to the CT. Drawing a region on any PET bin automatically 

creates a shadow on the CT. Drawing a region on the CT automatically creates a shadow region on each 

of the PET bins. 

In a layout, cycling through the displayed PET bins always displays the same CT. 

Gated PET on Gated CT – Different Number of Bins 

 
In the above case, eight bins of PET have been loaded against four bins of CT. The default links created 

have bound two PET bins to every CT bin. Drawing a region on a PET bin automatically creates a shadow 

region on the associated CT bin. Drawing a region on a CT bin automatically creates a shadow region on 

the two PET bins to which it is linked. 
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In a layout, cycling through the displayed PET bins will update the displayed CT bin for every other PET 

bin visited. Cycling through the CT bins will update the displayed PET bin every time the CT bin changes. 

As each CT bin is bound to two PET bins, the ambiguity is resolved by picking the first PET bin to which 

the CT is bound. For instance, selecting the second bin of the CT will select and display third bin of the 

PET as that is the first bin to which it is bound. 

Pictured below is an even more degenerate example of mismatching numbers of bins. In this instance 

there are five CT bins and eight PET bins. 

 
By default the application will bind each volume to at least one other volume so that nothing is left 

unbound. It is up to the user to determine whether the default bindings are appropriate and change 

them accordingly. 

Bindings for Dataset 

This section allows the viewing and editing of links between the same dataset across different time 

points. For instance, in a multi-time point gated CT read, the links between the CT bins across different 

time points can be viewed and edited. See the image below. 

This section is only available if multiple time points have been loaded. Bindings for Dataset only affect 

view bindings and, unlike Bindings for Timepoint, do not impact shadowing behavior. These bindings 

are further simplified by being constrained to allowing only single-to-single bindings.  
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The tab for Bindings for Dataset displayed above also includes a dataset selector. Use this drop-down to 

select the dataset for which bindings are to be viewed/edited. 

The image above shows how each bin of the baseline CT relates to the bins of the current CT. In the case 

shown above, eight bins of CT were loaded into the Anatomical role for the baseline time point and 

eight bins of CT were loaded into the Anatomical role for the current time point. The default links 

created by the application have paired them in a simple fashion. Bin 1 of the baseline CT is bound to bin 

1 of the current CT. Bin 2 of the baseline CT is bound to bin2 of the current CT et cetera. 

These links affect the views displayed in the layouts. When the first bin of the baseline CT is selected in a 

view for display, all other views of the baseline CT are updated to display the same bin. Additionally, all 

views of the current CT are updated to show the first bin as those bins are linked. 

These bindings can be removed by first clicking on a link and then selecting Remove Binding from the 

popup menu that appears. Bindings can be created by dragging and dropping the boxes to each other. 

Anchor Volumes 

Each data role that supports multiple volumes has the notion of an anchor volume. There is always 

exactly one anchor volume per multi-volume data role. The anchor volume is the volume that is used 

when performing registrations. For more information see the Multi-volume data in the Registration 

Manager subsection of the Registration Manager section. 

The Data Management screen is the place where the volume designated as anchor can be set. To 

change the anchor volume of a role simply click the right mouse button in any volume box and select Set 

as Anchor from the popup menu. 
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Registration Manager 

 The Registration Manager screen contains the following areas, which are described below. 

• Toolbar 

• Registrations area 

• Image area 

• Layers Panel 

• Visualization Tools Panel 

• Automatic Registration Panel 

• Manual Registrations Panel 

• Image Area context menu 

Toolbar 
The toolbar contains the same tools that are available elsewhere in the application. The tools are also 

available via the context menu and may alternatively be assigned to hotkeys. See the Toolbar and 

Menus section of this document for detailed descriptions for each tool. 

Registrations Area 
This area displays a graphical representation of the relationships between the datasets loaded into the 

review mode. In the example below, there are three time points of PET/CT data loaded. The black, red 

and green lines illustrate datasets with registration relationships that may be viewed, evaluated or 

reregistered. 

 
Each column represents a single time point. Each box represents a data role within the time point.  

The black lines represent datasets that share the same frame of reference and are hardware locked. 

Those datasets that are hardware locked will be displayed with a lock icon, as above. A context menu 

with dataset-specific options is available by clicking the right mouse button within the dataset rectangle. 

Selecting the ‘Unlock’ action will unlock the frames of reference so that registrations can be performed 

with other datasets. 
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The red lines represent rigid registrations, including the implicit center alignment created when clicking 

‘Reset Registration’. Green lines represent deformable registrations.  

Click on the lines to select a relationship. Once a relationship is selected, the datasets will be displayed 

in the image area and a number of tools will be available to review, evaluate or manipulate the 

registrations. 

Many review modes allow the loading of multiple volumes into a data role. This may be gated CT, gated 

PET, multi-phase MR or multi-sequence MR. When multiple volumes are loaded into a role, one of them 

is designated the anchor. There is always exactly one anchor volume per role. In the case that a data 

role contains a single volume, that volume is always the anchor. The anchor is a special volume. All 

registrations that are performed by the application are between anchor volumes. In the case of a gated 

PET and a gated CT loaded into General Fusion review mode, the registration that exists between the 

Functional (AC) role and the Anatomical role is the registration performed between the anchor 

Functional (AC) volume and the anchor Anatomical volume. 

By default, the registration manager displays an overview matrix where only one box is displayed per 

data role. See image below. 

 
In this case, two time points of data were loaded. Both the current and baseline Anatomical roles were 

populated with four gates of CT. The Functional (AC) roles were populated with a static PET series. In 

total, 10 volumes have been loaded (8 gates of CT and two PET volumes). The registration matrix 

displays only one box for each role and the registration relationships between those roles. To see a 

detailed view of each time point, click its time point label above the grid (highlighted in red above). 

Expanding a time point displays the relationships between all volumes loaded into that time point. An 

example is displayed below. 

 
The expanded baseline time point shows the four gates of CT and how they relate to static PET. All the 

gates of the CT are linked to the anchor CT gate. The anchor CT gate is also the volume that is related to 

the anchor PET volume. 
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This expanded view behaves much like the overview view of the registration matrix. Click a link between 

any two volumes to view the registration between those two volumes. The registrations can be 

manually edited as expected and automatic registrations can be run. For datasets that share a frame of 

reference (denoted by lock icons), it is necessary to first unlock those datasets before the registration 

between them can be modified. 

To return to the overview registration matrix, click the Back button highlighted in the image above. 

To change the anchor volume for a data role see the Anchor Volumes subsection of the Data 

Management section. 

Image Area 
This is the area where the selected datasets are displayed. 

Layers Panel 
The Layers Panel in the Registration Manager Toolbox displays a row for each dataset selected and 

displayed in the image area. Next to each layer is a box to check to include or remove that dataset from 

the current image view. By highlighting a particular layer (that row is highlighted in blue), you choose 

the layer for which controls are active. For example, when using the Transparency Tool, the system 

adjusts the transparency of the selected layer within the current image view. 

Visualization Tools Panel 
These QA tools are available to visualize the displacement following image registration: 

There is a drop down menu which includes the following QA tools to show the displacement after image 

registration: 

 Show Displacement Map displays the area of displacement with a color map; warm colors indicate 

high areas of deformation and cool colors indicate areas of low displacement. 

 Show Displacement Grid displays the area of displacement with a grid; areas of high grid 

displacement indicate high areas of deformation. 

 Show Displacement Arrows the amount and direction of deformation or displacement are 

indicated by arrows, where the length is proportional to the amount of deformation. 

These overlay tools are available to assess the registrations in a drop down menu: 

 Show Checkerboard Overlay: both layers are represented with alternating squares to evaluate 

registration between the two. 
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 Show Inset Overlay: All layers except the base layer are drawn in the region outside the inset 

window with the transparency settings adjusted as though the base layer had been hidden. 

The size of the overlay tools may be adjusted with the slider bar. 

 Show Displacement Value allows the displacement value for any specific point in the registration to 

be assessed. Use the cursor to point to any area on the registered datasets in the Image Area and view 

displacement value. 

Any of the visualization tools may be set to hotkeys via Tools -> Options by selecting the Hotkey 

Configuration button on the User Interface tab. 

 Functions that rely on the inversion of the registration deformation map such as the cross-hair 

alignment and Region of Interest propagation may exhibit inconsistent and asymmetrical behavior in 

certain situations. For example in Adaptive Planningreview mode, if the user were to navigate the cross-

hair to a location A in the Baseline Planning the software will automatically place the cross-hair at a 

particular corresponding location, B, in the Current Planning. However, if the user were then to move 

the cross-hair around in the Current Planning and then place it back at location B, the position of the 

cross-hair in the Baseline Planning may not be at location A."  

This applies to any deformable registration either within a timepoint or across timepoint. For example, 

in Fusion Analytics in which a deformable registration exists between the Planning and MR images, the 

Planning dataset should be used for cross-hair navigation. 

Automatic Registration Panel 
Automatic Registration tools are: 

• Reset Registration – Datasets are aligned using the field of view center of the displayed datasets 

for the current registration relationship. 

• Automatic Rigid – Selected datasets are aligned using the automated rigid algorithm. 

The following presets are available by selecting the  next to the Automatic Rigid button: 

o Medium – The default setting. 

o Fast – Runs faster as it works at a coarser resolution and for fewer iterations that the 

Medium setting. 

o Fine – Runs sower as it works at a finer resolution and for more iterations that the 

Mediuam setting. 

This choice is saved between launches of the application. 

• Multi-Modal Deformable – Selected datasets are aligned using the automated multi-modal 

deformable algorithm. 

The following presets are available by selecting the  next to the Multi-Modal Deformable 

button: 
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o Default – This is a generic preset that works well over a wide variety of multi-modal 

registration use-cases. 

o CT-PET Emission – A preset optimised for CT-PET registration. It is largely the same 

algorithm as Default, but with stronger constraints on transformation smoothness to 

account for weaker structural information. 

o CT-MR – A preset optimised for CT-MR use-cases. It is slower than the default, but 

generally gives more accurate registrations. 

o CT-CT – A preset optimized for CT-CT registration where the images have been acquired 

from different scanners, or for registering contrast enhanced CT with a non-contrast 

enhanced CT. 

o CT-CBCT – A preset optimized for registering a planning CT to a conebeam CT. 

o MR-MR – A preset optimized for registering MR to MR. 

This choice is saved between launches of the application. 

• CT Deformable – Selected datasets are aligned using the CT to CT deformable algorithm. 

• Smooth Deformation - Takes an existing deformable registration and filters it to reduce large 

deformations. Successive iterations of the Smooth Deformation command further reduce the 

deformation field until it reaches a maximum smoothness. 

When an automatic registration scheme is run with data assignments containing multiple related 

series (e.g. Gated CT or PET, Multi-phase CT, Multi-sequence MR), the first series/volume assigned is the 

one used for registration for registrations involving that assignment. This may or may not be the optimal 

series/volume to use for registration depending on the acquisition protocol. This can be modified on the 

Data Management screen by changing the ‘Anchor’ for the assignment and reviewed on the 

Registration -> Registration Manager to ensure that the registrations are satisfactory. 

Manual Registrations Panel 
Manual Registration tools provide a means of defining your own transformation between two datasets 

by dragging the mouse to slide (translate and rotate – rigid transformations) the base image overlay 

with respect to the base image. This technique relies on a visual examination of the registration by the 

user. 

With the layout set to Fused, the manual rigid registration control is active over the entire registration 

view. Dragging on the green circle controls rigid rotations; dragging elsewhere controls rigid 

translations. 
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With the layout set to Landmarks, you may define your own registration between two datasets by 

defining two equally numbered sets of landmark points at corresponding sites on the source and target 

views of the data. Use the left mouse button to place a landmark in any orthogonal view for the source 

or target data sets. An unpaired landmark will display as a cross on the image, place your mouse on the 

corresponding dataset. When landmarks are placed on both the source and target datasets, a label will 

be assigned and displayed on the image window. That label will also be added to the Marker table. You 

may visualize a particular marker by highlighting it in the Marker table and selecting the Go To button. 

Markers maybe deleted by highlighting the marker in the table and selecting the Delete button. 

The Image Area initially displays the axial, coronal and sagittal views for the two datasets that are 

selected in the registrations area. The image views behave as any other orthogonal image view in the 

main application. For example, double clicking enlarges the currently selected image to fill the image 

area.  

Loaded Registrations 
This area allows a loaded registration to be applied when the relationship for which it was created is 

displayed. Select a relationship to see the available registrations that can be applied. 
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Findings Table 

About the Findings Table 

 The Findings Table is where detailed statistics and graphs for regions and ruler measurements are 

displayed. The screen has a number of tabs predefined in the software. Each tab on the Findings Table 

has a statistics table and a graph area. The statistics that are displayed by default as appearing in the 

statistics table or plotted on the graph are defined for each tab.  

Saving the Tables and Graphs for Use Outside the Application 
Use the Snapshot Table button to save a table as a snapshot in the Image Gallery. Objects saved in the 

Image Gallery can be exported as DICOM Secondary Capture, .BMP, .PNG, or .JPEG files. 

Use the Copy Table button to copy the table to a Windows clipboard for use in any application that 

accepts data from a Windows clipboard. Examples include Microsoft Excel, Word, etc. 

Click the right mouse button on any graph to: 

• Copy to Windows clipboard 

• Save to a file destination of your choice 

• Save the graph to the image gallery to be exported as DICOM Secondary Capture, .BMP, .PNG, 

or .JPEG files. 

  



  mm2357-6 
  FUXD-USER 
 

Mirada Medical | XD 111 

 

Accessing the Findings Table 

 The Findings Table may be accessed from several points within XD3: 

• By selecting the Findings Table icon from the Regions of Interest panel of the Toolbox 

• By selecting the Findings Table icon from the Rulers and Annotation panel of the Toolbox 

• A list of available layouts including drop down lists and transparent list accessed with Ctrl + Tab  

• By selecting Window -> Findings Table from the menu 

The tables found under each of the tabs include the following columns: 

• Region Name 

• Lymph Column (indicates if a region has been set as a lymph node) 

• Dataset column 

• Quantification measure column (Rows displayed for each measure set for display on the tab) 

• Unit column (displays the unit of measure) 

• One column per time point using the time point naming convention (e.g. baseline) 

• Tracking column (displays the tracking mode) showing the percentage relative to the value being 

tracked 

To get back to the image window, select the Back to Layouts button in the upper left of the screen. 
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Findings Table Toolbox 

Settings 

Tracking mode specifies the way in which the comparison statistics are calculated and displayed for 

rulers and regions in the statistics table.  

• Baseline calculates the statistics relative to the baseline scan 

• Waterfall calculates statistics relative to the previous study  

• Min to Date calculates statistics relative to the time point containing the minimum value for the 

statistic being calculated; only time points prior to the one being calculated are considered 

when looking for the minimum value 

The Dataset Selector indicates for which set of data the statistics table and graphs will be displayed. 

The Options button allows you to choose whether or not you want to include graphs and tables in your 

display. Place a check mark in the column to indicate your preference. Use the buttons at the bottom of 

the Quantification Options dialog box to include All Tables, No Tables, All Graphs or No Graphs 

Findings 

The findings include regions, measurement, and annotations created on an image. You may modify the 

created findings’ names, colors and viewed statistics by double-clicking the finding name. When the 

mouse pointer hovers over any ROI or Ruler in this panel, the tooltip will display statistics or 

measurements. This feature is most useful with ROIs if a region has been projected. 

 



  mm2357-6 
  FUXD-USER 
 

Mirada Medical | XD 113 

 

The Findings panel toolbar contains the following options: 

 Delete the selected finding 

 Go To the selected finding 

 Show or hide the selected findings 

 Display the Findings Table 

 Link the selected findings 

 Display Findings Graph 

 Projects the selected finding to all time points 

 Projects the selected finding within its time point 

 Create regions at preset thresholds within the selected area 

Right click on any selected Finding to: 

• Delete 

 This action is also available from the toolbar. 

• Copy Statistics to Clipboard 

• Copy Statistics to the Image Gallery 

• Display Findings Graph 

This action is also available from the toolbar. 

• Go To Finding 

 This action is also available from the toolbar. 

• Go to Hottest Voxel 

 If the Go To Hottest Voxel tool is used on a region with more than one voxel with the highest 

intensity value, then only one of these voxels will be identified. 

• Create a ruler from the region 

• Create Multiple Threshold Regions: This creates multiple threshold ROIs from a previous 

threshold ROI.  Thresholds are pre-set in Tools -> Options under the Findings tab. 

 This action is also available from the toolbar. 

• Toggle to indicate lymph node 

• Unlink 
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• Link: There are two types of findings: rulers and regions. Rulers include uni-rulers, bi-rulers and 

angles (annotations are not classed as findings). Regions include isocontour regions (with 

threshold), filled regions, 2D rectangles, 2D ellipses and regions painted with the freehand paint 

tools. Ruler findings can always be linked to other ruler types. They can also always be linked to 

region types. Region findings can be linked to ruler findings but are restricted as to which other 

regions they can be linked. A region can only be linked to another region that was defined on 

the same data role. E.g. a region defined on the Anatomical data role in General Oncology 

Review can only be linked to another region defined on the Anatomical role and not to one 

defined on the Functional role. This is further restricted to only being able to be linked to 

another region defined on the same role but not on the same dataset. E.g. a region defined on 

gate 1 of a gated CT assigned to the Anatomical role can be linked to a region defined on gate 2 

of the same gated CT, but not to another region defined on the same gate 1. This restriction 

does not apply across time points. A region on gate 1 of a CT on the baseline time point can be 

linked to a region defined on gate 1 of a CT on the current time point.  

 This action is also available from the toolbar. 

• Show/Hide regions 

 This action is also available from the toolbar. 

• Project to all by Type : with a region selected, this option will propagate a finding to the 

equivalent dataset designation in all time points by recreating the region in each time point 

using the means by which the region was originally created (i.e. absolute threshold, % max 

threshold). If the region exists in multiple time points, then the value will be taken from the 

selected time point. 

 This action is also available from the toolbar. 

• Project to all by Volume: with a region selected, this option will project the region to the 

equivalent datasets designations in all time points by maintaining the volume of the original 

region. If the region exists in multiple time points, the volume value will be taken from the 

selected time point. 

• Project to all within Volume by Type: with a region selected, this option will project the region 

to all datasets from the same frame of reference (i.e. bins of a gated dataset, phases of a multi-

phase CT or sequences of multi-sequence MR) and create shadows on each of them. If the 

region exists in multiple datasets, then the absolute threshold value is taken from the selected 

dataset. 

 This action is also available from the toolbar. 

• Transform to All: with a region selected, the region will be transformed to the equivalent 

dataset designation in all time points using the existing registration to transform the ROI shape. 

If the region exists in multiple time points, then the selected time point will be propagated. 

• Options … (displays the Findings tab in Tools -> Options) 

There are additional options for projecting and transforming findings which are turned off in the menu 

by default, but may be enabled via Tools-> Options on the Findings tab. These additional tools are: 
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• Project to remaining by type: with a region selected, this option will propagate the selected 

region to the equivalent dataset designation in time points where the region does not already 

exist by recreating the region in each of the time points using the means by which the region 

was originally created (i.e. absolute threshold, % maximum threshold) 

• Project to Remaining by volume: with a region selected, this option will propagate the region to 

the equivalent dataset designation in time points where the region does not already exist by 

maintaining the volume of the propagated region. If the region exists in multiple time points, 

then the volume value will be taken from the selected time point 

• Transform to remaining: with a region selected, this option will propagate the region to the 

equivalent dataset designation in all time points that do not contain the region. The existing 

registration will be used to transform the ROI shape. If the region exists in multiple time points, 

then the selected time point will be propagated. 

• Project to remaining within timepoint by type: with a region selected, this option will project 

the region to all datasets from the same frame of reference (i.e. bins of a gated dataset, phases 

of a multi-phase CT or sequences of multi-sequence MR) where the region is not currently 

defined and create shadows on all datasets to which the role on which the region was defined 

are linked. If the regions exists in multiple datasets, the absolute/threshold value will be taken 

from the selected dataset. 

• Transform to all within timepoint: with a region selected, this option propagates the region to 

all datasets within the same frame of reference (i.e. bins of a gated dataset, phases of a multi-

phase CT or sequences of multi-sequence MR) using the existing registration to transform the 

ROI shape. If the region exists in multiple datasets within the same frame of reference, the 

selected region will be propagated. 

• Transform to remaining within timepoint: with a region selected, this option projects the 

region to the other datasets within the data designation (same frame of reference) that do not 

contain the region, using the existing registration to transform the ROI shape. If the region exists 

in multiple datasets within the designation, the selected region will be propagated. 

 Regions resulting from performing the Transform to All, Transform to Remaining, Transform to 

All within Timepoint and Transform to Remaining within Timepoint actions are highly dependent on 

the quality of the registration that exists between the dataset on which the source region exists and all 

the datasets to which the region is to be transformed. It is recommended that quality checks be 

performed within the Registration Manager screen on the accuracy of the registrations prior to 

performing a region transformation action. 
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Findings Table Tabs 
The Findings screen is populated with different tabs that contain subsets of the statistics available. Each 

tab is described in turn below. Each tab contains a table of results and a chart area where charts that 

have been enabled are displayed. The table contains statistics calculated for each finding at each time 

point in which it exists. The statistics calculated depend on the tab selected. There will be one row in the 

table per statistic per finding. 

Statistics 

Statistics for regions are calculated from the values of all voxels whose center is included within the 

region. The following, primary, statistics are available within the application. 

• Max – The maximum intensity of all the included voxels. 

• Min – The minimum intensity of all the included voxels. 

• Mean – The mean intensity of all the included voxels. 

• Median – The median intensity of all the included voxels. 

• StdDev – The standard deviation of all the included voxels. 

• Threshold – The lower threshold value of an isocontour region. This statistic only applies to 

isocontour regions. 

• Upper Threshold – The upper threshold value of an isocontour region. This statistic only applies 

to isocontour regions. 

• Volume – The volume in cubic centimeters of the region.  

• Volume Doubling Time – The time in days that it would take the region to double in volume. 

• Peak – The PERCIST peak. 

• BiLongAxis – The long axis measurement for a 2D ruler. 

• BiLongAxis – The short axis measurement for a 2D ruler. 

• BiRulerAuto – If the finding has been marked as a lymph node, then this statistic has the value of 

the short axis measurement for a 2D ruler. If the finding has not been marked as a lymph node, 

then this statistic has the value of the long axis measurement for a 2D ruler. 

• UniRuler – The length of a ruler. 

• Angle – The angle in degrees for an angle measurement. 

NOTE: As only voxels whose center lies within the region are considered when calculating statistics, 

the Volume statistic will always be a multiple of the voxel volume of the dataset on which the region is 

defined. Partial volume correction is not applied. 
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 Automatically shadowed regions will be quantified in the resolution of the dataset onto which 

the region was shadowed. Only voxels whose center lies within the region are considered when 

calculating statistics. If the dataset on which the original region was defined and the dataset onto which 

the region was shadowed are of a different resolution, the regions may have a different Volume statistic 

as the volume will always be a multiple of the voxel volume of the dataset on which the region is 

defined. For instance, a region defined on a CT dataset and automatically shadowed onto the PET may 

have a different Volume statistic when calculated on the CT compared the Volume statistic calculated on 

the PET if the CT dataset is of a different resolution to the PET.  

It follows that any statistic derived from the Volume statistic (e.g. Volume Doubling Time) will be 

different for a finding shadowed between a pair of datasets if the Volume statistic is different for that 

finding. 

SUV Peak 

The SUV Peak calculation is a method to provide a robust measure of tracer activity in PET imaging. It 

refers t the maximum average SUV within a small fixed-size ROI. The implementation used by XD3 

follows the definition provided in the PERCIST protocol. 

XD3 displays smooth images and contours, meaning that both the displayed images and contours are 

interpolated to produce a display without square edges around each voxel. However, quantification is 

always performed on the original voxels avoiding any form of interpolation or partial volume correction. 

For all ROIs, the quantified voxels are those whose centers fall inside the curve. This is illustrated in 

Figure 1, where the quantified voxels have been shaded for the region defined by the blue contour. 

 
Figure 1: Quantified Voxels are Shaded 
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A sphere of diameter approximately 1.2cm (to produce a 1cm3 volumetric sphere) is used to calculate 

the Peak value. This is refered to as the SUV Peak kernel. For all voxels in a region, the SUV Peak kernel is 

placed such that the center of the kernel is over the center of the voxel being assessed. The mean 

intensity of all voxels within the kernel is computed. The SUV Peak is the maximum of all the mean 

values computed from placing the kernel at each voxel in the ROI. For voxels near the edge of the ROI, 

some voxels within the SUV Peak kernel are used in the calculation of the mean SUV whether or not 

those voxels are inside the region as illustrated in Figure 2. The SUV Peak kernel is also quantized using 

the same approach as illustrated in Figure 3, specifically each voxel whose center is inside the kernel is 

used for the mean calculation. 

 
Figure 2: SUV Peak Kernel Counts Voxels Outside ROI 

 
Figure 3: SUV Peak Kernel Voxels are Shaded 

Due to its definition, the peak value may include voxel values from outside the ROI boundaries 

when the ROI is near an adjacent area of the image with high PET values. The user should treat the peak 

value with caution where high PET voxels are within 0.7 cm of the ROI boundaries. 
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Volume Doubling Time 

The volume doubling time can only be calculated when more than one timepoint of data has been 

loaded. It is based on the rate of change of the volume statistic. The rate of change is calculated from 

the volume of a region at a particular timepoint and the volume of the same (linked) region in the 

immediately preceeding timepoint. This means that the volume doubling time cannot be calculated for 

the baseline timepoint (as there is no preceeding timepoint), nor can it be calculated for a region if a 

linked region does not also appear in the immediately preceeding timepoint. 

The formula for the volume doubling time, 𝑡𝐷, is: 

𝑡𝐷 =
𝑡 ∙ log 2

log (
𝑉(𝑡)

𝑉0
)

 

Where 𝑉0 is the volume of the region and the preceeding timepoint, 𝑉(𝑡) is the volume of the region at 

the current timepoint, and 𝑡 is the time, in days, between the two volume measurements. 

Volume Doubling Time is not computed for a data role when a finding contains more than one region on 

the data role. For instance, if two linked regions are defined on a gated CT, Volume Doubling Time is not 

computed for that gated CT as there is no definitive Volume statistic. 

 The volume doubling time calculation becomes more robust the larger the regions become. At 

small volumes where the region volume consists of only a few voxels, the potential error in the reported 

volume may be quite large. The user is advised to use the Data QC screen to check the voxel dimensions 

when making a judgement as to how to interpret the volume doubling time. In addition, the volume 

doubling time calculation may become very large and sensitive when the volumes in consecutive 

timepoints are similar. 

 The volume doubling time statistic is derived from the volume statistic. It is an estimate of the 

true tumor volume doubling time and depends on the accuracy of the regions drawn. The region should 

be checked on every slice on which it exists to ensure it is as accurate as possible. 

Aggregation of Statistics 

Typically, only a single value is calculated for a particular statistic for a finding in a time point. For 

instance, if a linked finding contains two linked regions: one on the baseline PET and one on the current 

PET, then there would be one Max value calculated for the finding at the baseline time point and one 

Max value calculated for the finding at the current time point. This would be displayed as a row in the 

table. 
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In the case where the baseline PET is a gated PET and the current PET is also a gated PET then potentially 

many more values are calculated. If each of those PET datasets contained four bins then it is possible to 

define a region on each of the PET bins on the baseline time point and on each of the PET bins on the 

current time point and then link all of those regions into a single finding. When displayed in the findings 

table, an aggregate statistic is calculated for each time point. In this example, the four regions on the 

baseline PET could have Max SUVs of 4.1, 4.3, 3.9 and 4.0. The aggregate Max is the maximum of those 

values which is 4.3 in this case. The following table shows the operation used to aggregate the primary 

statistics for display in the table. 

Statistic Aggregation Method 
Max maximum 

Min minimum 

Mean mean 

Median mean 

StdDev mean 

Threshold a value is only displayed if all values being 
aggregated are equal 

Upper Threshold a value is only displayed if all values being 
aggregated are equal 

Volume mean 

Volume Doubling Time N/A 

Peak maximum 

BiLongAxis maximum 

BiShortAxis maximum 

BiRulerAuto maximum 

UniRuler maximum 

Angle mean 

These aggregate statistics are also displayed in the image views. For linked findings the value calculated 

for the region in the view is displayed and the aggregate value is displayed in parentheses next to the 

individual region value.  

Aggregation of Derived Statistics 

Typically only a single value is calculated for a particular derived statistic for a finding in a time point. For 

instance, for a linked finding contains two regions: one on the baseline CT and one on the current CT, 

then there would be one TLG value calculated for the finding at the baseline timepoint and one TLG 

value calculated for the finding at the current time point. This would be displayed as a row in the table. 
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In the case where the baseline CT is a gated CT and the current CT is a gated CT then, potentially, many 

more values are calculated. If each of those CT datasets contained four gates then it is possible to define 

a region on each CT gates on the baseline time point and on each of the CT gates on the current time 

point and then link all of those regions into a single finding. When calculating the TLG, aggregate values 

for the primary statistics are used. The TLG calculated for a particular timepoint is the aggregate mean 

multiplied by the aggregate volume. For instance, consider a linked Finding with a region on Gate 1 of 

the CT with a Mean of 𝑚𝑒𝑎𝑛1 and a Volume of 𝑣𝑜𝑙𝑢𝑚𝑒1and another region on Gate 2 of the same ct 

with a Mean of 𝑚𝑒𝑎𝑛2 and a Volume of 𝑣𝑜𝑙𝑢𝑚𝑒2. The TLG calculated is the aggregate Mean multiplied 

by the aggregate Volume. From the table above, the aggregate Mean is (
𝑚𝑒𝑎𝑛1+𝑚𝑒𝑎𝑛2

2
) and the 

aggregate Volume is (
𝑣𝑜𝑙𝑢𝑚𝑒1+𝑣𝑜𝑙𝑢𝑚𝑒2

2
). This means the aggregate TLG is: 

(
𝑚𝑒𝑎𝑛1 + 𝑚𝑒𝑎𝑛2

2
) × (

𝑣𝑜𝑙𝑢𝑚𝑒1 + 𝑣𝑜𝑙𝑢𝑚𝑒2

2
) 

NOTE: An aggregate statistic is only computed when more than one linked item exists on the same 

data role within the same timepoint.  

If we define the following aggregation operations: 

• mean(Statistic) – This is the mean of the individual Statistic values. 

• max(Statistic) – This is the maximum of all the individual Statistic values. 

• min(Statistic) – This is the minimum of all the individual Statistic values. 

• isSame(Statistic) – This aggretation method only returns a value if all the individual Statistic 

values are identical. 

Additionally, we define that Reference Mean is the Mean statistic for the Finding named “Reference” 

and that Reference StdDev is the Standard Deviation of the Finding named “Reference”. Then the 

derived statistics can be defined as follows: 

Statistic Aggregation Method 

BiRuler Product 𝑚𝑎𝑥(𝐵𝑖𝐿𝑜𝑛𝑔𝐴𝑥𝑖𝑠) × 𝑚𝑎𝑥(𝐵𝑖𝑆ℎ𝑜𝑟𝑡𝐴𝑥𝑖𝑠) 

Max Ratio to Reference Mean 𝑚𝑎𝑥(𝑀𝑎𝑥)

𝑚𝑒𝑎𝑛(𝑅𝑒𝑓𝑒𝑟𝑒𝑛𝑐𝑒 𝑀𝑒𝑎𝑛)
 

Mean Ratio to Reference Mean 𝑚𝑒𝑎𝑛(𝑀𝑒𝑎𝑛)

𝑚𝑒𝑎𝑛(𝑅𝑒𝑓𝑒𝑟𝑒𝑛𝑐𝑒 𝑀𝑒𝑎𝑛)
 

Mean Range 𝑚𝑎𝑥(𝑀𝑒𝑎𝑛) × 𝑚𝑖𝑛(𝑀𝑒𝑎𝑛) 

Mean Ratio 𝑚𝑎𝑥(𝑀𝑒𝑎𝑛)

𝑚𝑖𝑛(𝑀𝑒𝑎𝑛)
 

PERCIST Threshold Blood Pool 2𝑚𝑒𝑎𝑛(𝑅𝑒𝑓𝑒𝑟𝑒𝑛𝑐𝑒 𝑀𝑒𝑎𝑛) + 2𝑚𝑒𝑎𝑛(𝑅𝑒𝑓𝑒𝑟𝑒𝑛𝑐𝑒 𝑆𝑡𝑑𝐷𝑒𝑣) 

PERCIST Threshold Liver 1.5𝑚𝑒𝑎𝑛(𝑅𝑒𝑓𝑒𝑟𝑒𝑛𝑐𝑒 𝑀𝑒𝑎𝑛) + 2𝑚𝑒𝑎𝑛(𝑅𝑒𝑓𝑒𝑟𝑒𝑛𝑐𝑒 𝑆𝑡𝑑𝐷𝑒𝑣) 
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Threshold % of Max 100(𝑚𝑎𝑥(𝑀𝑎𝑥) × 𝑖𝑠𝑆𝑎𝑚𝑒(𝑇ℎ𝑟𝑒𝑠ℎ𝑜𝑙𝑑)) 

TLG 𝑚𝑒𝑎𝑛(𝑀𝑒𝑎𝑛) × 𝑚𝑒𝑎𝑛(𝑉𝑜𝑙𝑢𝑚𝑒) 

Intensity Distribution Tab 
This tab displays the intensity distribution values for all the categories set for the currently active 

Intensity Distribution definition. The values are displayed as Hounsfield units (HU). 

Intensity Distribution definitions may be set via Tools -> Options on the Region Intensity Distribution 

tab. See User Preferences section for details. 

PERCIST Tab 
Designed for users wishing to display the PERCIST specific statistics and/or tracking information for 

regions. By clicking on the Options button in the Toolbox, the following quantification options are 

available for plotting in the Findings Table and as graphs: 

Derived Statistics are available for: 

• Mean 

• Maximum 

• Standard Deviation 

• Peak 

• Volume 

• TLG 

• Max Ratio to Reference Mean 

• Mean Ratio to Reference 

• PERCIST Threshold Liver 

• PERCIST Threshold Blood Pool 

In addition, summary quantification data for plotting in the Findings Table and as graphs is included for: 

• Sum of Peak 

• Track Peak 

• Sum of TLG 

• Track Max Ratio 

• Track Mean Ratio 

NOTE: Reference statistics will not be available until a region has been created and named 

‘Reference’. You may use any ROI as your reference or use the Drop 1 cm Sphere or 3 cm Sphere tools 

to create regions of a specific size. See the Quantify menu section of this manual for details on the 

Sphere tool. 
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RECIST Tab 
Designed for users wishing to display RECIST specific statistics and/or tracking information for rulers and 

bi-rulers only. No regions information is displayed on this screen. By clicking the Options button in the 

Toolbox, the following quantification options are available for plotting in the Findings Table and as 

graphs: 

• BiRuler Long Axis 

• BiRuler Short Axis 

• Bi Ruler Auto (chooses the long axis if lymph node flag is off, short axis if it is on) 

• UniRuler length 

The software also includes summary quantification data for plotting in the Findings Table and as graphs 

on the RECIST tab. Summary quantification is included for: 

• Sum of BiRuler Auto 

• Sum of Uni Ruler length 

Regions Tracking Tab 
Designed for users wishing to display statistics and / or tracking information for regions only. There is no 

ruler information displayed on this screen. By clicking on the Options button in the Toolbox, the 

following derived quantification options are available for plotting in the Findings Table and as graphs: 

• Max 

• Mean 

• Median 

• Threshold 

• Volume 

• Volume Doubling Time 

In addition, summary quantification data for plotting in the Findings Table and as graphs is included for: 

• Track Max  

• Mean of Mean  

WHO Tab 
Designed for users wishing to display WHO specific statistics and/or tracking information for bi-rulers 

only. No other ruler or region information is displayed on this screen. By clicking the Options button in 

the Toolbox, the following quantification options are available for plotting in the Findings Table and as 

graphs: 

• BiRuler Long Axis 

• BiRuler Short Axis 
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Derived statistics are available for BiRuler Product. 

Summary statistics are available for Sum of BiRuler Product. 

Advanced Tab 
Designed for users wishing to display statistics and/or tracking information for regions, rulers and bi 

rulers together. By clicking the Options button in the Toolbox, the following quantification options are 

available for plotting in the Findings Table and as graphs: 

Quantification 

• Intensity Distribution 

Derived statistics are available for: 

• Angle 

• BiRuler Long Axis 

• BiRuler Product 

• BiRuler Auto 

• BiRuler Short Axis 

• Max 

• Max Ratio to Reference Mean 

• Mean 

• Mean Ration to Reference 

• Mean Range 

• Mean Ratio 

• Median 

• Min 

• Peak 

• PERCIST Threshold Blood Pool 

• PERCIST Threshold Liver 

• Standard Deviation 

• Threshold 

• Threshold % of Max 

• TLG 

• UniRuler Length 

• Volume 

• Volume Doubling Time 

Summary Statistics are available for: 

• Mean of Mean Range 

• Mean of Mean Ratio 
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• Mean of Mean 

• Mean of Peak 

• Mean of Volume 

• Sum of BiRuler Auto 

• Sum of BiRuler Product 

• Sum of Mean 

• Sum of Peak 

• Sum of TLG 

• Sum of UniRuler Length 

• Sum of Volume 

• Track Max Ratio 

• Track Max 

• Track Mean Ratio 

• Track Mean 

• Track Peak 

NOTE: Reference statistics will not be available until a region has been created and named 

‘Reference’. You may use any ROI as your reference or use the Drop 1cm3 Sphere or Drop 3cm3 Sphere 

tools to create regions of a specific size. See the Quantify menu section of this manual for details on 

the Sphere tool. 

Creating a Custom Quantification Tab 
You may wish to create a custom tab with quantification statistics that you choose to include. You can 

accomplish this from the Advanced tab in the Findings Table. In the toolbox, select the Options button 

from the Settings area to display the Quantification Options window. Place checks in the boxes next to 

the quantification statistics you wish to include in your new tab. You can specify whether you want the 

statistics displayed as graphs, tables or both. Use the buttons below the selections to choose all or none 

of the tables or graphs.  

When you are satisfied with your selections select OK. You will be able to preview your new tab on 

screen to make certain you are satisfied with your selections. Once you are satisfied, click Save View in 

the Toolbox to enter a name for your custom tab and select OK. Then choose whether you want the tab 

available for current user only or all users (you must have appropriate permission to save for all users). 

You will see a confirmation window that the tab has been saved and it will be immediately available for 

selection. 
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Gated Data 

XD3 supports the display of gated CT, PET, Planar NM and SPECT. Multiple time points of gated data are 

supported. 

Findings 
You may perform any ruler measurement or region definitions on any of the bins of the gated data. 

Regions can be projected and transformed to other bins or time points. Regions will be 

projected/transformed as set in the bindings in Tools -> Data Management. Defaults are provided but 

can be modified. See the Data Management section of this document for further details. 

Layouts 
When creating layouts for gated data, if you wish to display all of the bins individually in a layout, use 

the ‘Data Offset’ in the right mouse button menu within the cell. This will allow you to separate out the 

bins as ‘Dataset 1’, ‘Dataset 2’, ‘Dataset 3’, etc. If you prefer to view the gated data as a cine, create the 

layout using the axial, coronal or sagittal views you wish to include and the bins may be displayed one at 

a time using the ‘left and right arrow keys or played as a cine. 

The image below illustrates the navigation tools for viewing gated data. In this example, the 10 bins of 

gated data are represented by the blue boxes at the top of the image window. You may click on the 

boxes to view the various bins of gated data. 
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Multi-phase CT Data 

In the General Oncology Review Mode, PET/CT/MR Review Mode and Single Volume Review Mode, XD3 

allows the display of multiple CTs acquired in the same frame of reference, such as multi-phase CT. The 

CT phases may all be displayed on the screen at one time or one view at a time with the ability to 

manually switch between the loaded CT phases using the left and right arrow keys, or by using the 

navigation tools. 

The image below illustrates the navigation tools within the image view. The blue boxes at the top of the 

image represent the three phases of this CT study. You may click on the boxes to display the various 

phases. The slider bar is present on the left side of the image window to allow scrolling through the 

slices. 

 

Registration 
If desired, you may choose to adjust the registration between the CT phases, as in the event of patient 

motion between acquisitions. The frame of reference may be unlocked in the registration manager to 

adjust the registrations.  

Findings 
You may perform any ruler measurements or region definitions on any of the CTs. Rulers and regions 

defined on one CT are shadowed as defined on the Data Management screen.  
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Layouts 
When creating layouts for multi-phase CT data, if you wish to display all of the phases at one time in a 

layout, use the ‘Data Offset’ in the right mouse button within the cell. This will allow you to separate out 

the phases as ‘Dataset 1’, ‘Dataset 2’, ‘Dataset 3’, etc. If you prefer to view the sequences one at a time, 

create the layout using the axial, coronal or sagittal views you wish to include and all sequences may be 

displayed one at a time using the left and right arrow keys. 
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Multiple Sequence MR Data 

In the General Oncology Review Mode, PET/CT/MR Review Mode and Single Volume Review Mode, XD3 

allows the display of multiple MRs acquired in the same frame of reference, such as multiple sequences. 

The MR sequences may all be displayed on the screen at one time or one view at a time that allows you 

to manually switch between the loaded MR sequences using the left and right arrow keys, or by using 

the navigation tools as shown below. The blue boxes at the top of the image window represent the five 

sequences of MR data loaded into the application. You may click on the individual boxes to navigate 

through the sequences. The slider bar on the left side of the image window allows you to scroll through 

the slices. 

 

Registration 
If desired, you may choose to adjust the registration between the MR sequences, as in the event of 

patient motion between acquisitions. The frame of reference may be unlocked in the registration 

manager to adjust the registrations.  

Findings 
You may perform any ruler measurements or region definitions on any of the MRs. Rulers and regions 

defined on one MR are displayed on the other MRs that the system configuration specifies.  
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Layouts 
When creating layouts for multi-sequence MR data, if you wish to display all of the sequences at one 

time in a layout, use the ‘Data Offset’ in the right mouse button within the cell. This will allow you to 

separate out the sequences as ‘Dataset 1’, ‘Dataset 2’, ‘Dataset 3’, etc. If you prefer to view the 

sequences one at a time, create the layout using the axial, coronal or sagittal views you wish to include 

and all sequences may be displayed one at a time using the left and right arrow keys. 
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Reporting 

Creating a Report 

The reporting screen is available by selecting Window ->Report Screen from the menu or by 

selecting Report Screen from any of the layout menus. The reporting feature allows you to create 

reports based on report templates. Default templates are provided for each review mode, but you can 

make modifications and save them back to the same or a new template. The intent is to auto-populate 

the reports as much as possible, so you only have to insert captured images and free text from your 

findings. 

Once you’ve entered the Report Screen, the Image Gallery and Reporting Tools are available from the 

Toolbox. The Image Gallery is accessible if you have saved key images or bookmarks during your reading 

session. If you have key images or bookmarks in the gallery, the gallery will display an enlarged view of 

the image when the mouse pointer hovers over the image thumbnail. You may double click on any 

image to transfer it to the report or you may drag and drop any key image into the report.  
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Image Gallery 
The Image Gallery panel is where screenshots, image view captures, bookmarks, snapshots and DICOM 

secondary captures are stored in a thumbnail view. These images may be exported or added to a report 

once the report screen is displayed. Images can also be previewed in a larger form by hovering your 

mouse over them, or they may be removed from the image gallery entirely, by highlighting the image 

and clicking the Remove button.  

Bookmarks are available in order for you to stop what you are doing and return at a later time without 

losing your previous work. You may double click on bookmarked images to restore a particular layout 

and crosshair position (when not previewing the report), as well as window/level and zoom settings. 

Bookmarks may also be exported to Casebook. Double clicking an image when viewing the report adds 

the image to the report page. 

The Image Gallery may be filtered by time point by using the dropdown menu at the bottom of the 

Image Gallery window. 

If a DICOM secondary capture image is present in the Image Gallery it may be displayed by selecting the 

‘Switch to Secondary Capture Screen’ icon. 

 

Reporting Tools 
It is recommended that the application window be full screen when creating the report. When 

converting to PDF, conversion of the report contents is based proportional to the screen height and 

width. 

The reporting tools panel is available in the Toolbox whenever the reporting screen is selected. This 

contains a number of controls which can be used to add information to the report or to manage the 

information contained in the report. 

Switch to Secondary 

Capture Screen icon  
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Items available to add include: 

• Text – this adds a text box to the currently displayed report page if there is space to do so. If 

there is insufficient space on the current page then a new page should be inserted and the text 

box placed there. 

• Statistics – this allows addition of the quantification statistics table displayed on the 

quantification screen to the report, allowing you to specify the tab from quantification screen 

statistics to include (Basic Tracking, RECIST, etc.) and for which datasets the statistics are to be 

included (i.e. CT, PET AC, etc.). 

• Data QC – this allows information configured for display from the applicable modality attributed 

defined in the Data QC options. 

• Patient Information – this adds the patient’s name, sex and date of birth to the report. 

Also included in the Reporting Tools is a section called Manage Report. This allows manual addition or 

removal of a report page. The report may be refreshed to update any manipulation to the data that may 

have been done during the report creation. Additionally, the page may be flipped from portrait to 

landscape layout. 

Saved Templates are listed in a drop down menu. The Restore button allows you to discard all changes 

and creates a new report based on the current template. Save Template allows you to name and save a 

custom template after selecting which Review Mode(s ) the template is valid. 
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The Export button prompts you to select which data series you would like the report associated, provide 

a series description, add the physician’s name, and add operator’s name. You may then select the 

destination from a drop down menu to choose File, SCP or Application Launcher. You may browse to 

select a destination directory, type in a file name and select the file format from a drop down menu. File 

format choices are DICOM, BMP, PNG and JPEG. 

The report may also be saved as a PDF. You will be prompted to specify a location on the local file 

system for the file to be saved. 

The Settings button allows you to enter and save your institution name, paper size and a logo for the 

header of your reports. You may also specify whether you would like to be prompted to refresh report 

content when exporting or if you would like the report to be automatically refreshed when exporting. 

You may right click on any of the page tabs at the top of the report to : 

• Remove a page 

• Add a page 

• Flip the page from landscape to portrait 

• Add a text box 

• Add statistics 

• Add Data QC 

• Add patient information 

• Select Options – to set preferences for your report. 
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Secondary Capture Screen 

 The Secondary Capture screen is a dedicated screen for viewing loaded secondary capture images 

and any bookmarks or screenshots created within XD3. Additionally, any RT Image objects loaded within 

XD3 will be added to the Image Gallery. To view an image, double-click the left mouse button on an 

image icon within the Image Gallery. The selected image will be displayed in the main viewing area at its 

natural size or, if it is larger than the display area, a scaled size that fits the view.The images can be 

manipulated with the standard Zoom, Pan and Window and Level controls. 

If the selected image series has multiple frames such as a multi-frame secondary capture, it is possible 

to scroll through the different image slices using the mouse wheel or the slice nagivation slider. 
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Setting User Preferences 

XD3 allows certain preferences to be applied on a per user basis. These settings are remembered 

between runs of the application. The preferences can be set via the Tools -> Options menu.  

Unless stated otherwise, all preferences described in this section apply on a per-user basis. Changes 

made will affect the currently logged-in user. In deployments where multiple users share the same user 

account, preference settings will also be shared. Changes made by one user will affect all users sharing 

that account so care must be taken to check important settings on startup. To avoid this it is strongly 

recommended that all unique users of the system have an individual user account. 

The following sections describe each tab in the Preferences section. 

DICOM  
This allows you to define DICOM nodes to which you wish to send data. These are global settings and 

hence require sufficient access rights to save changes. The access privileges required are those required 

to write to public or shared document areas. It is recommended, for example, to use a local 

administrator account when making system-wide changes such as defining DICOM preferences. 

NOTE: In general, this tab applies settings on a system-wide basis. All other preference tabs are 

applied on a per user basis. However, on some integrations, this may not be present at all or may 

apply on a per user basis rather than a global one. 

Data QC 
The Data QC tool is provided to allow you to view attributes from datasets loaded into the application 

for review. Attributes such as scanner manufacturer, software version, slice thickness, kVP, X-ray tube 

current and several others may be displayed for the CT data. Likewise, software version, injected dose, 

delay time, half-life, patient height, patient weight and additional attributes are available for PET data.  

If you wish, you may perform validation of this data based on limits that you define. For example, you 

may want to be warned if the delay time variance from the time of injection to time of scan between 

time points is greater than a certain amount of time. This Data QC screen will show you the attributes 

and flag any that are outside the tolerance levels you have set.  

Additionally, the Data QC screen may be included in a custom report. You may choose which attributes 

are visible and whether you would like to be prompted to display the Data QC screen on startup if there 

are validation warnings.  

To set your preferences: 

1. Select the modality from the list on the left to view the list of attributes available for inclusion 

and validation on the Data QC screen.  
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2. Double-click on an item in the list to indicate whether you want this row to be visible in the 

table and if you want to perform validation. Note that some items are for display only and the 

validation settings are disabled upon selection.  

3. Enter validation settings – most of the attributes allow you to set a minimum value (you will be 

warned if the value falls below this number), a maximum value (you will be warned if the value 

falls above this number) and a variance. The variance can be used if you wish to be notified of 

variances between time points. For example, you may want to be alerted if the injected dose 

varies by more than 5 mCi between any number of scans.  

At the bottom of the screen you can indicate whether you would like to be prompted to display the Data 

QC screen on startup if there are validation warnings, or if you want to automatically switch to the Data 

QC screen if there are validation warnings. Place a check in the box next to your preference and click 

Apply and OK to save your selections. 

Findings 
This tab allows you to choose whether to draw Regions as Outline, Shaded or Outline and shaded. 

Additionally, you may select to set the ROI Transparency percentage using a slider.  

The context menu may be configured by selecting the Context Menu button and ticking the items you 

wish to have available on the findings context menu (accessed by clicking right on any highlighted 

finding). 

Place a tick in the box if you wish to show tooltips in the Findings panel table. 

You may also set preferences for contour creation including Type of Region: Cuboid or Ellipsoid from 

drop down menu.  

A preference for default absolute threshold or default percentage threshold may be input as well from 

this screen. These settings will be applied when you use the corresponding region tools elsewhere in the 

application. 

Place a check in the box if you would like to center image views when you create a new region. 

Place a check in the box if you wish to be prompted for a name upon creation of a new finding. The 

Suggestions button allows you to add, edit and delete from the list of suggested finding labels. 

Multi-threshold region boundary values can be set, for the the create multiple threshold regions tool. 

Select Add to add a new threshold, Edit to edit the selected existing threshold, and Delete to delete a 

threshold. 

Click Apply and OK to save your selections. 

Licensing 
This option should be provided by your system administrator or by Mirada Customer Support personnel 

during installation. 
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Quantification 
Allows you to select the ROI statistics to display in the on-screen labels within the image views. The 

options are configurable on a per-modality basis. Any combination of the following statistics may be 

configured for display: 

• Mean 

• Max 

• Min 

• Threshold 

• Upper Threshold 

• Median 

• Peak 

• Volume 

• Intensity Distribution 

• Volume Doubling Time 

You may select whether you want your rulers to display measurements in mm or cm. 

Findings Table preferences allow you to select the enabled statistics tabs in the Findings Table view. 

Options are: 

• Intensity Distribution 

• PERCIST 

• RECIST 

• Regions Tracking 

• WHO 

• Advanced 

If you have created any custom tabs, they will be available for selection in this space as well. 

Select your default statistics tab for display in the Findings Table from the drop down menu.  

Click Apply and OK to save your selections. 

Region Intensity Distribution 
The Region Intensity Distribution tool allows you to set categories for voxel intensities within a region 

of interest. For example, you may wish to assign categories for air, water, bone, contrast, fat, etc. in a CT 

region of interest. These categories are reported in parts of the application that report the region 

statistics. These are reported via the image view statistics, the intensity distribution graphs from the 

Regions Table and from the regions tracking tab on the Regions Table. The categories may be set in User 

Preferences via Tools -> Options on the Region Intensity Distribution tab.  
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Select the modality for which you wish to set intensity ranges from the list on the left. Select the 

quantification method from the dropdown menu. Click on New to create a new region intensity 

distribution definition. This will open the dialog box which allows you to set the number and range of 

intensity levels. Intensity Distribution definitions can also be cloned from existing ones and then 

modified. They cannot be edited once created. 

 
Use the green ‘+’ to add a category and use the red ‘X’ to delete a category.  

You may enter the values for the ranges in the and lower bound and upper bound boxes (double click in 

the box to enter numbers). Ranges may be defined with gaps between one category upper bound and 

the next category lower bound. In a similar way, they can be set to overlap so a voxel could be counted 

in multiple categories. It should be noted that gaps or overlapping voxels will likely result in the reported 

percentages not adding up to 100% for any given region. 

 Enter the names for your categories (e.g. air, water, contrast, bone, etc.) by double clicking the category 

name. The category color can be changed by selecting the colored squares to the left of the category 

name. This sets the color to represent that category in the graphical display (i.e. Intensity Distribution 

graphs). Click OK to continue and save your selections. 
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When a registration exists between a pair of datasets, it is possible to draw a region on one and the 

system will automatically create a shadowed region on the other. For example, when creating a region 

on the PET dataset, the system will automatically create the same region on the CT. The accuracy of the 

intensity distribution is limited by the quality of the registration. When relying on quantification 

statistics of a shadowed region created by the system, the quality of the registration should be checked 

in the Registration Manager first. In the example below the PET/CT has been deliberately misregistered 

to highlight the issue. A thresholded PET region has been automatically shadowed to the CT dataset and 

Hounsfield-based intensity distribution statistics are displayed for the CT region. The region has been 

classified as 62.5% air due to the misregistration placing the lesion in the lung. 

 

Report 
Allows you to customize your report. The following preferences are available: 

• Insert your Institution Name 

• Select whether you want to be prompted to refresh data included in the report or if you want 

the system to automatically refresh your report upon export 

• Select Paper Size 

• Insert a Logo to be displayed on your report 

Click Apply and OK to save your selections. 
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Review Modes  
This allows you to select a Review Mode and then select a default report template, an automatic 

registration scheme, and select from a list of Layouts which you would like to have available for that 

Review Mode. 

 
Both Mirada provided layouts and custom layouts are listed. Check the box for layouts you wish to have 

available. To select layouts to be displayed as Favorites in the Toolbox in the upper left-hand corner of 

your screen, check the box under the Favorite heading.  

If you wish to assign a layout to a hotkey, simply double-click in the hotkey field in the table and press 

the keystroke you would like to use as the shortcut. You may use single letters or complex hotkeys such 

as “ctrl+shift+1”. After you have pressed your keystroke, the hotkey or combination will be displayed. 

When you have assigned the hotkeys click Apply. The hotkeys will be available for use upon restarting 

the XD3 application and the Application Launcher. 
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Under the list of Layouts is a Window Defaults… button. Use this screen to define layouts for single or 

for multiple Windows. This allows you to define default layouts for a single, dual or triple screen monitor 

setup. The Fallback layouts are available to use if the defaults are not available. For example, if you have 

a 2 Time Point Layout selected as default for Adaptive Planning Review mode and you load a single time 

point study, the Fallback layout would be used. 

Use the Colormap Defaults button to choose color maps for base and overlay datasets in any of the 

Review Modes.  

When an automatic registration scheme is set to be run on application load, the results should be 

reviewed using the crosshair alignment and the quality control tools available via Registration -> 

Registration Manager to ensure that the registration is satisfactory. This is particularly important before 

propagation of ROIs between time points.  

Session 
This page allows you to set a preference whether you would like to be prompted to save your session 

upon exit of the application, or if you want to automatically save each session. 

Click Apply and OK to save your selections. 

User Interface 
Select the Hotkey Configuration button to set any of the tools in the toolbar or any of the menu items 

to hotkeys. Double-click in the Hotkey column and type the key or keystroke combination you wish to 

use.  

Select the ToolBar Configuration button to select which tools you want to have visible on your Toolbar. 

Place a check in the box next to those items you want to include. Select OK to save your selections and 

update the toolbar. 

Select the Context Menu Configuration button to select which tools you want to have visible in your 

context menu. The context menu 

 is accessed via the right mouse button in any image window. Place a check in the box next to those 

items you want to include. Select OK to save your selections and update the context menu. 

Startup Options allow you to make changes which do not take effect until the application is re-launched. 

Items you may change are: 

• Crosshair Style: may be set to Plain, Open, Target, or Frame Marker 

• Zoom Binding: may be set to Axial/Coronal + Sagittal, All, or None; where 

o None = Only the image view being manipulated is adjusted. 

o All = All image views are adjusted. 
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o Axial + Coronal/Sagittal – If an axial image is manipulated, all axial images are zoomed. If 

a coronal or sagittal image view is zoomed, all coronal and sagittal image views are 

adjusted. 

NOTE: MIPS and Orthogonal views do not share zoom factors. 

• Pan Binding: may be set to Per-Plane, or None, where: 

o Per-Plane = If a plane (e.g. axial) is manipulated, then all the image views of that plane 

are panned 

o None = Only the image view being manipulated is adjusted 

NOTE: MIPs and Orthogonal views do not share pan adjustments. 

Select compact display mode for optimized display when using the application on a laptop. 

Enable Direct3D Acceleration is enabled by default. This setting allows optimized performance with 

certain monitors and should only be disabled in the event of performance issues that are thought to be 

monitor related. 

If additional language packs are installed, use the Set Language dropdown to select the application 

language. 

Click Apply and OK to save your selections. 

Views 
View Settings allow you to: 

• Enable the use of high contrast borders 

• Show colored planes – displays colored frames around each plane displayed 

• Show progress information 

• Automatically play MIP cine 

• Select the MIP frame count from the dropdown menu – this selection takes effect only after a 

new launch of the application and affects both on-screen and an exported MIP cine 

• Select the behavior at the end of a slice cine – choose loop, pause, reverse from the dropdown 

menu 

• Determine how many slices are skipped when using Page Up and Page Down keys 

• Set whether you want to navigate slices by anatomy or slice number 

The Information Overlays section allows you to: 

• Change the interactive text color 

• Adjust the font size in the image windows 

• Set whether or not you want to show the instance number on slices 

• Set whether or not you want to show series description  
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• Set whether or not you want to show accession number 

• Set the option for slice numbering (i.e. head to foot or foot to head) 

Care should be taken to ensure that the slice numbering scheme chosen in XD3 matches that of 

any system used to launch XD3. 

The slice number option determines which numbering scheme will be used for display in the axial view 

only. Head to Foot will number the most superior slice as 1 and then slice numbers increment towards 

the feet. Foot to Head will number the most inferior slice as 1 and then slice numbers increment 

towards the head. It is important to note that these numbers refer to the slice number of the 

reconstructed 3D volume. It is possible for a reconstructed 3D volume to have greater or fewer slices 

than the number of individual instances from which it was reconstructed. This happens when the slice 

thickness or slice spacing varies within the original series slices. The Views configuration page has an 

option to display the image instance number. This number is the slice instance number of the slice from 

which the voxel at the crosshair location was taken. When reporting a slice number, the original instance 

number should be used rather than the reconstructed slice number. This will guarantee interoperability 

with other systems. The slice numbers displayed in the views are of the form: a/b (c) where a is the 

reconstructed slice number, b is the number of reconstructed slices in the current plane and c is the 

image instance number. 

The slice navigation slider is specifically designed to be able to navigate quickly to a desired area 

within an image view. As such the slice navigation slider does not display every slice in the view being 

navigated from the currently displayed slice to the slice represented by the slider position set. 

Window Level  
Allows you to select modality-specific Window and Level settings to apply on start-up for CT, PT, NM, 

and MR datasets. Use the drop down menus to select the preset type and the preset values you wish to 

apply on startup for the initial data load. 
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You may specify whether to override the window level values contained within the data with your 

selected preset by checking the box.  

To assign a window level setting to a hotkey of your choice, double –click in the Hotkey field in the table 

and press your keystroke as normal. For example, press control key and F1 to assign a shortcut of “ctrl + 

F1”. Because the keys are set per modality, the same key may be used for different modalities. The 

hotkeys will be available for use upon restarting the XD3 application and the Application Launcher. 

Use the drop down box at the bottom of the window to select window/level binding on startup. You 

may specify whether you want bindings applied to all displayed datasets or by time point. 

Click Apply and OK to save selections.  
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Keyboard Shortcuts 

Keyboard Shortcut Mappings 

Action Keyboard 
Shortcut 

Description 

Toggle between Time 
Points 

Space Bar Toggles between time points when multiple time points 
are loaded in a review mode and a single time point layout 
is used. 

Zoom Ctrl + mouse 
wheel 

Magnifies images in the selected image window. 

Pan Ctrl + left mouse 
button 

Pans images in the selected image window. 

Undo Ctrl + Z Undo last step. 

Redo Ctrl + Y Redo last step. 

Copy Ctrl + C Only available from the Report Screen – copies items from 
a page on the report to allow them to be pasted on the 
same or a different page. 

Cut Ctrl + X Only available from the Report Screen – cuts items from a 
page on the report to allow them to be pasted (moved) to 
an area on the same or a different page. 

Paste Ctrl + V Only available from the Report Screen – Pastes a 
previously cut or copied item from a page on the report. 

Delete Report Item Delete Only Available from the Report Screen – deletes the 
selected item on a report page. 

Capture View Ctrl + E Sends the selected view to the Image Gallery. 

Capture Screenshot Ctrl + Shift + E Sends a screenshot of the selected application window to 
the Image Gallery. 

Copy View to 
Clipboard 

Ctrl + K Copies the image in the currently selected view to the 
clipboard. 

Copy Screenshot to 
Clipboard 

Ctrl + Shift + K Copies a screenshot of the currently selected application 
window to the clipboard. 

Help F1 Opens the help file. 

Full Screen F11 Displays the application as full screen, removing toolbar 
and side bar 

Return to Layouts CTRL + Left Returns the selected window from specific screens to the 
image layouts 

Rigid Registration F2 Applies the automatic rigid registrations defined in the 
review mode. 

Deformable 
Registration 

F5 Applies the automatic Deformable  
registrations defined in the review mode. 

Show Displacement 
Field 

SHIFT+CTRL+F Shows the displacement field when a deformable 
registration exists between the datasets visible in a fused 
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image view 

Show Displacement 
Grid 

SHIFT+CTRL+G Shows the deformation grid when a deformable 
registration exists between the datasets visible in a fused 
image view 

Show Displacement 
Map 

SHIFT+CTRL+M Shows the deformation map when a deformable 
registration exists between the datasets visible in a fused 
image view 

Increase Slice Index Up Arrow Increases the slice index by one in the selected view. E.g. if 
the currently selected view is a Coronal view at slice index 
314, pressing the up arrow increases the slice index in the 
Coronal view to 315. 

Decrease Slice Index Down Arrow Decreases the slice index by one in the selected view. E.g. 
if the currently selected view is a Sagittal view at slice 
index 112, pressing the down arrow decreases the slice 
index in the Sagittal view to 111. 

Increase by 10 slices Page up  

Decrease by 10 slices Page down  

Restore Object 
selection mode 

Escape Exits control modes such as window level control mode 

Increase Slice Index Up Arrow Increases the slice index by one in the selected view; for 
example, if the currently selected view is Coronal view at 
slice index 314, pressing the up arrow increases the slice 
index in the Coronal view to 315. 

Decrease Slice Index Down Arrow Decreases the slice index by one in the selected view; for 
example, if the currently selected view is a Sagittal view at 
slice index 112, pressing the down arrow decreases the 
slice index in the Sagittal view to 111. 

Show/Hide Volume 
Bounds 

B Toggles display of Volume Bounds in the display window. 

Toggle Annotations A Removes annotations from the image views 

Toggle Navigation 
Controls 

N Show/Hide navigation controls 

Remove Crosshairs C Removes crosshairs from the image views. 

Remove Information 
Overlays from the 
image views 

I Removes the Information Overlays from the image views 

Show Timepoint 
Information 

T When launched with more than one timepoint, displays 
the timepoint name and date in the image views. 

Toggle Overlay O Toggles the overlay between the current transparency 
setting and fully transparent. This has the effect of 
showing and hiding the overlay. This is only available if the 
currently selected view has both a base and overlay 
dataset. 
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Remove Patient 
Information overlays 
from image views 

P Removes the Patient Information from Image Views. 

Show/Hide Region 
Statistics 

S Toggles display of region statistics on and off in the display 
window. 

Toggle ROIs R Removes ROIs and associated text from the image views 

Toggle Region 
Crosshair Display 

V Displays the crosshair ROI 

Increase Volume 
Crosshair Size 

=  

Decrease Volume 
Crosshair Size 

-  

Define Ellipsoid Region CTRL+L  

Define Rectangular 
Region 

CTRL+R  

Paint Tool Q  

Eraser Tool W  

Toggle PET AC/NAC T Replaces the selected PET or SPECT AC dataset with the 
PET or SPECT NAC dataset. 

Delete Object Delete Deletes the currently selected annotations, rulers, angles 
or regions. 

View Context Menu Right Mouse 
button 

Displays the floating toolbar (also known as context menu) 
in an image window. 

Move to Start Home This action depends on the currently selected view and 
preference setting: 
 
System preferences set to navigate by slice number: 
 

• Axial: moves to the axial slice index at the bottom 
of the patient 

• Coronal: moves to the coronal slice index with the 
highest value 

• Sagittal: moves to the sagittals slice index with the 
highest value 

  
System preferences set to navigate by anatomy: 
 

• Axial: moves to the most inferior slice in the axial 
view 

• Coronal: moves to the most posterior slice in the 
coronal view 

• Sagittal: moves to the most leftward slice in the 
sagittals view 
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Licensing 

XD3 includes licensed software components. Licenses for these components follow. These licenses do 

not apply to XD3 as a whole. 

Licenses 
Copyright (c) 2002-2004 JGoodies Karsten Lentzsch. All rights reserved. 

Redistribution and use in source and binary forms, with or without modification, are permitted provided 

that the following conditions are met: 

• Redistributions of source code must retain the above copyright notice, this list of conditions and 

the following disclaimer. 

• Redistributions in binary form must reproduce the above copyright notice, this list of conditions 

and the following disclaimer in the documentation and/or other materials provided with the 

distribution.  

• Neither the name of JGoodies Karsten Lentzsch nor the names of its contributors may be used 

to endorse or promote products derived from this software without specific prior written 

permission. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY 

EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL 

THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 

PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 

INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 

LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 

THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

 

iText library – Copyright (c) 1999-2009 by Bruno Lowagie and Paolo. 

 

MOZILLA PUBLIC LICENSE 

        Version 1.1 

 

        --------------- 

 

1. Definitions. 
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  1.0.1. "Commercial Use" means distribution or otherwise making the 

  Covered Code available to a third party. 

 

  1.1. "Contributor" means each entity that creates or contributes to 

  the creation of Modifications. 

 

  1.2. "Contributor Version" means the combination of the Original 

  Code, prior Modifications used by a Contributor, and the Modifications 

  made by that particular Contributor. 

 

  1.3. "Covered Code" means the Original Code or Modifications or the 

  combination of the Original Code and Modifications, in each case 

  including portions thereof. 

 

  1.4. "Electronic Distribution Mechanism" means a mechanism generally 

  accepted in the software development community for the electronic 

  transfer of data. 

 

  1.5. "Executable" means Covered Code in any form other than Source 

  Code. 

 

  1.6. "Initial Developer" means the individual or entity identified 

  as the Initial Developer in the Source Code notice required by Exhibit 

  A. 

 

  1.7. "Larger Work" means a work which combines Covered Code or 

  portions thereof with code not governed by the terms of this License. 
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  1.8. "License" means this document. 

 

  1.8.1. "Licensable" means having the right to grant, to the maximum 

  extent possible, whether at the time of the initial grant or 

  subsequently acquired, any and all of the rights conveyed herein. 

 

  1.9. "Modifications" means any addition to or deletion from the 

  substance or structure of either the Original Code or any previous 

  Modifications. When Covered Code is released as a series of files, a 

  Modification is: 

   A. Any addition to or deletion from the contents of a file 

   containing Original Code or previous Modifications. 

 

   B. Any new file that contains any part of the Original Code or 

   previous Modifications. 

 

  1.10. "Original Code" means Source Code of computer software code 

  which is described in the Source Code notice required by Exhibit A as 

  Original Code, and which, at the time of its release under this 

  License is not already Covered Code governed by this License. 

 

  1.10.1. "Patent Claims" means any patent claim(s), now owned or 

  hereafter acquired, including without limitation, method, process, 

  and apparatus claims, in any patent Licensable by grantor. 

 

  1.11. "Source Code" means the preferred form of the Covered Code for 

  making modifications to it, including all modules it contains, plus 
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  any associated interface definition files, scripts used to control 

  compilation and installation of an Executable, or source code 

  differential comparisons against either the Original Code or another 

  well known, available Covered Code of the Contributor's choice. The 

  Source Code can be in a compressed or archival form, provided the 

  appropriate decompression or de-archiving software is widely available 

  for no charge. 

 

  1.12. "You" (or "Your") means an individual or a legal entity 

  exercising rights under, and complying with all of the terms of, this 

  License or a future version of this License issued under Section 6.1. 

  For legal entities, "You" includes any entity which controls, is 

  controlled by, or is under common control with You. For purposes of 

  this definition, "control" means (a) the power, direct or indirect, 

  to cause the direction or management of such entity, whether by 

  contract or otherwise, or (b) ownership of more than fifty percent 

  (50%) of the outstanding shares or beneficial ownership of such 

  entity. 

 

2. Source Code License. 

 

  2.1. The Initial Developer Grant. 

  The Initial Developer hereby grants You a world-wide, royalty-free, 

  non-exclusive license, subject to third party intellectual property 

  claims: 

   (a) under intellectual property rights (other than patent or 

   trademark) Licensable by Initial Developer to use, reproduce, 

   modify, display, perform, sublicense and distribute the Original 
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   Code (or portions thereof) with or without Modifications, and/or 

   as part of a Larger Work; and 

 

   (b) under Patents Claims infringed by the making, using or 

   selling of Original Code, to make, have made, use, practice, 

   sell, and offer for sale, and/or otherwise dispose of the 

   Original Code (or portions thereof). 

 

   (c) the licenses granted in this Section 2.1(a) and (b) are 

   effective on the date Initial Developer first distributes 

   Original Code under the terms of this License. 

 

   (d) Notwithstanding Section 2.1(b) above, no patent license is 

   granted: 1) for code that You delete from the Original Code; 2) 

   separate from the Original Code; or 3) for infringements caused 

   by: i) the modification of the Original Code or ii) the 

   combination of the Original Code with other software or devices. 

 

  2.2. Contributor Grant. 

  Subject to third party intellectual property claims, each Contributor 

  hereby grants You a world-wide, royalty-free, non-exclusive license 

 

   (a) under intellectual property rights (other than patent or 

   trademark) Licensable by Contributor, to use, reproduce, modify, 

   display, perform, sublicense and distribute the Modifications 

   created by such Contributor (or portions thereof) either on an 

   unmodified basis, with other Modifications, as Covered Code 

   and/or as part of a Larger Work; and 
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   (b) under Patent Claims infringed by the making, using, or 

   selling of Modifications made by that Contributor either alone 

   and/or in combination with its Contributor Version (or portions 

   of such combination), to make, use, sell, offer for sale, have 

   made, and/or otherwise dispose of: 1) Modifications made by that 

   Contributor (or portions thereof); and 2) the combination of 

   Modifications made by that Contributor with its Contributor 

   Version (or portions of such combination). 

 

   (c) the licenses granted in Sections 2.2(a) and 2.2(b) are 

   effective on the date Contributor first makes Commercial Use of 

   the Covered Code. 

 

   (d) Notwithstanding Section 2.2(b) above, no patent license is 

   granted: 1) for any code that Contributor has deleted from the 

   Contributor Version; 2) separate from the Contributor Version; 

   3) for infringements caused by: i) third party modifications of 

   Contributor Version or ii) the combination of Modifications made 

   by that Contributor with other software (except as part of the 

   Contributor Version) or other devices; or 4) under Patent Claims 

   infringed by Covered Code in the absence of Modifications made by 

   that Contributor. 

 

3. Distribution Obligations. 

 

  3.1. Application of License. 

  The Modifications which You create or to which You contribute are 
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  governed by the terms of this License, including without limitation 

  Section 2.2. The Source Code version of Covered Code may be 

  distributed only under the terms of this License or a future version 

  of this License released under Section 6.1, and You must include a 

  copy of this License with every copy of the Source Code You 

  distribute. You may not offer or impose any terms on any Source Code 

  version that alters or restricts the applicable version of this 

  License or the recipients' rights hereunder. However, You may include 

  an additional document offering the additional rights described in 

  Section 3.5. 

 

  3.2. Availability of Source Code. 

  Any Modification which You create or to which You contribute must be 

  made available in Source Code form under the terms of this License 

  either on the same media as an Executable version or via an accepted 

  Electronic Distribution Mechanism to anyone to whom you made an 

  Executable version available; and if made available via Electronic 

  Distribution Mechanism, must remain available for at least twelve (12) 

  months after the date it initially became available, or at least six 

  (6) months after a subsequent version of that particular Modification 

  has been made available to such recipients. You are responsible for 

  ensuring that the Source Code version remains available even if the 

  Electronic Distribution Mechanism is maintained by a third party. 

 

  3.3. Description of Modifications. 

  You must cause all Covered Code to which You contribute to contain a 

  file documenting the changes You made to create that Covered Code and 

  the date of any change. You must include a prominent statement that 
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  the Modification is derived, directly or indirectly, from Original 

  Code provided by the Initial Developer and including the name of the 

  Initial Developer in (a) the Source Code, and (b) in any notice in an 

  Executable version or related documentation in which You describe the 

  origin or ownership of the Covered Code. 

 

  3.4. Intellectual Property Matters 

   (a) Third Party Claims. 

   If Contributor has knowledge that a license under a third party's 

   intellectual property rights is required to exercise the rights 

   granted by such Contributor under Sections 2.1 or 2.2, 

   Contributor must include a text file with the Source Code 

   distribution titled "LEGAL" which describes the claim and the 

   party making the claim in sufficient detail that a recipient will 

   know whom to contact. If Contributor obtains such knowledge after 

   the Modification is made available as described in Section 3.2, 

   Contributor shall promptly modify the LEGAL file in all copies 

   Contributor makes available thereafter and shall take other steps 

   (such as notifying appropriate mailing lists or newsgroups) 

   reasonably calculated to inform those who received the Covered 

   Code that new knowledge has been obtained. 

 

   (b) Contributor APIs. 

   If Contributor's Modifications include an application programming 

   interface and Contributor has knowledge of patent licenses which 

   are reasonably necessary to implement that API, Contributor must 

   also include this information in the LEGAL file. 
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    (c) Representations. 

   Contributor represents that, except as disclosed pursuant to 

   Section 3.4(a) above, Contributor believes that Contributor's 

   Modifications are Contributor's original creation(s) and/or 

   Contributor has sufficient rights to grant the rights conveyed by 

   this License. 

 

  3.5. Required Notices. 

  You must duplicate the notice in Exhibit A in each file of the Source 

  Code. If it is not possible to put such notice in a particular Source 

  Code file due to its structure, then You must include such notice in a 

  location (such as a relevant directory) where a user would be likely 

  to look for such a notice. If You created one or more Modification(s) 

  You may add your name as a Contributor to the notice described in 

  Exhibit A. You must also duplicate this License in any documentation 

  for the Source Code where You describe recipients' rights or ownership 

  rights relating to Covered Code. You may choose to offer, and to 

  charge a fee for, warranty, support, indemnity or liability 

  obligations to one or more recipients of Covered Code. However, You 

  may do so only on Your own behalf, and not on behalf of the Initial 

  Developer or any Contributor. You must make it absolutely clear than 

  any such warranty, support, indemnity or liability obligation is 

  offered by You alone, and You hereby agree to indemnify the Initial 

  Developer and every Contributor for any liability incurred by the 

  Initial Developer or such Contributor as a result of warranty, 

  support, indemnity or liability terms You offer. 

 

  3.6. Distribution of Executable Versions. 
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  You may distribute Covered Code in Executable form only if the 

  requirements of Section 3.1-3.5 have been met for that Covered Code, 

  and if You include a notice stating that the Source Code version of 

  the Covered Code is available under the terms of this License, 

  including a description of how and where You have fulfilled the 

  obligations of Section 3.2. The notice must be conspicuously included 

  in any notice in an Executable version, related documentation or 

  collateral in which You describe recipients' rights relating to the 

  Covered Code. You may distribute the Executable version of Covered 

  Code or ownership rights under a license of Your choice, which may 

  contain terms different from this License, provided that You are in 

  compliance with the terms of this License and that the license for the 

  Executable version does not attempt to limit or alter the recipient's 

  rights in the Source Code version from the rights set forth in this 

  License. If You distribute the Executable version under a different 

  license You must make it absolutely clear that any terms which differ 

  from this License are offered by You alone, not by the Initial 

  Developer or any Contributor. You hereby agree to indemnify the 

  Initial Developer and every Contributor for any liability incurred by 

  the Initial Developer or such Contributor as a result of any such 

  terms You offer. 

 

  3.7. Larger Works. 

  You may create a Larger Work by combining Covered Code with other code 

  not governed by the terms of this License and distribute the Larger 

  Work as a single product. In such a case, You must make sure the 

  requirements of this License are fulfilled for the Covered Code. 
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4. Inability to Comply Due to Statute or Regulation. 

 

  If it is impossible for You to comply with any of the terms of this 

  License with respect to some or all of the Covered Code due to 

  statute, judicial order, or regulation then You must: (a) comply with 

  the terms of this License to the maximum extent possible; and (b) 

  describe the limitations and the code they affect. Such description 

  must be included in the LEGAL file described in Section 3.4 and must 

  be included with all distributions of the Source Code. Except to the 

  extent prohibited by statute or regulation, such description must be 

  sufficiently detailed for a recipient of ordinary skill to be able to 

  understand it. 

 

5. Application of this License. 

 

  This License applies to code to which the Initial Developer has 

  attached the notice in Exhibit A and to related Covered Code. 

 

6. Versions of the License. 

 

  6.1. New Versions. 

  Netscape Communications Corporation ("Netscape") may publish revised 

  and/or new versions of the License from time to time. Each version 

  will be given a distinguishing version number. 

 

  6.2. Effect of New Versions. 

  Once Covered Code has been published under a particular version of the 

  License, You may always continue to use it under the terms of that 
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  version. You may also choose to use such Covered Code under the terms 

  of any subsequent version of the License published by Netscape. No one 

  other than Netscape has the right to modify the terms applicable to 

  Covered Code created under this License. 

 

  6.3. Derivative Works. 

  If You create or use a modified version of this License (which you may 

  only do in order to apply it to code which is not already Covered Code 

  governed by this License), You must (a) rename Your license so that 

  the phrases "Mozilla", "MOZILLAPL", "MOZPL", "Netscape", 

  "MPL", "NPL" or any confusingly similar phrase do not appear in your 

  license (except to note that your license differs from this License) 

  and (b) otherwise make it clear that Your version of the license 

  contains terms which differ from the Mozilla Public License and 

  Netscape Public License. (Filling in the name of the Initial 

  Developer, Original Code or Contributor in the notice described in 

  Exhibit A shall not of themselves be deemed to be modifications of 

  this License.) 

 

7. DISCLAIMER OF WARRANTY. 

 

  COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, 

  WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, 

  WITHOUT LIMITATION, WARRANTIES THAT THE COVERED CODE IS FREE OF 

  DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGING. 

  THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED CODE 

  IS WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT, 

  YOU (NOT THE INITIAL DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE 
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  COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER 

  OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF 

  ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER. 

 

8. TERMINATION. 

 

  8.1. This License and the rights granted hereunder will terminate 

  automatically if You fail to comply with terms herein and fail to cure 

  such breach within 30 days of becoming aware of the breach. All 

  sublicenses to the Covered Code which are properly granted shall 

  survive any termination of this License. Provisions which, by their 

  nature, must remain in effect beyond the termination of this License 

  shall survive. 

 

  8.2. If You initiate litigation by asserting a patent infringement 

  claim (excluding declatory judgment actions) against Initial Developer 

  or a Contributor (the Initial Developer or Contributor against whom 

  You file such action is referred to as "Participant") alleging that: 

 

  (a) such Participant's Contributor Version directly or indirectly 

  infringes any patent, then any and all rights granted by such 

  Participant to You under Sections 2.1 and/or 2.2 of this License 

  shall, upon 60 days notice from Participant terminate prospectively, 

  unless if within 60 days after receipt of notice You either: (i) 

  agree in writing to pay Participant a mutually agreeable reasonable 

  royalty for Your past and future use of Modifications made by such 

  Participant, or (ii) withdraw Your litigation claim with respect to 

  the Contributor Version against such Participant. If within 60 days 
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  of notice, a reasonable royalty and payment arrangement are not 

  mutually agreed upon in writing by the parties or the litigation claim 

  is not withdrawn, the rights granted by Participant to You under 

  Sections 2.1 and/or 2.2 automatically terminate at the expiration of 

  the 60 day notice period specified above. 

 

  (b) any software, hardware, or device, other than such Participant's 

  Contributor Version, directly or indirectly infringes any patent, then 

  any rights granted to You by such Participant under Sections 2.1(b) 

  and 2.2(b) are revoked effective as of the date You first made, used, 

  sold, distributed, or had made, Modifications made by that 

  Participant. 

 

  8.3. If You assert a patent infringement claim against Participant 

  alleging that such Participant's Contributor Version directly or 

  indirectly infringes any patent where such claim is resolved (such as 

  by license or settlement) prior to the initiation of patent 

  infringement litigation, then the reasonable value of the licenses 

  granted by such Participant under Sections 2.1 or 2.2 shall be taken 

  into account in determining the amount or value of any payment or 

  license. 

 

  8.4. In the event of termination under Sections 8.1 or 8.2 above, 

  all end user license agreements (excluding distributors and resellers) 

  which have been validly granted by You or any distributor hereunder 

  prior to termination shall survive termination. 

 

9. LIMITATION OF LIABILITY. 
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  UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT 

  (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL YOU, THE INITIAL 

  DEVELOPER, ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE, 

  OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR 

  ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY 

  CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, 

  WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER 

  COMMERCIAL DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN 

  INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF 

  LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY 

  RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE EXTENT APPLICABLE LAW 

  PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE 

  EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO 

  THIS EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU. 

 

10. U.S. GOVERNMENT END USERS. 

 

  The Covered Code is a "commercial item," as that term is defined in 

  48 C.F.R. 2.101 (Oct. 1995), consisting of "commercial computer 

  software" and "commercial computer software documentation," as such 

  terms are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48 

  C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995), 

  all U.S. Government End Users acquire Covered Code with only those 

  rights set forth herein. 

 

11. MISCELLANEOUS. 

 



  mm2357-6 
  FUXD-USER 
 

Mirada Medical | XD 165 

 

  This License represents the complete agreement concerning subject 

  matter hereof. If any provision of this License is held to be 

  unenforceable, such provision shall be reformed only to the extent 

  necessary to make it enforceable. This License shall be governed by 

  California law provisions (except to the extent applicable law, if 

  any, provides otherwise), excluding its conflict-of-law provisions. 

  With respect to disputes in which at least one party is a citizen of, 

  or an entity chartered or registered to do business in the United 

  States of America, any litigation relating to this License shall be 

  subject to the jurisdiction of the Federal Courts of the Northern 

  District of California, with venue lying in Santa Clara County, 

  California, with the losing party responsible for costs, including 

  without limitation, court costs and reasonable attorneys' fees and 

  expenses. The application of the United Nations Convention on 

  Contracts for the International Sale of Goods is expressly excluded. 

  Any law or regulation which provides that the language of a contract 

  shall be construed against the drafter shall not apply to this 

  License. 

 

12. RESPONSIBILITY FOR CLAIMS. 

 

  As between Initial Developer and the Contributors, each party is 

  responsible for claims and damages arising, directly or indirectly, 

  out of its utilization of rights under this License and You agree to 

  work with Initial Developer and Contributors to distribute such 

  responsibility on an equitable basis. Nothing herein is intended or 

  shall be deemed to constitute any admission of liability. 
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13. MULTIPLE-LICENSED CODE. 

 

  Initial Developer may designate portions of the Covered Code as 

  "Multiple-Licensed". "Multiple-Licensed" means that the Initial 

  Developer permits you to utilize portions of the Covered Code under 

  Your choice of the NPL or the alternative licenses, if any, specified 

  by the Initial Developer in the file described in Exhibit A. 

 

EXHIBIT A -Mozilla Public License. 

 

  ``The contents of this file are subject to the Mozilla Public License 

  Version 1.1 (the "License"); you may not use this file except in 

  compliance with the License. You may obtain a copy of the License at 

  http://www.mozilla.org/MPL/ 

 

  Software distributed under the License is distributed on an "AS IS" 

  basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the 

  License for the specific language governing rights and limitations 

  under the License. 

 

  The Original Code is ______________________________________. 

 

  The Initial Developer of the Original Code is ________________________. 

  Portions created by ______________________ are Copyright (C) ______ 

  _______________________. All Rights Reserved. 

 

  Contributor(s): ______________________________________. 
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  Alternatively, the contents of this file may be used under the terms 

  of the _____ license (the "[___] License"), in which case the 

  provisions of [______] License are applicable instead of those 

  above. If you wish to allow use of your version of this file only 

  under the terms of the [____] License and not to allow others to use 

  your version of this file under the MPL, indicate your decision by 

  deleting the provisions above and replace them with the notice and 

  other provisions required by the [___] License. If you do not delete 

  the provisions above, a recipient may use your version of this file 

  under either the MPL or the [___] License." 

 

  [NOTE: The text of this Exhibit A may differ slightly from the text of 

  the notices in the Source Code files of the Original Code. You should 

  use the text of this Exhibit A rather than the text found in the 

  Original Code Source Code for Your Modifications.] 

 

 

   GNU LESSER GENERAL PUBLIC LICENSE 

      Version 3, 29 June 2007 

 

 Copyright (C) 2007 Free Software Foundation, Inc. <http://fsf.org/> 

 Everyone is permitted to copy and distribute verbatim copies 

 of this license document, but changing it is not allowed. 

 

 

 This version of the GNU Lesser General Public License incorporates 

the terms and conditions of version 3 of the GNU General Public 

License, supplemented by the additional permissions listed below. 
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 0. Additional Definitions. 

 

 As used herein, "this License" refers to version 3 of the GNU Lesser 

General Public License, and the "GNU GPL" refers to version 3 of the GNU 

General Public License. 

 

 "The Library" refers to a covered work governed by this License, 

other than an Application or a Combined Work as defined below. 

 

 An "Application" is any work that makes use of an interface provided 

by the Library, but which is not otherwise based on the Library. 

Defining a subclass of a class defined by the Library is deemed a mode 

of using an interface provided by the Library. 

 

 A "Combined Work" is a work produced by combining or linking an 

Application with the Library. The particular version of the Library 

with which the Combined Work was made is also called the "Linked 

Version". 

 

 The "Minimal Corresponding Source" for a Combined Work means the 

Corresponding Source for the Combined Work, excluding any source code 

for portions of the Combined Work that, considered in isolation, are 

based on the Application, and not on the Linked Version. 

 

 The "Corresponding Application Code" for a Combined Work means the 

object code and/or source code for the Application, including any data 

and utility programs needed for reproducing the Combined Work from the 
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Application, but excluding the System Libraries of the Combined Work. 

 

 1. Exception to Section 3 of the GNU GPL. 

 

 You may convey a covered work under sections 3 and 4 of this License 

without being bound by section 3 of the GNU GPL. 

 

 2. Conveying Modified Versions. 

 

 If you modify a copy of the Library, and, in your modifications, a 

facility refers to a function or data to be supplied by an Application 

that uses the facility (other than as an argument passed when the 

facility is invoked), then you may convey a copy of the modified 

version: 

 

 a) under this License, provided that you make a good faith effort to 

 ensure that, in the event an Application does not supply the 

 function or data, the facility still operates, and performs 

 whatever part of its purpose remains meaningful, or 

 

 b) under the GNU GPL, with none of the additional permissions of 

 this License applicable to that copy. 

 

 3. Object Code Incorporating Material from Library Header Files. 

 

 The object code form of an Application may incorporate material from 

a header file that is part of the Library. You may convey such object 

code under terms of your choice, provided that, if the incorporated 
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material is not limited to numerical parameters, data structure 

layouts and accessors, or small macros, inline functions and templates 

(ten or fewer lines in length), you do both of the following: 

 

 a) Give prominent notice with each copy of the object code that the 

 Library is used in it and that the Library and its use are 

 covered by this License. 

 

 b) Accompany the object code with a copy of the GNU GPL and this license 

 document. 

 

 4. Combined Works. 

 

 You may convey a Combined Work under terms of your choice that, 

taken together, effectively do not restrict modification of the 

portions of the Library contained in the Combined Work and reverse 

engineering for debugging such modifications, if you also do each of 

the following: 

 

 a) Give prominent notice with each copy of the Combined Work that 

 the Library is used in it and that the Library and its use are 

 covered by this License. 

 

 b) Accompany the Combined Work with a copy of the GNU GPL and this license 

 document. 

 

 c) For a Combined Work that displays copyright notices during 

 execution, include the copyright notice for the Library among 
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 these notices, as well as a reference directing the user to the 

 copies of the GNU GPL and this license document. 

 

 d) Do one of the following: 

 

  0) Convey the Minimal Corresponding Source under the terms of this 

  License, and the Corresponding Application Code in a form 

  suitable for, and under terms that permit, the user to 

  recombine or relink the Application with a modified version of 

  the Linked Version to produce a modified Combined Work, in the 

  manner specified by section 6 of the GNU GPL for conveying 

  Corresponding Source. 

 

  1) Use a suitable shared library mechanism for linking with the 

  Library. A suitable mechanism is one that (a) uses at run time 

  a copy of the Library already present on the user's computer 

  system, and (b) will operate properly with a modified version 

  of the Library that is interface-compatible with the Linked 

  Version. 

 

 e) Provide Installation Information, but only if you would otherwise 

 be required to provide such information under section 6 of the 

 GNU GPL, and only to the extent that such information is 

 necessary to install and execute a modified version of the 

 Combined Work produced by recombining or relinking the 

 Application with a modified version of the Linked Version. (If 

 you use option 4d0, the Installation Information must accompany 

 the Minimal Corresponding Source and Corresponding Application 
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 Code. If you use option 4d1, you must provide the Installation 

 Information in the manner specified by section 6 of the GNU GPL 

 for conveying Corresponding Source.) 

 

 5. Combined Libraries. 

 

 You may place library facilities that are a work based on the 

Library side by side in a single library together with other library 

facilities that are not Applications and are not covered by this 

License, and convey such a combined library under terms of your 

choice, if you do both of the following: 

 

 a) Accompany the combined library with a copy of the same work based 

 on the Library, uncombined with any other library facilities, 

 conveyed under the terms of this License. 

 

 b) Give prominent notice with the combined library that part of it 

 is a work based on the Library, and explaining where to find the 

 accompanying uncombined form of the same work. 

 

 6. Revised Versions of the GNU Lesser General Public License. 

 

 The Free Software Foundation may publish revised and/or new versions 

of the GNU Lesser General Public License from time to time. Such new 

versions will be similar in spirit to the present version, but may 

differ in detail to address new problems or concerns. 

 

 Each version is given a distinguishing version number. If the 
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Library as you received it specifies that a certain numbered version 

of the GNU Lesser General Public License "or any later version" 

applies to it, you have the option of following the terms and 

conditions either of that published version or of any later version 

published by the Free Software Foundation. If the Library as you 

received it does not specify a version number of the GNU Lesser 

General Public License, you may choose any version of the GNU Lesser 

General Public License ever published by the Free Software Foundation. 

 

 If the Library as you received it specifies that a proxy can decide 

whether future versions of the GNU Lesser General Public License shall 

apply, that proxy's public statement of acceptance of any version is 

permanent authorization for you to choose that version for the 

Library. 

 

 

Copyright (c) 2003-2006, Joe Walnes 

Copyright (c) 2006-2007, XStream Committers All rights reserved. 

 

Redistribution and use in source and binary forms, with or without 

modification, are permitted provided that the following conditions are met: 

 

Redistributions of source code must retain the above copyright notice, this 

list of 

conditions and the following disclaimer. Redistributions in binary form must 

reproduce the above copyright notice, this list of conditions and the 

following disclaimer in the documentation and/or other materials provided 

with the distribution. 
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Neither the name of XStream nor the names of its contributors may be used to 

endorse or promote products derived from this software without specific prior 

written permission. 

 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" 

AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 

IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE 

ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE 

LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 

CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 

SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR 

BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER 

IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) 

ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 

POSSIBILITY OF SUCH DAMAGE. 

 

 

This software module was originally developed by Raphaël Grosbois and 

Diego Santa Cruz (Swiss Federal Institute of Technology-EPFL); Joel 

Askelöf (Ericsson Radio Systems AB); and Bertrand Berthelot, David 

Bouchard, Félix Henry, Gerard Mozelle and Patrice Onno (Canon Research 

Centre France S.A) in the course of development of the JPEG2000 

standard as specified by ISO/IEC 15444 (JPEG 2000 Standard). This 

software module is an implementation of a part of the JPEG 2000 

Standard. Swiss Federal Institute of Technology-EPFL, Ericsson Radio 

Systems AB and Canon Research Centre France S.A (collectively JJ2000 

Partners) agree not to assert against ISO/IEC and users of the JPEG 

2000 Standard (Users) any of their rights under the copyright, not 

including other intellectual property rights, for this software module 

with respect to the usage by ISO/IEC and Users of this software module 

or modifications thereof for use in hardware or software products 

claiming conformance to the JPEG 2000 Standard. Those intending to use 

this software module in hardware or software products are advised that 
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their use may infringe existing patents. The original developers of 

this software module, JJ2000 Partners and ISO/IEC assume no liability 

for use of this software module or modifications thereof. No license 

or right to this software module is granted for non JPEG 2000 Standard 

conforming products. JJ2000 Partners have full right to use this 

software module for his/her own purpose, assign or donate this 

software module to any third party and to inhibit third parties from 

using this software module for non JPEG 2000 Standard conforming 

products. This copyright notice must be included in all copies or 

derivative works of this software module. 

 

Copyright (c) 1999/2000 JJ2000 Partners. 

 

/* ==================================================================== 

 * The Apache Software License, Version 1.1 

 * 

 * Copyright (c) 2000 The Apache Software Foundation. All rights 

 * reserved. 

 * 

 * Redistribution and use in source and binary forms, with or without 

 * modification, are permitted provided that the following conditions 

 * are met: 

 * 

 * 1. Redistributions of source code must retain the above copyright 

 * notice, this list of conditions and the following disclaimer. 

 * 

 * 2. Redistributions in binary form must reproduce the above copyright 

 * notice, this list of conditions and the following disclaimer in 
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 * the documentation and/or other materials provided with the 

 * distribution. 

 * 

 * 3. The end-user documentation included with the redistribution, 

 * if any, must include the following acknowledgment: 

 *  "This product includes software developed by the 

 *  Apache Software Foundation (http://www.apache.org/)." 

 * Alternately, this acknowledgment may appear in the software itself, 

 * if and wherever such third-party acknowledgments normally appear. 

 * 

 * 4. The names "Apache" and "Apache Software Foundation" must 

 * not be used to endorse or promote products derived from this 

 * software without prior written permission. For written 

 * permission, please contact apache@apache.org. 

 * 

 * 5. Products derived from this software may not be called "Apache", 

 * nor may "Apache" appear in their name, without prior written 

 * permission of the Apache Software Foundation. 

 * 

 * THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED 

 * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 

 * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 

 * DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR 

 * ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 

 * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT 

 * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF 

 * USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 

 * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, 
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 * OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT 

 * OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF 

 * SUCH DAMAGE. 

 * ==================================================================== 

 * 

 * This software consists of voluntary contributions made by many 

 * individuals on behalf of the Apache Software Foundation. For more 

 * information on the Apache Software Foundation, please see 

 * <http://www.apache.org/>. 

 * 

 * Portions of this software are based upon public domain software 

 * originally written at the National Center for Supercomputing Applications, 

 * University of Illinois, Urbana-Champaign. 

 */ 

 

Copyright (c) 2007-2010 javagraphics, Jeremy Wood. All rights reserved. 

 

Redistribution and use in source and binary forms, with or without modification, are permitted provided 

that the following conditions are met: 

• Redistributions of source code must retain the above copyright notice, this list of conditions and 

the following disclaimer. 

• Redistributions in binary form must reproduce the above copyright notice, this list of conditions 

and the following disclaimer in the documentation and/or other materials provided with the 

distribution.  

• Neither the name of javagraphics nor the names of its contributors may be used to endorse or 

promote products derived from this software without specific prior written permission. 
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THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY 

EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL 

THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 

PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 

INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 

LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 

THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

 

Copyright (c) 2005-2010 Substance, Kirill Grouchnikov. 

Redistribution and use in source and binary forms, with or without modification, are permitted provided 

that the following conditions are met: 

• Redistributions of source code must retain the above copyright notice, this list of conditions and 

the following disclaimer. 

• Redistributions in binary form must reproduce the above copyright notice, this list of conditions 

and the following disclaimer in the documentation and/or other materials provided with the 

distribution.  

• Neither the name of JGoodies Karsten Lentzsch nor the names of its contributors may be used 

to endorse or promote products derived from this software without specific prior written 

permission. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY 

EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL 

THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 

PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 

INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 

LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 

THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 


